[Webinar] Streamline your web hosting managementRegister Today

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 226
  • Last Modified:

Linux email problem

I installed a inux mail server on my server

Usinf Fedora 4

I had problems sending email from an outside address which seems to be taking care of but now when I try

to send a reply to the out side address I get

Your message did not reach some or all of the intended recipients.

      Subject:      RE:
      Sent:      4/2/2006 10:14 AM

The following recipient(s) could not be reached:

      'Andrew Renolds' on 4/2/2006 10:14 AM
            554 <andrew@xxxxxx.com>: Relay access denied

I am using postfix any ideas
0
arahming
Asked:
arahming
1 Solution
 
ahoffmannCommented:
you need to ask the admin of the SMTP relay you configured how to use that server, probably you need to authenticate or the relay needs to allow access from your server
0
 
arahmingAuthor Commented:
I'm confused I had exchange set up last week and everything worked fine. I installed linux and now the box recieves but will not send...

I am a Linux novice....
0
 
xDamoxCommented:
Hi,

How are you sending that email? is their a user connecting in remotly and sending it? what mail server are you using?
0
Never miss a deadline with monday.com

The revolutionary project management tool is here!   Plan visually with a single glance and make sure your projects get done.

 
mjoachiamiakCommented:
You must have mail relying enabled in your server configuration. For most servers it is off by default. Write what is the name of your server. It it's postfix I can give my configuration file for checkout.
0
 
Cyclops3590Commented:
In postfix, there are various way to allow users to use your email server for sending.  The most common is permit_mynetworks.  Where any network declared in the mynetworks parameter are allowed.  If your IP isn't in one of those approved networks, then you must be allowed another way.  I use permit_sasl_authenticated as my secondary authentication.  This means  you need to setup server authentication on the client as well.  If you wish to use SMTP AUTH as an approval mechanism you need to setup a few items

cd /etc/postfix
mkdir sasl
vi smtpd.conf

smtpd.conf contents
--------------------------------------
mech_list:         plain login
pwcheck_method:    saslauthd
log_level:      3
-----------------------------------------
You can have other auth mechanisms listed, but for Outlook you need those two. Other would be cram-md5 and digest-md5 etc.
Now you need to make sure that saslauthd daemon is installed and running.
Now in /etc/sysconfig/saslauthd, you should have
----------------------------------------------------
# $Id: saslauthd.sysconfig,v 1.1 2001/05/02 10:55:48 wiget Exp $
# Authentications mechanism (for list see saslauthd -v)
SASL_AUTHMECH="shadow"

# Hostname for remote IMAP server (if rimap auth mech is used)
# Ldap configuration file (if ldap auth mech is used)
SASL_MECH_OPTIONS=

# Extra options (for list see saslauthd -h)
SASLAUTHD_OPTS=
-----------------------------------------------------------
the SASL_AUTHMECH needs to be shadow.  This mech just makes it easier because it will use the system shadow file for authentication.
So long as your /var/spool and the /var/lib directories are on the same partition this will work.  saslauthd creates a hard link file for postfix to use to check with saslauthd different credentials.  hard links cannot be created cross partition so thus won't work.

If this isn't the way you want to go let us know.  But for remote users, this is what I recommend.  And once you get that working you should configure SSL usage
0
 
arahmingAuthor Commented:
Anyway I attempted whats listed above to no avail I am still getting the error was going to try pop before smtp but that doesn't seem to work either web mail works great. I am starting to understnad why you pay so much for exchange take 1/2hour to confiure this is going on two weeks
0
 
paullamhkgCommented:
try add the domain into your access database, normally it's in /etc/mail

edit the access file as below

xxxxxx.com         relay

after add the above line run makemap hash access.db<access.   <----- this will write what you add into the access database

after that try again.
0

Featured Post

Never miss a deadline with monday.com

The revolutionary project management tool is here!   Plan visually with a single glance and make sure your projects get done.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now