?
Solved

Cisco 1700 Routing with dual ethernet and RIP

Posted on 2006-04-02
3
Medium Priority
?
814 Views
Last Modified: 2011-09-20
I am trying to setup RIP on a couple Cisco 1700's using the 10/100 ethernet ports and WIC's with ethernet as well. I got everything working and can ping through using a /24 (255.255.255.0) subnet mask...all set ...

Then if I change the internal subnet masks for the private LAN's to a /16 mask .... I lose connectivity and if I do a

-> sh IP protocols    the routing table shows no entries..... change it back to a /24 and everything goes back to full functionality....

Thought maybe RIP had some sort of issues with other subnets, but that makes no sense.....

figured i'd post and see if anyone had any experiance with this ....

Router 1
LAN intFast0 10.80.1.1  /16
WAN IFeth0 10.1.10.80 /24

Router 2
LAN intFast0 10.50.1.1  /16
WAN IFeth0 10.1.10.50 /24

config is:

interface Ethernet0
 ip address 10.1.10.80 255.255.255.0
 half-duplex
!
interface FastEthernet0
 ip address 10.80.1.1 255.255.255.0
 speed auto
!
router rip
 network 10.0.0.0
!
ip classless
no ip http server
!
access-list 101 permit icmp any any
access-list 101 permit ip any any
!
line con 0
 exec-timeout 5 0
line aux 0
line vty 0 4
 password brandywine
 login
!        
end
0
Comment
Question by:brandywine
1 Comment
 
LVL 20

Accepted Solution

by:
calvinetter earned 2000 total points
ID: 16357227
I assume you're using RIP only because some non-Cisco devices need to share RIP routing info?  If not, & you're strictly using Cisco routers, do yourself a favor & use EIGRP instead, which is a far superior routing protocol.
  If you must use RIP, try this on all routers involved:
router rip
version 2
no auto-summary
  On every interface you want to share RIP routing info, do this:
interface <name>
 ip rip receive ver 2
 ip rip send ver 2

  If you instead want to use EIGRP, you can do this on all routers:
no router rip
router eigrp 10  <- must use same autonomous system # on all routers you want to share EIGRP info
no auto-sum
network 10.0.0.0  <- only need this entry if all subnets fall into this range

For further reading (IOS 12.2):
  http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/fiprrp_r/index.htm

cheers
0

Featured Post

New feature and membership benefit!

New feature! Upgrade and increase expert visibility of your issues with Priority Questions.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I have seen some questions on problems with SSH/telnet access to Cisco routers that may occur despite the fact that from a PC connected to your LAN, Internet connectivity is in place and users can access Internet sites without any issues.  There are…
I recently attended Cisco Live! in Las Vegas, a conference that boasted over 28,000 techies in attendance, and a week of hands-on learning hosted by a solid partner with which Concerto goes to market.  Every year, Cisco displays cutting-edge technol…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

840 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question