Non-Administrator User cannot release/renew IP-address

I'm running a wireless lan under WinXP (SP2) using the SMC WLAN driver and configuration software (WZC disabled). Windows automatically added the Aegis Protocol for WPA working correctly. Unfortunately frequent disconnects occur.

When using an Administrator account, the wlan-nic automatically reconnects.
But when logged in as a regular "User", they don't seem to be able te renew their IP address. Trying to renew manually (e.g. using I get an error message.

How can I give the regular users the right to release/renew the IP address ?

Best regards,

Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Normally when you restart the machine, it will obtain the IP address automatically even before you login.
Does it renew when you restart your machine? Try adding the user as a power user (if that is acceptable for you) and try to use:
1) ipconfig /release  (will release the IP)  
2) ipconfig /reneaw  (will renew)
joeblack_2kAuthor Commented:
When starting the machine, the user first gets an IP. But at one point the user cannot ping any other address in the LAN anymore. I think this point of time is when there is a disconnect within the wlan connection. I got this conclusion by comparing with a login using an Adminstrator account.  

The Administrator gets short periods of time where the IP-Address is listed as "". Shortly after this, the correct IP address is being listed again.

For security reasons, I don't want to give users the rights of "Power users".
Am I only able to release/renew having Power user rights ?
How about disable /enable the WLAN connection?
Or just Disconnect/Reconnect the WLAN profile? These are the same.

How does the disconnect's happen? I think that you need to solve this problem first.
In case that disconnect happens and ipconfig /renew solves it - then may be you need to set the WLAN settings to make the DHCP Lease time longer - like 24 hours or something or longer.

I solved it like this on my WLAN router.
What were the top attacks of Q1 2018?

The Threat Lab team analyzes data from WatchGuard’s Firebox Feed, internal and partner threat intelligence, and a research honeynet, to provide insightful analysis about the top threats on the Internet. Check out our Q1 2018 report for smart, practical security advice today!

joeblack_2kAuthor Commented:
Under Win XP SP1 disconnects happend when Windows showed "Multiple networks available". Therefore I disabled WZC under SP2 and go with the SMC drivers/tools.

This way, I don't get the message for multiple wlan networks anymore.
Instead the response time for pings are awefully bad (takes 1000-3000 msec).
Also, I get lots of time outs.

Just Disconnecting and Reconnecting does not fix the problem. I'm staying in "acquiring network address" and after some time, I get an automatically set private IP by XP. DHCP lease time is one week.
Therefore I already change to a static IP address, but this only show the timeout issues I already mentioned.

Nevertheless, can you confirm, that a regular "User" cannot release/renew IP address ? (Only possible with power users and above ?)

Sorry, can't confirm that.
Also, I don't understand how do you intend to solve the problem with release and renew if u get a timeout on DHCP request.

Response time of 2 seconds for ping can be: signal block, signal interference...
Maybe access to certain files is screwing you up. Try giving the account(s) Power User access.

Control Panel > Performance and Maintenance > Administrative Tools > Computer Management

On the left side, go to Local Users and Groups, then Groups

On the right side, you should see all of the groups on your computer. Choose the Power Users group. Click Add, and add all of the accounts you should give access to. That would work best for you.

The standard XP accounts are too restrictive and sometimes will cause too many headaches, so user this backdoor approach. Should fix you up.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
The other option might actually be letting Windows manage the wireless connection. Your SMC software might be the thing that's standing in the way. The software may touch system files that User accounts can't touch.
I thought I also asked to add as a power user and try :)
doesn't matter.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Wireless Networking

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.