Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
?
Solved

Serv-U FTP server permissions problems

Posted on 2006-04-03
8
Medium Priority
?
2,392 Views
Last Modified: 2013-11-29
Serv-U v6.1
XP Pro SP2
Windows Firewall enabled (exception on port 2121)
Linksys Wireless router (port forwarding on port 2121)




This is the error I am getting while trying to access the FTP server from outside the router:


An error occurred opening that folder on the FTP server.  Make sure you have permissions to access that folder.

Details:
Operation timed out





Now, when I try to hit the server from the outside (with a laptop) and simultaneously look at the server (on the desktop PC) to see what the logs say, it shows that I am logged in.  But, it never actually shows any folder.  The little flashlight just keeps searching and searching until it times out.  I thought this might be a firewall issue, but since Serv-U shows me as being logged in I am a little confused.

Is it safe to say that this is no longer a network issue, and really is a permission/file path issue?


0
Comment
Question by:quicksilver98
8 Comments
 
LVL 67

Expert Comment

by:sirbounty
ID: 16361206
I've found that forwarding 20-21 works best...try that under linksys & xp's firewall...
0
 
LVL 17

Expert Comment

by:Dushan De Silva
ID: 16361963
Please check your ftp protocol timeout at FTP server.

BR Dushan
0
 

Author Comment

by:quicksilver98
ID: 16363362
The timeout is set to 300 seconds from what I can tell.  I actually just changed everything back to port 21 and it didn't seem to make a difference.

Also, It doesn't seem to matter whether I am inside the router or not.  It is doing this on every machine I have tried, inside the network and out.
0
Free Backup Tool for VMware and Hyper-V

Restore full virtual machine or individual guest files from 19 common file systems directly from the backup file. Schedule VM backups with PowerShell scripts. Set desired time, lean back and let the script to notify you via email upon completion.  

 
LVL 13

Expert Comment

by:ScooterAnderson
ID: 16365063
Have you taken a look here??

http://www.rhinosoft.com/knowledgebase/KBArticle.asp?RefNo=1044&prod=su

Also, since you are seeing this inside your firewall,  check the Serv-U permissions on the default folder.  At minimum you need Read & List perms on the folder...

Scooter
0
 
LVL 67

Accepted Solution

by:
sirbounty earned 500 total points
ID: 16365901
quicksilver98 - in Linksys, forward ports 20-21.  In XP ICF, forward ports 20-21, in Serv-U, use port 21.
I have mine setup like this and it works fine...
I don't think it's permissions...
0
 

Author Comment

by:quicksilver98
ID: 16366035
I gotta admit, I was a little skepitcal on sirbounty's advice, but it turned out to be that simple.  Switching back to port 21 worked.  Why?  I have no idea, but it worked.  Very strange.

Thank you everyone for your help.
0
 
LVL 67

Expert Comment

by:sirbounty
ID: 16366546
It has to do with the type of FTP you're using...known as "Active FTP".
It uses the two ports, (the command & data port, as they're also known as) to setup and initiate the transmission.

Read more, if you're curious, here: http://slacksite.com/other/ftp.html
0
 

Author Comment

by:quicksilver98
ID: 16367392
Thank you sir.  That is a big help.  Especially for someone like me, who is new to the world of File Transfer Protocol.
0

Featured Post

Hire Technology Freelancers with Gigs

Work with freelancers specializing in everything from database administration to programming, who have proven themselves as experts in their field. Hire the best, collaborate easily, pay securely, and get projects done right.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article is a collection of issues that people face from time to time and possible solutions to those issues. I hope you enjoy reading it.
In this article I will be showing you how to subnet the easiest way possible for IPv4 (Internet Protocol version 4). This article does not cover IPv6. Keep in mind that subnetting requires lots of practice and time.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
In this brief tutorial Pawel from AdRem Software explains how you can quickly find out which services are running on your network, or what are the IP addresses of servers responsible for each service. Software used is freeware NetCrunch Tools (https…

580 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question