We help IT Professionals succeed at work.

We've partnered with Certified Experts, Carl Webster and Richard Faulkner, to bring you two Citrix podcasts. Learn about 2020 trends and get answers to your biggest Citrix questions!Listen Now


Cannot shrink log file 2 (sfs_genie_log) because all logical log files are in use.

Medium Priority
Last Modified: 2012-05-05
i am trying to run the following command, but am getting an error:


Cannot shrink log file 2 (sfs_genie_log) because all logical log files are in use.

How do I make the sfs_genie_log file not be in use? so that I can shrink it.

Watch Question

In query analyzer, change the pull-down, active DB, from SFS_GENIE, to "master" or something.


That didn't work. I ran a sp_who command to make sure that there are no open connections to the SFS_Genie database.

I also tried
dbcc shrinkfile( sfs_genie_log,1)
but that gave me the same message.
Top Expert 2011

do you have replication active on the database?

are there uncommitted transactions?

have you tried adding a new log file?
To solve this temporarily change the Recovery Model to Simple.  You should then be able to shrink.

Not the solution you were looking for? Getting a personalized solution is easy.

Ask the Experts


awesome, that worked. Thanks Sirees.
Thank you
Access more of Experts Exchange with a free account
Thanks for using Experts Exchange.

Create a free account to continue.

Limited access with a free account allows you to:

  • View three pieces of content (articles, solutions, posts, and videos)
  • Ask the experts questions (counted toward content limit)
  • Customize your dashboard and profile

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.


Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.