[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1638
  • Last Modified:

No DHCP on Latitude C400

Dell Latitude C400
Dell WLAN 1300 Wireless G Mini-PCI card
Windows XP SP2

Problem – Wireless hardware will only work using native Dell wireless utility. With Win XP managing connection, I can only get connectivity from wireless router, (green bars in systray) but cannot get DHCP IP address assigned on client. Have tried all usual remedies such as ipconfig /renew, /flushdns, etc. Also tried stopping/starting Win XP Wireless Zero Configuration service, uninstall/reinstall of Dell WLAN 1300 driver and have tried different driver versions.

I have also tried uninstalling and removing Dell mini-pci card and using Linksys cardbus wireless G card. Same result. Can only get DHCP assigned IP address using Linksys native utility.  

All other wireless clients at this location are working normally and nothing has been changed on wireless router. I do not use MAC address filtering and problem persists even with WEP encryption turned off at router.  

I would appreciate any suggestions. Thanks.


0
RRC_techsupport
Asked:
RRC_techsupport
  • 5
  • 5
  • 5
  • +1
1 Solution
 
tim_quiCommented:
Please download HijackThis 1.99.1
http://www.cyberanswers.org/forum/uploads/HijackThis1991.exe
Open Hijackthis, click "scan and save a logfile" don't fix anything yet, just upload the logfile created, go here and paste your Hijackthis log, http://www.rafb.net/paste/
then at the bottom left corner click "paste"
Copy the address/url and post it here:

Or copy and paste the log at;
http://www.hijackthis.de/ 
and click "Analyse", "Save".  Post a link to the saved list here.
0
 
Wooky JackCommented:
What is your local area connections status showing you under the "Support" tab where you can repair the connection?  What ips is it giving you?

IP Address:
Subnet Mask:
Default Gateway:

And if you click on the "Details button below these options what information is it giving you there as well?
0
 
Wooky JackCommented:
Is the router password protected?

Do you have limited or no connectivity?

are you able to ping the laptop from other places?
0
A Cyber Security RX to Protect Your Organization

Join us on December 13th for a webinar to learn how medical providers can defend against malware with a cyber security "Rx" that supports a healthy technology adoption plan for every healthcare organization.

 
RRC_techsupportAuthor Commented:
Please see Hijack This log and other answers below:

Is the router password protected? YES

Do you have limited or no connectivity? YES.

are you able to ping the laptop from other places? NO

What is your local area connections status showing you under the "Support" tab where you can repair the connection?  What ips is it giving you?

(This system is still using the Linksys cardbus adapter.)

WITH THE LINKSYS UTILITY MANAGING THE WIRELESS CONNECTION:
Physical Address: 00-12-17-DB-D1-6A
IP Address: 192.168.0.106
Subnet Mask: 255.255.255.0
Default Gateway: 192.168.0.1
DHCP Server: 192.168.0.1
Lease Obtained: 4/4/2006 7:37:33 PM
Lease Expires: 4/5/2006 7:37:33 PM
DNS Server: 192.168.0.1
WINS Server:  


WITH WINDOWS XP MANAGING THE CONNECTION
Physical Address: 00-12-17-DB-D1-6A
IP Address: 169.254.130.151
Subnet Mask: 255.255.0.0
Default Gateway:
DNS Server:
WINS Server:

Logfile of HijackThis v1.99.1
Scan saved at 7:32:30 PM, on 4/4/2006
Platform: Windows XP SP2 (WinNT 5.01.2600)
MSIE: Internet Explorer v6.00 SP2 (6.00.2900.2180)

Running processes:
C:\WINDOWS\System32\smss.exe
C:\WINDOWS\system32\winlogon.exe
C:\WINDOWS\system32\services.exe
C:\WINDOWS\system32\lsass.exe
C:\WINDOWS\system32\svchost.exe
C:\WINDOWS\System32\svchost.exe
C:\WINDOWS\system32\spoolsv.exe
C:\Program Files\Symantec AntiVirus\DefWatch.exe
C:\Program Files\Common Files\Microsoft Shared\VS7DEBUG\MDM.EXE
C:\Program Files\Linksys\Wireless-G Notebook Adapter\NICServ.exe
C:\Program Files\Symantec AntiVirus\Rtvscan.exe
C:\WINDOWS\Explorer.EXE
C:\WINDOWS\system32\pctspk.exe
C:\Program Files\Synaptics\SynTP\SynTPLpr.exe
C:\Program Files\Synaptics\SynTP\SynTPEnh.exe
C:\PROGRA~1\SYMANT~1\VPTray.exe
C:\WINDOWS\system32\hkcmd.exe
C:\Program Files\CyberLink\PowerDVD\PDVDServ.exe
C:\Program Files\iTunes\iTunesHelper.exe
C:\Program Files\iPod\bin\iPodService.exe
C:\Program Files\QuickTime\qttask.exe
C:\Program Files\Common Files\Real\Update_OB\realsched.exe
C:\WINDOWS\system32\ctfmon.exe
C:\Program Files\Linksys\Wireless-G Notebook Adapter\Gcc.exe
C:\Program Files\Linksys\Wireless-G Notebook Adapter\OdHost.exe
C:\Program Files\HijackThis 1.99.1\HijackThis.exe


O2 - BHO: AcroIEHlprObj Class - {06849E9F-C8D7-4D59-B87D-784B7D6BE0B3} - C:\Program Files\Adobe\Acrobat 7.0\ActiveX\AcroIEHelper.dll
O2 - BHO: SSVHelper Class - {761497BB-D6F0-462C-B6EB-D4DAF1D92D43} - C:\Program Files\Java\jre1.5.0_06\bin\ssv.dll
O4 - HKLM\..\Run: [PCTVOICE] pctspk.exe
O4 - HKLM\..\Run: [SynTPLpr] C:\Program Files\Synaptics\SynTP\SynTPLpr.exe
O4 - HKLM\..\Run: [SynTPEnh] C:\Program Files\Synaptics\SynTP\SynTPEnh.exe
O4 - HKLM\..\Run: [vptray] C:\PROGRA~1\SYMANT~1\VPTray.exe
O4 - HKLM\..\Run: [IgfxTray] C:\WINDOWS\system32\igfxtray.exe
O4 - HKLM\..\Run: [HotKeysCmds] C:\WINDOWS\system32\hkcmd.exe
O4 - HKLM\..\Run: [RemoteControl] "C:\Program Files\CyberLink\PowerDVD\PDVDServ.exe"
O4 - HKLM\..\Run: [iTunesHelper] "C:\Program Files\iTunes\iTunesHelper.exe"
O4 - HKLM\..\Run: [QuickTime Task] "C:\Program Files\QuickTime\qttask.exe" -atboottime
O4 - HKLM\..\Run: [TkBellExe] "C:\Program Files\Common Files\Real\Update_OB\realsched.exe"  -osboot
O4 - HKCU\..\Run: [ctfmon.exe] C:\WINDOWS\system32\ctfmon.exe
O4 - Startup: Adobe Gamma.lnk = C:\Program Files\Common Files\Adobe\Calibration\Adobe Gamma Loader.exe
O4 - Global Startup: Adobe Reader Speed Launch.lnk = C:\Program Files\Adobe\Acrobat 7.0\Reader\reader_sl.exe
O4 - Global Startup: Wireless-G Notebook Adapter.lnk = C:\Program Files\Linksys\Wireless-G Notebook Adapter\Gcc.exe
O8 - Extra context menu item: E&xport to Microsoft Excel - res://C:\PROGRA~1\MICROS~2\OFFICE11\EXCEL.EXE/3000
O9 - Extra button: (no name) - {08B0E5C0-4FCB-11CF-AAA5-00401C608501} - C:\Program Files\Java\jre1.5.0_06\bin\ssv.dll
O9 - Extra 'Tools' menuitem: Sun Java Console - {08B0E5C0-4FCB-11CF-AAA5-00401C608501} - C:\Program Files\Java\jre1.5.0_06\bin\ssv.dll
O9 - Extra button: Research - {92780B25-18CC-41C8-B9BE-3C9C571A8263} - C:\PROGRA~1\MICROS~2\OFFICE11\REFIEBAR.DLL
O9 - Extra button: Messenger - {FB5F1910-F110-11d2-BB9E-00C04F795683} - C:\Program Files\Messenger\msmsgs.exe
O9 - Extra 'Tools' menuitem: Windows Messenger - {FB5F1910-F110-11d2-BB9E-00C04F795683} - C:\Program Files\Messenger\msmsgs.exe
O16 - DPF: {6414512B-B978-451D-A0D8-FCFDF33E833C} (WUWebControl Class) - http://v5.windowsupdate.microsoft.com/v5consumer/V5Controls/en/x86/client/wuweb_site.cab?1109025274859
O16 - DPF: {6E32070A-766D-4EE6-879C-DC1FA91D2FC3} (MUWebControl Class) - http://update.microsoft.com/microsoftupdate/v6/V5Controls/en/x86/client/muweb_site.cab?1138213434468
O20 - Winlogon Notify: igfxcui - C:\WINDOWS\SYSTEM32\igfxsrvc.dll
O20 - Winlogon Notify: NavLogon - C:\WINDOWS\system32\NavLogon.dll
O23 - Service: Adobe LM Service - Adobe Systems - C:\Program Files\Common Files\Adobe Systems Shared\Service\Adobelmsvc.exe
O23 - Service: Ati HotKey Poller - Unknown owner - C:\WINDOWS\system32\Ati2evxx.exe
O23 - Service: Symantec AntiVirus Definition Watcher (DefWatch) - Symantec Corporation - C:\Program Files\Symantec AntiVirus\DefWatch.exe
O23 - Service: InstallDriver Table Manager (IDriverT) - Macrovision Corporation - C:\Program Files\Common Files\InstallShield\Driver\11\Intel32\IDriverT.exe
O23 - Service: iPodService - Apple Computer, Inc. - C:\Program Files\iPod\bin\iPodService.exe
O23 - Service: NICSer_WPC54G - Unknown owner - C:\Program Files\Linksys\Wireless-G Notebook Adapter\NICServ.exe
O23 - Service: SAVRoam (SavRoam) - symantec - C:\Program Files\Symantec AntiVirus\SavRoam.exe
O23 - Service: Symantec AntiVirus - Symantec Corporation - C:\Program Files\Symantec AntiVirus\Rtvscan.exe




0
 
tim_quiCommented:
Try a physical reset of the router, near the antenna you'll find a hole, insert the tip of a pen in there until all the lights flash on the router.  You'll have to re-enter a password as the reset will set it back to default.
0
 
tim_quiCommented:
Here's a link to your analyzed hjt log; http://www.hijackthis.de/logfiles/3f93dd66459785b8c2bb326b1e1482a4.html

I would remove the linksys stuff from start up with hjt.
0
 
tim_quiCommented:
Take adobe out of start up too.
0
 
RRC_techsupportAuthor Commented:
Have already tried reseting the router. No improvement. Also, 3 other dell laptops with Win XP and wireless-g cards are working fine with it.

The Linksys stuff is running the wireless-g card. If I take it out, the card would stop working.

Not too worried about the Adobe stuff. Worst it could do is slow down boot-up time. This laptop has 512mb ram, so it's not an issue. Also, the user needs it to run Adobe programs.  

I am betting that this is some sort of OS or registry corruption. Problems started when I tried to change out the current router, a D-Link DI-624, to a Netgear WGT634U. I couldn't get this C400 laptop to work with the Netgear so I switched back to the  D-Link. Before the switch, the C400 worked correctly with WinXP managing the connection.
0
 
Wooky JackCommented:
I switched from my dlink to a 2wire gateway and had a problem getting dhcp.  

I finally figured out how to enable it on the router and restarted all computers on the network and refreshed the ips and was able to get an ip from the router.

The initial problem was my desktop had the physical IP from the ISP, while my laptop and roommate's desktop had router IPs which was preventing connectivity to the net.  

Probably has no relation, but sounds closely related.
0
 
RRC_techsupportAuthor Commented:
Well, it sounds related, but not the same. For the record, I tried reseting the router several times and it continues to work fine for the other wireless and wired clients connected to it. Only the Latitude C400 has a problem. And it has the problem with every wireless router it tries to connect to, not just this one. Also, for the record, the wired nic port on this unit works fine and gets DHCP with no problems. Anyone???
0
 
rindiCommented:
Then this is probably a bad mini pci card. Before replacing it, just make sure that the antennae cable is connected to the adapter.
0
 
RRC_techsupportAuthor Commented:
I already tried replacing the mini pci card. Also tried using a Linksys cardbus adapter. Same result each time - can't get DHCP address when using Win XP to manage wireless connection. Only get "Limited connectivity" (169.254.xxx.xxx). As for the antennae, the unit is getting a strong signal, no problem. I still suspect OS and/or registry corruption as the problem.  
0
 
Wooky JackCommented:
Try running this then connecting to the net.  This should cleant he registry of malicious entries and such.

http://www.ewido.net/en/download/
0
 
Wooky JackCommented:
RRC,

question, when you cmd/ipconfig all the computers/laptops connected with this router is there one that is just getting this IP: IP Address: 169.254.130.151 and no router ip?
0
 
tim_quiCommented:
0
 
RRC_techsupportAuthor Commented:
Well, I was saving a clean install as a last resort. I'm going to pop a Dell WinXP sp2 CD into the system and run "sfc/SCANNOW" first to see if it can fix anything. Thanks.
0

Featured Post

A Cyber Security RX to Protect Your Organization

Join us on December 13th for a webinar to learn how medical providers can defend against malware with a cyber security "Rx" that supports a healthy technology adoption plan for every healthcare organization.

  • 5
  • 5
  • 5
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now