setup can not find hard drive

Hi,
I have a Gateway Laptop and something happened during the weekend so it could not run Windows.
I put in some recovery CD (called Red Cd) and it asked for all the files to be deleted from the hard drive.
Now when I inserted the Windows XP Installation CD it gets stuck on Examining 57232 MB disk 0 at ID 0 on bus 0 on atapi.
Please, help
abobevaAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

David-HowardCommented:
Have you entered your BIOS to see if the hard drive is listed?
Do you have any hard drive led activity on the front of your pc? (Amber light usually)
0
antonafCommented:
Try cleaning the Windows XP CD with a damp cloth (white alcohol) then wipe it off with a dry cloth.  Same as you would with a PS2 CD that won't play.  I've seen this happen plenty of times and sometimes cleaning it off thouroughly does the trick.

Otherwise, try another XP CD if you have one

Hope this helps!
0
antonafCommented:
Also, make sure you are set to boot from CD by going into the BIOS, click F2 (or it may say something different - look at the screen when it first turns on and click the button it says for BIOS or setup configuration)

In the BIOS configuration look for boot options and make sure it is set to BOOT FROM CD
0
Cloud Class® Course: CompTIA Cloud+

The CompTIA Cloud+ Basic training course will teach you about cloud concepts and models, data storage, networking, and network infrastructure.

abobevaAuthor Commented:
David,
in the BIOS Main screen I have
IDE 0 Master: None
IDE 1 Master: QSI CD-RW
So I guess I can not see it in the BIOS.
0
abobevaAuthor Commented:
Hi,
It is setup to boot from CD and it is but it can not find a hard drive. The windows XP cd starts and I have a few cd's that are working on the other computer. So, after CD starts it writes a bunch of files and then it gets stuck.
Can I somehow try and repartition that hard drive since I can not even find it.
10x. I am totally lost here
0
David-HowardCommented:
Abobeva,
That's your problem then.
If the BIOS does not detect your hard drive you have no chance at a software installation.
If you have not altered your hard drives jumper settings (and you didn't mention that you did), then you may
be looking at a faulty hard drive. If you have ANY spare drive that you can connect to your system please do so and attempt an OS load. I'm assuming that you have verfied that all IDE cables and power connectors are seated correctly.
:-)
0
antonafCommented:
If I'm getting this right, the hard drive cannot be found by the BIOS.  In a case like this, the jumper settings should be checked and reseated on the physical hard drive.

But....

If it is a hard drive issue then I can't understand why the installation would begin and write a few files (where is it writing to ... if no hard drive is found), therefore the hard drive must be is being found.  Have you tried wiping the CD??  Try also wiping the CD drive (carefully)??  You'd be surprised how tedious this problem probably is.  I hope this helps!
0
abobevaAuthor Commented:
Well, the drive was on the same laptop and working until someone tried to install an I-pod. So the system started acting funky. So, can not really verify any cables since it is a laptop computer. Could this be a virus ? Is there any way I can try to access that drive since I am pretty sure it is not physically removed or broken.
0
antonafCommented:
You should be able to access that drive in 2 ways I know.

1.  Install another hard-drive as the master drive and slave the corrupt drive.  Start the computer and boot into the master drive.  Log in and then go to MY COMPUTER and look for the corrupt drive.  Grab all the files you need and put them in a new location.

2.  Download and burn a copy of Knoppix (http://knoppix.org) and boot from CD then grab the files.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
jrs_50Commented:
Was the drive working BEFORE you used "Red CD"?  You said "it asked for all files to be deleted... Now..."

Can you 'boot' with Red CD?  If so; what does IT say about the hard drive?  What IS Red CD?

0
abobevaAuthor Commented:
It is a Gateway driver CD. It is used as the first CD for system restore. It asked for all files to be deleted before you can proceed with windows installation. I deleted them and tried to proceed with windows installation but it always takes me back to "all files need to be deleted".
0
David-HowardCommented:
Antonaf,
The reason a software load would begin without the BIOS recognizing the drive is due to memory. I've began software installations and all appeared well until the software attempted to access the drive (formatting, etc.). That's when an incorrect configuration or faulty hardware rears its head.
Abobeva, I wouldn't think that a virus is your issue at this point.
Laptop: So we can pretty much rule out incorrect jumper settings. Maybe we rule out loose cabling as well. At least for now.
Please access the BIOS and tell me what the hard drive is set to. Meaning, is it set to Auto Detect, User defined, etc.?
:-)
0
abobevaAuthor Commented:
I get a few messages before it gives me language options. One of these is " unable to find a FAT or ... file system on drive C(it has an NTFS format).
Then when it starts it gives me : Your computer's file system appears to be protected with an NTFS format. If you still want to use this option you must first go back to the Main Menu and select option"1. Delete all files" before reinstalling windows.
0
abobevaAuthor Commented:
Bios has the following IDE 0 Master: None
IDE 1 Master: QSI CD-RW/DVD - Rom
I am not sure if IDE 0 Master is the hard drive.
0
David-HowardCommented:
IDE 0 is attempting to list the hard drive. I was curious as to if the setting for IDE 0 Master was set to Auto-Detect, User defined, etc. You could try resetting the defaults. Enter the BIOS and look for an F key that says something similar to "Reset defaults". It may be a key such as F2, etc. Reboot the system after this and see if the drive is detected. :-)
0
abobevaAuthor Commented:
I can not get past the date to and time to change anything on that IDE Master.
 I did Setup Defaults but the IDE 0 master is still none
0
antonafCommented:
!!!CAUTION!!!!
BEFORE YOU ATTEMPT TO RESET DEFAULTS MAKE SURE YOU HAVE NOT MADE ANY BIOS CHANGES OR INSTALLED ANY NEW HARDWARE


--  The reason a software load would begin without the BIOS recognizing the drive is due to memory. I've began software installations and all appeared well until the software attempted to access the drive (formatting, etc.). That's when an incorrect configuration or faulty hardware rears its head. ---

Then that would suggest a memory problem, if the error appears at the point stated by abobeva

I would suggest removing the hood on the box and checking the jumper settings as well as reseating the jumpers, cables, and power.

But....

If you are getting an error "unable to find a FAT or ... file system on drive C" then this tells me that it does see a hard drive (even though your BIOS config ... shows different).  Then you staed that it starts and gives an error "Delete all files before installing windows." ...again it tells me it sees something on the drive.  Therefore, I would try this if all else fails.  

Download the XP setup bootdisks
http://www.microsoft.com/downloads/details.aspx?FamilyID=55820edb-5039-4955-bcb7-4fed408ea73f&DisplayLang=en

You may also want to run fdisk and erase the drive IF YOU WANT A FRESH INSTALL AND DO NOT NEED ANY FILES FROM OFF THE DRIVE

If you need files from off the drive then I would suggest trying to remove those first with the above suggestions.

Good luck!
0
Juan OcasioApplication DeveloperCommented:
I would try to remove the drive and reseat it.  There may be something funky going on.  I don't think the ipod install caused it, I think it was a coincidence that it happened to bomb after that install.  When you power on the laptop, do you hear the drive at all?  Do you see the lights flicker for the harddrive?

jocasio
0
David-HowardCommented:
Jacasio, Good question about the front panel LED. I asked in the beginning and did not receive a reply.
0
venom96737Commented:
ide0 is your harddrive it always will be your harddrive showing 0 indicates that its not picking up the drive at all the reason for the fat messase is its not in fat format its in ntfs but a common install for factory crap is usually placed in fat format be4 the ntfs partition.  the reason for this error can be simple or tricky was there a thunder stom or a power surge of any sort I have on at home that a guy was trying to install a piece of hardware on caught a spark and the ide slot 1 will not pick up anything at all anymore solution was a new motherboard. being that this is a laptop it would really not be easy to open and get to the motherboard and unplug the ide cable and reinsert the cable to see if it might detect it that way so maybe you could try to look for an update to the bios online see if that helps but you must get the bios to detect that harddrive or it will never boot and reinstall it will be impossible because your computer right now thinks that there is nothing to write to but a cd drive.
0
ridCommented:
IDE 0 is the first (primary) hard drive on an IDE channel. In most cases... I think I've seen some systems using "1" and "2" instead of "0" and "1".

I am sure to repeat a lot of the things already said here, but anyway:

1. If the BIOS doesn't say anything about your IDE 0 drive, or says "None", BIOS can't find the drive. Some BIOS's allow you to tell them to autodetect or do settings manually; most laptops only have "Auto". If the drive is described as "None", it isn't there or isn't responding properly - it's shot, probably.

2. Install program comments aren't conclusive. BIOS is the most important part, as it is used for HD access in the first stages of boot. If it can't find the drive - no boot. Some install programs set up a RAM disk, so comments may very well be misleading.

3. Re-seat the HD, or try it in a desktop using an adapter, to get mor evidence either way.

4. You can try to access the HD by booting from a Knoppix CD, but if you're not going to install Linux, that may be helpful inasmuch as it could allow you to salvage data. To get windows to install properly, you need to resolve this hardware issue first.

/RID
0
antonafCommented:
Sorry wrong post
0
jrs_50Commented:
It could be too late but ignoring the Red CD issue and going back to the "something happened during the weekend" and keeping in mind that the system does not seem to be recognizing the hard drive:

Place the laptop on a level surface.  Lift the side that contains the hard drive (usually the front) about 2 finger widths from the surface.  Remove fingers so that system drops (hard).

Seems extremely odd, I know, BUT I have had it 'work' (twice).  Would have tried that first were it my laptop.  Scenario is disk head mechanism 'sticking'/'jammed' = no drive recognized.  The "jar" may break it loose.

Works best when problem first encountered.  Not sure of the scenario at this point.

Good luck.  Unsubscribing.  No time.
0
BLundahl1987Commented:
Do you have access to another laptop HD by chance.... just so that we can rule out the hard drive.

The other option would also be to plug your existing laptop hard drive into an enclosure to see if this is able to read it.  If it reads than there is a good chance that your problem is not your HD, but your system.

My reasoning:  I am trying to rule out whether or not the hard drive or maybe the hard drive controller has failed.
0
prasanna_lakkundiCommented:
It seems that your HDD have bad sectors on it. thats why it gets stuck while scanning. Please format the HD and install Win XP.
0
abobevaAuthor Commented:
Hi,
You guys are amazing. I am trying to format it but it does not find "c". So, I am going to try everything above and if the format starts I will do that too before installing XP.
Copied Setup Disk and it loaded everything in the laptop - where? I don't know.
Bios still does not see a hard drive.
Dropped the system. I do not know if that worked but now I am back to where I started.
Examining 57232 MD Disk 0 at ID 0 on bus 0 on atapi.
I do not have another laptop handy but I have a few desktop computers. However I am not sure how to attach this laptop to the desktop.
Thanks
Albena
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Operating Systems

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.