• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 263
  • Last Modified:

SQL Reporting Services - Parameter not being recognized in oracle 8

I setup the paramters via the report menu (via the file menu) and in the datasource parameter tab.  I also add in my sql in the where clause:

fieldname = @parameter_name

but everytime i run the report, i get an ora-01036 illegal variable name/number.

0
michael1174
Asked:
michael1174
  • 2
1 Solution
 
pbocanegraCommented:
into the TAB "DATA"

Write your SQL, in the where clause write your parameters with "?"

In the Top of TAB "DATA" where dataset name appears, there is "..." button. Press it.
Then start new form and press the parameters TAB.
In this form, associate the "?" with the Parameter value.
0
 
michael1174Author Commented:
Still can't get this working still.. in my SQL statement, my where clause has this:

COMPANY_NAME.WRITING_COMPANY_NAME = ?WRITING_COMPANY_NAME

in the parameters tab, it has:

name                                   value
------                                    ------
?WRITING_COMPANY_NAME  =Parameters!WRITING_COMPANY_NAME.Value

In the reports menu off of the file menu, it has:

Parameters:
WRITING_COMPANY_NAME
0
 
michael1174Author Commented:
Ahh, found it.. need to use a : instead of a ?
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now