?
Solved

WSUS scripting error when opening the page for the first time.

Posted on 2006-04-03
3
Medium Priority
?
235 Views
Last Modified: 2012-05-05
Whenever I load WSUS for the first time on my server in Internet Explorer, a scripting error appears, stating something in Banner.aspx hasn't loaded. If I refresh the page, it's fine. If I don't refresh the page, WSUS doesn't work full stop!

This has recently started happening since installing .NET Framework v2.0; could that be the cause?
0
Comment
Question by:DReade83
2 Comments
 
LVL 23

Accepted Solution

by:
TheCleaner earned 2000 total points
ID: 16366493
Based on what you are saying, it may be this:


Issue 12: If .NET Framework 1.0 or 2.0 is installed after WSUS is installed, the WSUS administrative console will not appear
This is caused by the fact that.NET Framework 1.0 is registered with IIS and that WSUS Server requires.NET Framework 1.1. To resolve this issue, open aspnet_regiis.exe and run the following commands, where website id is the value contained in the following registry key:

HKLM\Software\Microsoft\WindowsUpdateServices\Server\Setup\IISTargetWebsiteIndex

• %windir%\Microsoft.NET\Framework\v1.1.4322\\aspnet_regiis.exe -s W3SVC\<website id>\ROOT\ReportingWebService
 
• %windir%\Microsoft.NET\Framework\v1.1.4322\\aspnet_regiis.exe -s W3SVC\<website id>\ROOT\ClientWebService
 
• %windir%\Microsoft.NET\Framework\v1.1.4322\\aspnet_regiis.exe -s W3SVC\<website id>\ROOT\SimpleAuthWebService
 
• %windir%\Microsoft.NET\Framework\v1.1.4322\\aspnet_regiis.exe -s W3SVC\<website id>\ROOT\WSUSAdmin
 
• %windir%\Microsoft.NET\Framework\v1.1.4322\\aspnet_regiis.exe -s W3SVC\<website id>\ROOT\AdministrationWebService
 
• %windir%\Microsoft.NET\Framework\v1.1.4322\\aspnet_regiis.exe -s W3SVC\<website id>\ROOT\ServrSyncWebService
 
• %windir%\Microsoft.NET\Framework\v1.1.4322\\aspnet_regiis.exe -s W3SVC\<website id>\ROOT\DssAuthWebService
 
• %windir%\Microsoft.NET\Framework\v1.1.4322\\aspnet_regiis.exe -s W3SVC\<website id>\ROOT\Content
 


From here:  http://technet2.microsoft.com/WindowsServer/en/Library/4244109a-395a-4ff8-9989-ea55ab0964a31033.mspx
0
 

Author Comment

by:DReade83
ID: 16619148
Apologies, the solution was to reinstall WSUS, which worked. The closest comment goes to TheCleaner though.

Accepted.
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

The HP utility "HP Lights-Out Online Configuration Utility for Windows Server 2003/2008" could be of great use when it comes to remotely configure a HP servers ILO WITHOUT rebooting the server. We would only need to create and run scripts using thi…
I've always wanted to allow a user to have a printer no matter where they login. The steps below will show you how to achieve just that. In this Article I'll show how to deploy printers automatically with group policy and then using security fil…
this video summaries big data hadoop online training demo (http://onlineitguru.com/big-data-hadoop-online-training-placement.html) , and covers basics in big data hadoop .
Is your data getting by on basic protection measures? In today’s climate of debilitating malware and ransomware—like WannaCry—that may not be enough. You need to establish more than basics, like a recovery plan that protects both data and endpoints.…

850 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question