We help IT Professionals succeed at work.

We've partnered with Certified Experts, Carl Webster and Richard Faulkner, to bring you two Citrix podcasts. Learn about 2020 trends and get answers to your biggest Citrix questions!Listen Now

x

Adding memory gives BSOD's every 5 minutes

mjeet
mjeet asked
on
Medium Priority
298 Views
Last Modified: 2013-11-10
I have a ASUS board with AMD Athalon processor. The board has 3 memory slots and accepts max two DDR333 modules and max of 3GB memory. I already had a DDR333 512MB on board so I got two DDR266 512 modules. When I poped in the two modules everything booted fine and windows shows 1.5GB of memory but then I got a STOP ERROR (BSOD) and the computer reboot.

So then I downloaded MEMTEST and ran test on all three individually and everything went good. Then I poped all three in and ran MEMTEST and I got errors towards the end.

Any help would be appreciated.
Comment
Watch Question

Computer Integration Specialist
Commented:
incompatible memory

Not the solution you were looking for? Getting a personalized solution is easy.

Ask the Experts
CERTIFIED EXPERT
Top Expert 2010
Commented:
the best option is to run memory that is all the same (brand / type).  usually you are ok to run memory of different brands... but i would not mix speeds.  if you have DDR333mhz, you should add 333mhz memory, not 266.  mixing speeds can cause problems in some computers.
try look into the bios pages to see if there is any memory timing function. try to slow down the memory and see.
You are obviously fooled, like most people are, by the DDR266 and DDR333 memory specs.  These mean nothing for real performance compatibility.  Those numbers are marketing hype.  The REAL crucial feature of RAM speed compatibility is the CL (CAS).  If your MB chipset need CL 2.5 to work right, this error is exactly what you will get from CL3 ram -- its refresh is TOO SLOW for fast chipsets.  Please in future ignore the marketing numbers and look only to the CL speed of the RAM.  Most is CL3 these days, and it is too slow for fast chipsets like NVidia.  Nvidia will never work with CL3, regardless of 266-333, etc.
CERTIFIED EXPERT
Distinguished Expert 2019

Commented:
well, i had the same problem with identical memory sticks, and had to remove one.
Never found a cure : it works fine with 1 stick, and not with 2 x  512 MB sticks, both kingston, same model.
CERTIFIED EXPERT
Distinguished Expert 2019

Commented:
...a,d it was an ASROCK board (Asus too)
CERTIFIED EXPERT
Most Valuable Expert 2015
Commented:
Maybe your board doesn't support the memory like you want it to. Many boards have 3 slots, the first two often hold 2 memory banks each, and the 3rd may hold only 1 memory bank (total 5 memory banks). A single sided memory module would be 1 memory bank, a double-sided memory module two memory banks...

It is also possible one of your memory slots is bad. Run memtest with only one module, but test that module in every slot.
Also try cushioning your ram settings.

Manaully set the speed to 266mhz.

Also turn down the cas latencies, refresh, etc.

Author

Commented:
Here is the motherboard page specifying the memory requirements

http://www.asus.com/prog/spec.asp?m=a7v8x-x

I just plugged in the two DDR266 512's and removed the PC333 512 and went to bios and the memory timing shows auto and 333. And it is set to auto.

Author

Commented:
nevermind guys. my bad. I just figured out both the new modules are DDR333 single bank. For some reason I kept thinking that they were DDR266.
Access more of Experts Exchange with a free account
Thanks for using Experts Exchange.

Create a free account to continue.

Limited access with a free account allows you to:

  • View three pieces of content (articles, solutions, posts, and videos)
  • Ask the experts questions (counted toward content limit)
  • Customize your dashboard and profile

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.