We help IT Professionals succeed at work.

We've partnered with Certified Experts, Carl Webster and Richard Faulkner, to bring you two Citrix podcasts. Learn about 2020 trends and get answers to your biggest Citrix questions!Listen Now

x

Windows Server 2003 and Wyse S10 and Data Encryption error

Medium Priority
723 Views
Last Modified: 2008-01-09
Hello All,

Have a windows 2003 Server with plenty of terminal licenses.
Mix of Desktops and Wyse Terminals.

Server is newley installed.

All RDP sessions from a desktop are able to connect without a problem.

If you connect via a wyse terminal.  User can log in for a little (no specific time) and then gets kicked out.  The following error shows up in even viewer.

The RDP protocol component "DATA ENCRYPTION" detected an error in the protocol stream and has disconnected the client.

Have read the solutions on here and microsofts website ("The RDP Protocol Component "DATA ENCRYPTION" Detected an Error..." error message)

I have tried the following registry edit solution.  
1. Start Registry Editor.
2. Locate and then click the following registry subkey:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\TermService\Parameters
3. Under this registry subkey, delete the following values:
• Certificate
• X509 Certificate
• X509 Certificate ID

If you delete the above they just reappear.  If you delete just the values NO ONE can login via RPD/Terminal services.
Then have to restore registry for them to access.
 
4. Quit Registry Editor, and then restart the server.


HELP HELP.

So question is why are users via RDP on a desktop not having a problem, but wyse terminals getting kicked off and the Data Encryption error appears?  Anyone have a solution to resolve this problem.

If more details are needed let me know.
Comment
Watch Question

Commented:
hi friend,

configure  encrypts  data transfering to "low" as this article explain and check again.
http://technet2.microsoft.com/WindowsServer/en/Library/a92d8eb9-f53d-4e86-ac9b-29fd6146977b1033.mspx

Maheen

Not the solution you were looking for? Getting a personalized solution is easy.

Ask the Experts

Commented:
thanks for points,

Did you solved the problem..

can you say some words about the soluation ?

Maheen

Author

Commented:
What actually worked was changing the encryption option to compatible.

Scott
Access more of Experts Exchange with a free account
Thanks for using Experts Exchange.

Create a free account to continue.

Limited access with a free account allows you to:

  • View three pieces of content (articles, solutions, posts, and videos)
  • Ask the experts questions (counted toward content limit)
  • Customize your dashboard and profile

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.