Running Remote Desktop from network behind a Linksys router and modem.

Posted on 2006-04-03
Last Modified: 2013-12-14
I have a DSL subscription with a static IP assigned from my ISP. I use Linksys ADSL2MUE modem, WRT54GS wireless broadband router, and WMP54GS as the wireless PCI adaptors on 2 PCs running WinXP Pro and Win 2003. I have configured the router and the PCs with static IP addresses. I properly configured McAfee Personal Firewall and Windows Firewall to open and unblock port 3389 so I can use RDP to get through to one of my PCs. I believe I properly configured the router to unblock and forward port 3389 to an IP address of one of the PCs. I installed DynIP to be able to resolve PC name to get through while I am away, but unfortunately to no avail. When I try to resolve my PC name from within DynIP website, it fails and comes back with “port 3389 is blocked”. Can anyone help me have Remote Desktop my PC please?
Question by:EEhab
    LVL 33

    Accepted Solution

    Most of everything you have sounds fine.  Maybe it's me, but I can't figure out why you even have DynIP in use if you have DSL with a static IP address and you have static IP addresses on your internal network PCs.  I'm not sure why the PC name is even important to you when you have all of the static IP address information you need to make it all happen regardless of what the PC name is.

    The key should be the router port forwarding to that one internal static IP address and the enabling of Remote Desktop on that one PC so that it is ready to accept incoming requests.
    LVL 33

    Expert Comment

    BTW, you can try to Remote Desktop from your internal WinXP to your Win2003 Server, just to see if it's working as you think it should be within your internal network.  We are assuming it works at all without checking that it works within your own network from machine to machine.  [Or if the PC you are trying to get to is the WinXP one, try the same from the Win 2003 PC to it.]
    LVL 33

    Expert Comment

    Without even worrying about a PC name, when I come in from outside to get to one of my PCs, all I have to do is to type in my assigned external IP address that my ISP has given me.  That's it.  

    Once I have that done, the request is automatically assumed to use port 3389 and looks to my router at my home to see what internal IP address I have port 3389 assigned to.  If there is an active "port forwarding" setup in the router to get to an internal IP address, the request gets passed right through to my local PC and then looks to see that Remote Desktop has been enabled on that PC.  

    Assuming the firewall stuff has been setup to allow that to happen, the session will either log you in if you already had supplied the user name and password, or will ask you for a login name and password to get the session started.

    It works fine for me.
    LVL 12

    Expert Comment

    I agree, first though .. can you access the machine from another machine within the network to isolate your problem to router or pc machine config? This will also "Check" your pc config to be properly configured..

    what about the machine you are trying FROM the internet? is that firewalled?
    LVL 1

    Assisted Solution

    I have run into problems with macafee firewall for some unknown reason even after I punched a hole for port 3389 (Have seen this happen with norton also)
    I found that zoneAlarm worked great, and opened the port with no problem and has more features than macafee and norton ( )

    try connecting from within your local network, if no joy with this, try disabeling your firewalls and try again. If you connect after disabeling than the problem is with your firewall.
    if you can connect from interal network, then double check your router port-forwarding and static IP assignment for you internal network.

    also make sure you have enabled remote desktop and added the users you wish to have connect remotely (they must use passwords to log into computer)

    if you want to resolve your ip address from your isp to an easy to remember name try using no-ip, it's free and works great

    LVL 12

    Expert Comment


    Any luck here?
    LVL 9

    Expert Comment

    try or

    either will allow remote access and be safer, since they use port 80, and will go past firewalls.

    Good Luck,

    Featured Post

    How your wiki can always stay up-to-date

    Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
    - Increase transparency
    - Onboard new hires faster
    - Access from mobile/offline

    Join & Write a Comment

    This solves the problem of diagnosing why an internet connection is no longer working. It also helps identify the likely cause of the lost connection if the procedure fails to re-establish your internet connection. It helps to pinpoint the likely co…
    Sometimes you have to pull out old tricks to get a new firewall to work… While we were installing a new Sonicwall at a customers site we found that sites they were able to visit before were not working.  It seemed random and we could not understa…
    In this seventh video of the Xpdf series, we discuss and demonstrate the PDFfonts utility, which lists all the fonts used in a PDF file. It does this via a command line interface, making it suitable for use in programs, scripts, batch files — any pl…
    Access reports are powerful and flexible. Learn how to create a query and then a grouped report using the wizard. Modify the report design after the wizard is done to make it look better. There will be another video to explain how to put the final p…

    746 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    18 Experts available now in Live!

    Get 1:1 Help Now