• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 3948
  • Last Modified:

The Security certificate was issued by a company you have not chosen to trust.

I've gone through all of the many reponses on previous postings of this topic and they all more or less appear to be resolved by the questioner giving up and going to some non-IE solution. I hope you all can do better on this one.

I have a site: https://www.novatec-inc.com/appl/ar that always gives me the security alert message. The certificate is issued by Network Solutions. I've tried clicking on the 'View Certificate', 'Install Certificate', etc. many times and have tried installing the certificate letting the "Certificate Import Wizard" automatically selecting the certficate store and I've tried specifying 'Trusted Root Certification Authorities'. None of that works.

I've added https://www.novatec-inc.com to my trusted sites. All this accomplishes is to bring up an additional, absolutely idiotic, security alert message which says, "The current web page is trying to open a site in your Trusted Sites list. Do you want to allow this?" Wny NO! I put it in my trusted sites list because I like getting extra messages, not because I actually trust the site! Thanks IE for acting like I'm a freaking idiot! I don't even have the option on this dialog of NEVER SEEING THIS MESSAGE AGAIN! After I click on Yes, I get the "Security Certificate" alert message again. So now I'm getting two alerts before I can get to the web page.

So, how to I get rid of all these stupid messages? I'm using XP service pack 2 and IE 6.0 SP2.
0
jmarkfoley
Asked:
jmarkfoley
1 Solution
 
SaineolaiCommented:
Have you installed the intermediate certificates on the webserver?  The GTE CyberTrust Global Root CA and
Network Solutions CA.

They are available from network solutions at the following URL with instructions for many web servers.

http://www.netsolssl.com/support/install/index.php
0
 
Keith AlabasterCommented:
If you view the detail of the certificate, you will see there are alerts on the key. your system is doing its job by telling you that the certificate being proffered by Novatec has an issue. Also on the very front page of the certificate (select view) it states that the certificate can not be authenticated.

Bottom line, you cannot add an unauthenticated certificate to the certificates library.
regards
keith
0
 
jmarkfoleyAuthor Commented:
Saineolai - yes, I have installed the certificates on the web server.

keith_alabaster - OK, I believe you that I can't install an "unauthenticated" certificate to the certificates library. Why is it  unauthenticated? Why is Network Solutions not a trusted authority? I guess I still don't understand the basic problem.

0
Cyber Threats to Small Businesses (Part 2)

The evolving cybersecurity landscape presents SMBs with a host of new threats to their clients, their data, and their bottom line. In part 2 of this blog series, learn three quick processes Webroot’s CISO, Gary Hayslip, recommends to help small businesses beat modern threats.

 
SaineolaiCommented:
What platform is the webserver on operating system and webserver?  I still believe this is an issue with the certificate chain on the server.  Which stores did you add the certificates on the webserver?  If you ask the page from the webserver do you also get the invalid certificate warning?
0
 
jmarkfoleyAuthor Commented:
Saineolai: The platform is Linux 2.4.29 and the webserver is Apache 1.3.33

Yes, I get the security alert warning which you can see at the web site I mentioned above: https://www.novatec-inc.com/appl/ar

Once you click to 'proceed' it works and I don't see that message again until I close the browser and go there with a new browser instance.

I want to be able to make this warning go away! It is creating anxiety in my users.
0
 
SaineolaiCommented:
Which distriubtion of linux?  And when you access from the web server are you using the full url, rather than the local hostname or ip address.  As these will also cause certificate warnings due to hostname mismatch on the certificate.  
0
 
SaineolaiCommented:
Have you added the following lines to your httpd.conf with paths amended as appropriate?  Check the third in particular.  Verify that the path in each command points to a valid file.

SSLCertificateFile /etc/ssl/crt/yourdomainname.crt

SSLCertificateKeyFile /etc/ssl/crt/private.key

SSLCACertificateFile /etc/httpd/conf/ca-bundle/NetworkSolutionsCA.crt
0
 
jmarkfoleyAuthor Commented:
Great! That was it! My SSLCACertificateFile line was commented out in the httpd.conf file. When I uncommented it, specified the correct path and restarted apache, it work.

Thanks.
0
 
PandoraCommented:
Hi have added a similar plea for help on this error, but for Win 2008 IIs7 butonly when browsing with ie6!
http://www.experts-exchange.com/Security/Operating_Systems_Security/Windows/Q_24756746.html
Any help would be great pls!
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now