WIN 98 - Manual IP addressing -

Maybe it's just been a while since I've worked with a Win 98 system. . .



Here is the setup:

2 computers

1 Dell Dimension running windows 98 SE
1 Dell Precision 380 running XP SP2.

I need to get these two computer to talk to each other over a network - no internet acces, no servers - Peer to Peer

Setup the  Dimension with:
IP : 192.168.10.13, 255.255.255.0, 192.168.10.1, DNS 192.168.10.1  

Setup the 380 with:
IP: 192.168.10.10, 255.255.255.0, 192.168.10.1, DNS 192.168.10.1

The address 192.168.10.1 does not exist.

I cannot get the two computers to ping each other.

Both plugged in a Netgear FS108 eight port switch - both get link lights, both nics pass internal diags.

I thought that this should be it for a simple closed manually setup IP network?

Also the options to run NetBIOS over IP on win98 is greyed out.

Help please. . .
gpradminAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

sirbountyCommented:
For something like - don't use TCP/IP...use NetBeui...smaller, faster, easier to configure.
Win98 includes by default, but XP will require the cd (or you can download the two files you need)

http://support.microsoft.com/?id=301041
sirbountyCommented:
If you 'must' have TCP, for whatever reason, first of all, disable any firewalls for testing and see if it works.  XP's ICF may be blocking communication.  If that's the problem, you can set it up to allow an exception for File sharing and optionally, ICMP echo replies.

You don't need the DNS/Gateway entries either...
Irwin SantosComputer Integration SpecialistCommented:
Configure as follows

Dimension
192.168.1.100  IP
255.255.255.0 Subnet
192.168.1.1 gateway
192.168.1.1 dns

380
192.168.1.101 IP
255.255.255.0 Subnet
192.168.1.1 gateway
192.168.1.1 dns
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

muhalokCommented:
This is not an issue of gateway, since you connect both PCs to the switch and they are on the same subnet 192.168.10.x

I believe that the problem will be in WinXP SP2 internal firewall - it blocks ICMP (ping) by default).

Open Control Panel and look for Windows Firewall. Open it and configure the "Allow" for ICMP.

If you need more than ping - probably file access - configure WinXP SP2 firewall accordingly. Its pretty intuitive.
gpradminAuthor Commented:
I have already turned off the XP ICF from the XP control panel.

The reason I would like to use IP now is that as soonas the ISP is ready this network will have broadband internet access thru a network firewall.

But IP should work the way it is currently configured.
Irwin SantosComputer Integration SpecialistCommented:
have you applied my configuration?
sirbountyCommented:
You can still use IP for internet access, but P2P would use NetBeui...

Try this from each system and post your results:

Start->Run->Command <Enter>

Ping localhost <Enter>
Ping 127.0.0.1 <Enter>
Ping 192.168.10.xx (where xx=10 or 13 depending on the local system's IP)
Ping 192.168.10.yy (where yy=10 or 13 - the address of the remote system's IP)

sirbountyCommented:
irwinpks - how is your config any different?  It should work with the IP that is set already...
Irwin SantosComputer Integration SpecialistCommented:
@sirbounty... the 192.168.1 schema always worked for me, and I use that to model the networks that I setup.
muhalokCommented:
Try rebooting the Netgear switch. I had the same problem once after it fell on the floor - links wer e up and not connectivity.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
rfreestunCommented:
Hi
I've done this on my home network, and found I needed to have 3 things set up:
1) Both the XP box and Win98 box needed to be members of the same workgroup
2) Both need to have Microsoft Networking Client Installed
3) Both need File and print sharing turned on

I use a Netgear DG834 router as a DHCP server now, and can ping each (and several other) PCs, but remember the horrible situation of trying to join Win 95, Win 98 and 2000 PCs together over Coax. (Ethernet) - definitely needed the NetBui then, but not now.  IP works fine.

Hope this helps.
rfreestunCommented:
Sorry - I also meant to say you only need to specify the IP address and Subnet Masks to make the boxes on the same segment.  You shouldn't need gateway or dns addresses without a router.  I plug my laptop into the switch regularly and can access the other boxes from network Neighbourhood.
Irwin SantosComputer Integration SpecialistCommented:
@rfreestun.. #2 is the missing component..once we establish that both machines can ping. .apply this and we should all be good.
rfreestunCommented:
Are you sure both PCs are actively on the network.
From a command window (DOS Window) type ipconfig /all on the XP box, and winipcfg on the 98 box.  Do they both report as you expect.  Try pinging the network card on each.  Ping 127.0.0.1 to ensure the card is active.
You could also try adding the ip address for each into the ARP table of the other PC, and try pinging each other again.
Does Net View on each indicate the network is working - can you see the other box.
(Once they are both in the same Workgroup you should see the PCs in Netview).
maduropaCommented:
troubles will remain untill you have setup your router / firewall because you have a DNS setup, and there's nothing on that IP address.
This way the clients have nowhere to ask who their neighbors are, and what name corresponds to what IP address.
Like mentioned above, install the Netbios-protocol next to the IP-protocol, and have the clients in the same workgroup, also allow the XP-PC to be pinged, and if required, install sharing.
you can use the IP-setup like you have mentioned.
next, give it a few days or hours before the computers finally can make propper contact, until they have learned about eachother.
You can also fill in the host file with the IP's and names of the computer, this should also help.

As soon as you have entered your router or firewall, he will act as the proper gateway for your network and smooth things up.

good luck
Irwin SantosComputer Integration SpecialistCommented:
@maduropa.. there is no router in this configuration.  only a switch
sirbountyCommented:
I'll have to disagree to that...if you want to establish where the systems are on your network, as previously suggested, simply add these lines to your hosts file (C:\Windows, by default in '98 and C:\windows\system32\drivers\etc by default in XP):

127.0.0.1             localhost
192.168.10.13      Dimension
192.168.10.10      380


DNS is not needed at all, especially if you're trying to ping by IP address...
maduropaCommented:
@irwinpks    I meant the router that will be placed in the future, the one that will be at 192.168.10.1 and will make the conenction to his broadband internet,

Irwin SantosComputer Integration SpecialistCommented:
ic
syamrajsrCommented:
Hello man,
Check the following please..
Make sure that you are using the right cabling method, not cross-cabling.
Use client for MS networks, File and Printer sharing and TCP/IP in both machines.
Just give IP address and Subnet mask, no gateway and no DNS.
Do not enable IEEE 802.1x authentication for this network in the X'P' machine.
If you have enabled firewall in XP, allow ICMP in the exceptions list.
Make sure that the computer names are different and workgroup name is same.
Please check these and revert.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Networking

From novice to tech pro — start learning today.