Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 164
  • Last Modified:

Validation Problems

Please see here:
http://validator.w3.org/check?uri=http%3A%2F%2Fwww.shekerra.com%2Ftest2%2Findex.html&charset=%28detect+automatically%29&doctype=Inline

I've tried everything but always run into this problem in a few templates with validation. I am wondering if there is a CSS way that I can manipulate this and still have it look the same? I've been on this problem for two days now and need some good answers or work arounds

In shekerra.css
#header-bgimage {
background: url("/picts/bluebar.gif");
background-repeat: repeat-x;
height: 18px;      
width: 125px;
}                this does not work!

What can I do to correct these errors?

TIA shek
0
GUEEN
Asked:
GUEEN
  • 5
  • 3
1 Solution
 
kevp75Commented:
your problme isn't in the CSS

most of it is right here:
<BODY BGCOLOR="#FFFFFF" background="picts/background-main.jpg" TEXT="#000000" LINK="#339966" VLINK="#663399" ALINK="#666666" leftmargin=0 rightmargin=0 topmargin=0 bottommargin=0 marginheight=0 marginwidth=0>

use css to do the margins, background image, backgrounbd color, font color, and link color for you, like this:

body {
        margin:0px;
        padding:0px;
        background:#FFFFFF url("picts/background-main.jpg";/*set whatever repeating you need*/
        color:#000000;
        }
a {
        color:#339966;
   }
a:visited {
            color:#663399;
             }
a:hover {
            color:#666666;
            }
0
 
kevp75Commented:
...sorry....and just make you body element <body>
0
 
kevp75Commented:
p.s.  this is just a start.  Looks like you have other invalid attributes in a table as well.  like the height attribute, etc....
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
GUEENAuthor Commented:
thanks for your help thus far - I only have one error now but the page looks funny in Firefox (looks ok in IE6) - I would like to get the page fixed and open a new question for the final error.
0
 
kevp75Commented:
ok.

Unfortunatly they are different page rendering engines, and sometimes if you use a blank image to get a table cell, or whatever sized correctly, firefox renders it as not even having the image.

I'm not sure if this is the case with yours, I can't see your code  :)
0
 
GUEENAuthor Commented:
I'll have to open up a new question - will do this in sequence!
0
 
kevp75Commented:
k.

Thanks for the grade  :)
0
 
GUEENAuthor Commented:
THANK YOU for resolving this! I have two more questions that I would like you to check out.

0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 5
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now