We help IT Professionals succeed at work.

We've partnered with Certified Experts, Carl Webster and Richard Faulkner, to bring you two Citrix podcasts. Learn about 2020 trends and get answers to your biggest Citrix questions!Listen Now

x

Solaris 10 x86 ftp JASS URGENT

kristian_gr
kristian_gr asked
on
Medium Priority
2,281 Views
Last Modified: 2013-12-21
Hi.
I've hardened my Solaris 10 using JASS, but I need to start the ftp server from time.
I've tried svcam enable network/ftp and this seames to start the ftp server?
using NETSTAT -a | grep LISTEN it now listen on the .ftp
I've added ftpd: ALL   to /etc/hosts.allow.
And I've disabled ipfilter, while I'm trying to be shure.

ftp localhost gives me:
ftp: connect to address ::1: Network is unreachable
Trying 127.0.0.1...
Connected to localhost.
421 Service not available, remote server has closed connection

and ftp from a remote host gives me theese messages in /var/adm/messages:
Apr  4 17:33:08 webserver inetd[238]: [ID 317013 daemon.notice] ftp[713] from 192.168.10.151 3084
Apr  4 17:33:08 webserver in.ftpd[713]: [ID 808958 daemon.warning] refused connect from 192.168.10.151 (access denied)

Any ide what I'm missing?
Comment
Watch Question

CERTIFIED EXPERT

Commented:
make sure that FTP is enable, check /etc/services and /etc/inetd.conf file and make sure that your firewall open for port 21.

Consider use secure ftp (sftp comes with openshh) instead od FTP, you can download it from:
http://sunfreeware.com/
CERTIFIED EXPERT

Commented:
are you using the ipf that's installed with solaris? or did you isntall afterwards? did you disable or just allow FTP? if you allowed FTP, re-HUP the fw process....not being able to connect via localhost on the box itself points to the service not being started on the box....

Commented:
ipf has nothing to do with this.  

I'm suspect of the /etc/ftpd/ftpaccess file.  Run the following:

# inetadm -l ftp | grep exec
         exec="/usr/sbin/in.ftpd -a"

Notice the -a is set.  Man page for in.ftpd says:

     -a              Enables use of the ftpaccess(4) file.

Man page for ftpaccess has the following entry:

     deny addrglob [message_file]

         Deny access to host(s) that match addrglob  and  display
         message_file.  If  the  value of addrglob is !nameserved
         access to sites without a working nameservers is denied.
         message_file  may contain magic cookies. See message for
         more details.

Check your /etc/ftpd/ftpaccess file for a "deny" statement.

Author

Commented:
# inetadm -l ftp | grep exec
gives me:
exec="/usr/sbin/in.ftpd -l -a"
-l should just be logging
ftpaccess has no deny statement
ftphost:   allow    ftp   *


XoF

Commented:
No comment has been added to this question in more than 21 days, so it is now classified as abandoned.
I will leave the following recommendation for this question in the Cleanup topic area:

PAQ - refund points

Any objections should be posted here in the next 4 days. After that time, the question will be closed.

-XoF-
EE Cleanup Volunteer
Commented:
PAQed with points refunded (500)

CetusMOD
Community Support Moderator

Not the solution you were looking for? Getting a personalized solution is easy.

Ask the Experts
Access more of Experts Exchange with a free account
Thanks for using Experts Exchange.

Create a free account to continue.

Limited access with a free account allows you to:

  • View three pieces of content (articles, solutions, posts, and videos)
  • Ask the experts questions (counted toward content limit)
  • Customize your dashboard and profile

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.