URGENT:The remote SMTP service rejected AUTH negotiation.

HELP! PLEASE!
I have read all the questions I can find on this problem and still can't get it to work.
I am running Exchange v6.5 on a 2003 SBS

I cannot get outgoing mail to be sent. It sticks in the Exchange SMTP queue.
I have checked the SMTP server smtp.btconnect.com, username and password by configuring Outlook Express on the server. It sends email straight away to my external web account.

Settings.
Protocols SMTP Default has no authentication it uses anonymous (my understanding is that this is overridden by the connectors setting). I have tried it with basic auth as well.

I have a configured SMTP connection that uses a smarthosts connector smt.btconnect.com
Local bridgehead connects the server to the SMTP default protocol.
Advanced Tab, nothing set apart from basic authentication using the username and password that I have tested.
Address space set to SMTP

AND IT STILL DOESN'T WORK....
Any help and especially a solution will be gratefully received.


I have also tried running the connect to the internet wizard from the management console.
I have stopped and started the queue.

(Sometimes, very strange, a couple of the emails pop through and get sent to my web account. But this only seems to happen when I have changed some settings.)

AndyYuleAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

SembeeCommented:
Have you told BT Internet which domain you are sending from? From past experience with them, they don't allow anyone to relay email through their servers, you have to phone them up and tell them which domain you sending emails "from". They then add it to their list and you can relay.

Simon.
AndyYuleAuthor Commented:
Yep, have already done that and tghey have confirmed that mail relaying is enabled for the domain. I have also tested it using Outlook Express from the server. It works fine on that connection.
SembeeCommented:
If you are getting auth errors then the server is rejecting the username and password that you have entered, or the format.
You haven't enabled TLS on the SMTP connector?

Simon.
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

AndyYuleAuthor Commented:
Unfortunately I can;t remote access the server right at the moment! Typical, don't know why. I'm sure that TLS was not enabled (it's an option on the advanced tab is it not?). Should it be enabled?
SembeeCommented:
Unless the ISP supports TLS (which I doubt whether BT do) then it should NOT be enabled.

Simon.
AndyYuleAuthor Commented:
The only thing that was set on the advance tab was the basic authentication. (My dynamic IP to the server seems to have gone a bit :( must get a static assigned to it. So I can't get access and check/change any settings at the moment.

Can you think of anything else I can check when I get access again? The fact that Outlook Express works without any problems seems very strange. Could it be anything to do with the DNS and somehow not being able to authenticate to the BT server? But I can ping their DNSs without any probs.
AndyYuleAuthor Commented:
That was a bit of luck.... The remote backup is running and that logged the IP address of the server. I now have remote access again and can check the settings. TLS is definately OFF
AndyYuleAuthor Commented:
I have just tried setting the properties for the Protocol SMTP Default both the Access tab (authentication button) and Delivery Tab (Outbound security button). Why does the Browse button allow you to select users from the local domain, this implies that this property, username and password are NOT the ones use to authenticate the SMTP outgoing mail on BT servers! Am I correct or not?
AndyYuleAuthor Commented:
According to a MS article I ran a telnet localhost 25 and then ehlo some of the responses were missing. If they are missing then it means a problem with Exchange - it didn't understand the rest of it... so I'm stuck if this is the case.

http://support.microsoft.com/kb/257265/

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
AndyYuleAuthor Commented:
Had to bite the bullet in the end and reinstall exchange. Followed instructions as per Q_21478576.html
Worked a treat - can go to bed now.

It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.