• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 668
  • Last Modified:

Shadow copy fails to run on schedule

Running Windows Server 2003 with SP1 - have shadow copy scheduled to run weekly on Friday nights.  It is a compressed drive, but that should not matter.  Every week it updates the schedule to the next week, but nothing else.  There has not been a shadow copy generated since it was scheduled many weeks ago (other than the manually generated one that is).  There are no error messages in the event viewer at the scheduled shadow copy run time.  When I run 'vssadmin list writers' all writers report Stable No error.
0
harkeninc
Asked:
harkeninc
  • 6
  • 5
1 Solution
 
TheCleanerCommented:
Did you setup the scheduled VSS and then promote/demote the box to a DC?  I remember there being an issue with that, where you just had to delete and recreate the shadow copies.

Inside task scheduler what does the log say in Advanced/View Log (at the top).
0
 
harkenincAuthor Commented:
This server is just a member server and has never been a DC.

I had never tried accessing the shadow copy task via control panel scheduler.  I always use the drive properties -> shadow copies tab which there by creates the scheduled task.  Just now when I tried to access the task via scheduler there was an error -
General page initialization failure
specific error is:
0c8007000d

Next when I respond OK to the error screen, the task opens.  The runas is empty and greyed out.  I believe the runas user is supposed to be NT AUTHORITY\SYSTEM

Thanks for your attention to my question.
0
 
TheCleanerCommented:
Yeah, it creates the task schedule when you go to the shadow copies tab, and places them in the Scheduler.

When you open the scheduler as opposed to opening the task, look at the log instead by clicking Advanced at the top, then choosing View Log.

Post any errors.


BTW, I just pulled up a server and did what you just described, and no errors, and the RUNAS isn't greyed out.


0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
harkenincAuthor Commented:
"ShadowCopyVolume{909fc763-f1fb-47b1-9ed7-7feb29779d56}.job" (vssadmin.exe) 4/5/2006 12:00:00 PM ** ERROR **
      The attempt to retrieve account information for the specified task failed; therefore, the task did not run. Either an error occurred, or no account information existed for the task.
      The specific error is:
      0x8007000d: The data is invalid.
0
 
TheCleanerCommented:
I would try removing the shadow copies and make sure they are gone from the scheduled tasks too, then recreate them.

Also, check these KB articles:

http://support.microsoft.com/default.aspx?scid=kb;en-us;822904

http://support.microsoft.com/default.aspx?scid=kb;en-us;884573
0
 
harkenincAuthor Commented:
I already had disabled and enabled shadow copies and did again now.  The task automatically deletes and recreates.  The articles don't seem to provide the solution because the 2003 server is not a dc and not xp.  It seems to me though that the system account is not working for the shadow copies.
0
 
TheCleanerCommented:
Does the VSS service show as running under the Local System account?
0
 
harkenincAuthor Commented:
VSS service is running and the "logon as" is set to local system account
0
 
TheCleanerCommented:
I'm at a loss.  You may try disabling the VSS copies again, then disable the service.  Then reinstall SP1.

Other than that, I don't want to keep guessing for you, so I'd suggest checking with MS or their managed newsgroups.
0
 
harkenincAuthor Commented:
Thanks for trying.  I remember that SP1 did claim to resolve some issues about shadow copies. If I ever do find a solution I'll try to post it here so you will know.  
0
 
TheCleanerCommented:
cool deal...I'll definitely add it to my bookmarks if you find something.
0
 
GranModCommented:
PAQed with points refunded (250)

GranMod
Community Support Moderator
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

  • 6
  • 5
Tackle projects and never again get stuck behind a technical roadblock.
Join Now