Where can I set the updateable property for a form item?

I wish to set the update allowed property for one of the form  items on my form to false  (code item) if  the value of another form item (type) is 'F' when the values are loaded from the record into the form. Where should I write this trigger? Would it be at the post-query block level ?
geeta_m9Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

riazpkCommented:
POST Query:

If BLOCK_NAME.item1  = 'F' then
SET_ITEM_INSTANCE_PROPERTY('BLOCK_NAME.ITEM_NAME',     SYSTEM.TRIGGER_RECORD,UPDATE_ALLOWED ,property_false);
END IF;


I supposed you want to set updateable property of BLOCK_NAME.ITEM_NAME on the basis of value of item BLOCK_NAME.item1. You will have to replace items names and block name.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
riazpkCommented:
A minor correction:

SYSTEM.TRIGGER_RECORD

should be

:SYSTEM.TRIGGER_RECORD
0
geeta_m9Author Commented:
What is the difference between set_item_property and set_item_instance_property? I tried using set_item_property in the post query trigger but it didn't work. i.e. it was still allowing update of the item. However, when I placed the set_item_property in the when-new-record-instance trigger, then it worked. I also set one of the form item's update_not_allowed property to false at the pre-form level as I do not want any user to enter a value in that form item. It works for records with values in it but  it will not work for new records, i.e. for a new (blank) record. How can I set update_not_allowed for that item for a new record?
0
geeta_m9Author Commented:
Never mind about the last part. I forgot I can set the property for the item in the property palette to insert and update not allowed.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Oracle Database

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.