You do not have sufficient permission to perform this operation on this object. -- Adding access to another users mailbox

Server Configuration is win2k3 SP1 with Exchange 2003 SP1.  User is using Outlook 2003.

I have two users created in active directory.  One user is tsmith and the other user is members.  I created members so that multiple people could view the email that comes into that account.  

First I went into active directory and opened 'members.'  I then granted mailbox rights to user 'tsmith.'  (delete, read, change, take ownership and full mailbox access)

I setup outlook for tsmith by adding 'members' to tsmith's profile.  (control panel, mail, email accounts, view or change email accounts, change, more settings, advanced tab, add)

The mail box is added to the profile.  I can view the email within the members email account.  I can open the email.  I cannot reply to the email or send.  I recieve the following error if I try:

You do not have sufficient permission to perform this operation on this object. See the folder contact or your system administrator.

The odd thing is I added the members email to another users account with the same rights as tsmith.  The user was able to reply to mail in the members inbox.  

I logged in as tsmith on 3 different machines and checked all of the setting son each machine to make sure that it was not the user workstation or outlook.  I have basically narrowed it down to ad or exchange.

If it is unclear what exactly I am trying to do I can post some screenshots if it would help.  

Thank you for your time.
CBIAAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

SembeeCommented:
You should have only granted "Full mailbox" rights to the folder. Nothing else. Full Mailbox should be used exclusively on its own - as it gives the rights required.

Therefore I would remove the account from the list and put it back in again, granting JUST full mailbox.
Once you have done that, on the Security tab, grant the user "Send As" permissions as well.

To summarise:

Two permissions only need to be granted.

Full Mailbox
Send As.

Nothing else.

Simon.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
CBIAAuthor Commented:
The user is re-added to the list, and has only full mailbox checked.

I however cannot find the 'security' tab to specify the 'send as' permission.  where exactly is that located?
SembeeCommented:
The Security tab isn't enabled by default. In ADUC, choose View, the Advanced features. Then go back in to the properties of the user and you should see the Security tab.
Again, enable JUST the Send As option - nothing else.

Simon.
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

CBIAAuthor Commented:
I found the security tab, and enabled 'Send As' only.

At this point only those two options are enabled.

I logged the user out and back in.  Unfortunately the same problem persists.  The user can view mail, read mail but cannot reply to a message.  I also tested it on my workstation as well and the same symptoms are occurring.

Any more information you might need to come to another resolution?
SembeeCommented:
You will need to wait.
Exchange caches permissions and these are only flushed and refreshed every two hours. The only way to get them to flush more frequently is to reboot the server.

Simon.
CBIAAuthor Commented:
I will post back here at 4:00PM PST and let you know if it worked.  Thanks for your help thus far.
CBIAAuthor Commented:
It now works!  Sembee if I lived in england I would gladly buy you a beer!  cheers!
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.