Cannot play audio CD's, sound on PC OK.

I'm working on an old eMachines PC (Cyrix 333 mhz, win 98SE).
This is wierd: the machine has sound, the CD-ROM plays games, applications, everything normal. When I try to play an audio CD (not copy, bought from store), CD player opens, and looks like it's 'playing' (the counter goes 01, 02, 03 secs, etc), but no sound comes out of the computer.
I have changed the CD-ROM, the audio cable, the data cable, the connection on the motherboard( this is built-in sound) has two ways or plugs for 3 or 4 pin connections (tried both), have tried different audio CD's. No luck, samo, samo.
So, is there a way to play an audio CD on this machine?, HOW???, re-installing Win98?, upgrading the O.S.?; I may do that, just wondering why it cannot play audio CD's right now.
TIA for any help, advice, input.
efrain12Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

nikpeglerCommented:
I ran into this issue not too long ago and solved it very simply.  Download Winamp at http://www.winamp.com.  If you don't want winamp, then you can find another multitude of media players online that will read the cds by default instead of Win98 CD Player.  I, personally, have had many many problems with Win98 CD Player even on a SoundBlaster Live! 5.1 LS.  Let me know if this helps any.

Niklaus.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
GinEricCommented:
My guess is that you have the cable in the wrong place.  That's because it says it's playing, and if it says it is and counting it, then it is playing it, you're just not hearing it.  This could be because you have an onboard sound chip and a sound card and the default is the onboard.  The connector for the onboard is on the cabinet, not at your soundcard output.

The CD and other devices can and often do have their own onboard sound chips and BIOS, which is picked off by most motherboard BIOS in the boot up process.  In fact, a voice modem will have such chips and BIOS, so will various DVD's.

If two or more BIOS fight it out, i.e., motherboard vs device, and motherboard wins in basic BIOS, but loses in Windows Operating System dectection, then one is seen as playing [input] and the other is seen as output.

If it's counting, it's playing it, you're just not hearing it.
0
haim96Commented:
in the volume control panel, goto option,make sure to select the proper mixer device
select playback mode. and the check all the volume control that relevent.
make sure that the cd player is not mute.

if it's all OK, check the cable again and the line-in (on board)

good luck!
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

jhanceCommented:
It's also possible that the audio circuits in the CD drive are faulty.  If the drive has a headphone jack on its front panel, try a headphone there when you have it in play mode.  If there is no sound there, then you can probably assume the drive is defective.  If there is sound, then the problem is likely in the cable, connector, sound input, or sound control panel settings.
0
efrain12Author Commented:
I have no sound card installed.
There are no IRQ conflicts.
 
0
jhanceCommented:
>>I  have no sound card installed.

Then _WHERE_ are you plugging the CD audio cable to?  I think you are mistaken but if you are right, then your expectation of sound from the CD is unreasonable.
0
GinEricCommented:
"I have no sound card installed.
There are no IRQ conflicts."

Proof?  Although I still think you're plugged into the wrong hole.

To make it simpler, get a Bar Graph VU and open it.  Then play something.  If it's on the bar graph, the onboard sound chip is playing!

http://xfx.net/index.htm

the demo will work, use Freq & Vol Meter and "What You Hear"  Although you may not hear it, if the meter "hears" it, it's there, which means, your cabling or routing of the sound signal is wrong.  This could even be an old or outdated driver, even in XP, definitely in Win98SE.

See if the signal is truly there first!


0
nikpeglerCommented:
Why go through all that difficulty when you can just download a media player off the Internet that you can set as default to play cd's instead of the Win98 CD-Player.  Honestly, if that is the only problem that you are encountering, I'd just go with the simplest solution.

Niklaus.
0
GinEricCommented:
nikpegler, I don't think you understood the question, he can't hear it playing, so another player downloaded from the internet shouldn't make a difference, particularly if the speaker is plugged into the wrong hole.
0
nikpeglerCommented:
At the header of the message he says that other sound is ok GinEric.  I don't even have an audio data cable between my mobo & cd-drive and the audio players work just fine on my system.  I open CD-Player and nothing, just like he's running into.

Niklaus
0
maramomCommented:
I vaguely recall having that same issue with Windows 95. It turned out to be a conflict between my HP scanner and the cd output. All sound was fine, except cd playing. Changing the resource settings for the scanner solved the problem. There was no conflict showing in device manager, however...it just happened to be a known issue.

If you want to try to troubleshoot for this as a possible issue..either post ALL specs of components and peripherals..
or
disable devices in device manager one by one, try to play a cd, and see if you find the culprit.
0
haim96Commented:
note that original music disk are playing via the audio cable becouse the cdrom drive itself
do all the procces and send the signal to audio device.
but if you play MP3 you will be able to hear it even if don't connect the audio cable
since the CPU is procces the file and deliver the signal to the audio device.
0
GinEricCommented:
"I don't even have an audio data cable between my mobo & cd-drive and the audio players work just fine on my system." yes because the sound is sent on the buss, whether it's IDE PCI whatever.

He does have to post his configuration.  Two ROM drives will also cause this problem, especially if one is a DVD.  Writers only complicate it.  There are various settings in writer properties that vary between CD and DVD as well.  The point is, however, that if it shows up on "the scope," then the problem is in the send path of the sound, not the device or driver or cabling, not even the buss.  It could be as simple as the device output, say direct from CD, is muted in Volume Control.

I guess we shouldn't assume that he's right clicked on Volume Control in systray and Open Volume Control then switched back and forth between Play and Record and made sure nothing is muted.  Try that.

0
chiingliangCommented:
2 way of solving this:
1. use digital playback as suggested (winamp etc)
2. check ur wiring on the mobo. Look closely and you will find the pcb thread have 1 thicker than the other 2. the thicker one is the GND wire. make sure the wiring is correct.

0
efrain12Author Commented:
Sorry I could not answer before.
Thanks to ALL replies, but the first one I tried (Winamp) worked. Better yet, this gave me the idea of removing Winamp and installing Windows Media Player ( I'm a Microsoft fan, sorry). I did work, as well. There's always something to learn in life.
Thanks again to all, including EE.

Efrain Portales
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Hardware

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.