Exchange 2003 POP3 Virtual Server does not restart

I noticed several other postings regarding the POP3 Service not starting after reboot.
Our server is having an issue with an open file agent causing the system to crash anywhere between once a day and once every few days.  So when it reboots, the virtual service does not restart automatically.
This is a major issue.
Is there a way to script it to restart and have the script check the service every hour or so?

Desperate...

Brian
LVL 2
brian_appliedcpuAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

jss1199Commented:
Hi brian_appliedcpu,

Use the script and proceduers below...

:BEGIN


set LOGFILE=POP3_Service.log
sc \\MAILSERVER query spooler > LOGFILE
grep "STOPPED" LOGFILE
if not errorlevel 1 goto error

:error
net send admin POP3SERVICE on MAILSERVER stopped, restarting
sc \\MAILSERVER start POP3SERVICE
now >> POP3_service.err
echo POP3 on SERVER stopped, restarting >> SERVER.ERR
end

Change the below variables in the script:

MAILSERVER = The server with the POP3 Service - 3 locations in script to change
POP3SERVICE - Name of th ePOP3 service to check/start - 2 locations in script to change

Save the above as a cmd file and schedule a task in schedule task to launch every hour (or thrity minutes)

Download SC.EXE from - http://www.activexperts.com/activmonitor/windowsmanagement/reskit2000/
Download GREP from - http://www.thedance.net/~win95/grep.exe


Cheers!
0
brian_appliedcpuAuthor Commented:
This would work great however the pop3 virtual server is not the Microsoft Exchange POP3 Service.
The virtual server is within Exchange 2003.

BKL
0
SembeeCommented:
They are one and the same.
The service listed is the virtual server.

Are you saying that the service is running, but the virtual server is not?

Simon.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

brian_appliedcpuAuthor Commented:
0
brian_appliedcpuAuthor Commented:
I found my answer, the service will not start automatically upon reboot by design.
0
SembeeCommented:
That isn't your answer.
It is not a design feature of the Exchange POP3 service to not start on reboot.
If it was a design feature I think it would be well known and there would be third parties who have created tools to start the service automatically as it would not be accepted.

Simon.
0
brian_appliedcpuAuthor Commented:
Did you read the above posting?
0
SembeeCommented:
I did indeed.

You stated...

"I found my answer, the service will not start automatically upon reboot by design."

That is not the case.
I am sat, at a server right this second (at gone midnight here in the UK), which has been rebooted at least a dozen times today. The POP3 service is enabled and has started correctly every time.

In the link that you provided there wasn't a real solution found, that I can read. It appears it may have been caused by a Windows Update, but I haven't seen one do that.

Simon.

0
brian_appliedcpuAuthor Commented:
OK, by broken design.  This is typical of MS but that does not lead me to a solution.  I may need to contact MS to resolve this.

bkl
0
brian_appliedcpuAuthor Commented:
Close however you feel fair.
I still have the issue, but am just dealing with it.

Brian
0
brian_appliedcpuAuthor Commented:
I do not want to give Sembee a poor grade but he did not provide a solution, so it may be fair to just delete the question.

Brian
0
SembeeCommented:
I haven't seen the error before which I was unable to post any more.

However what I didn't want going in to the PAQ was anything about the service being broken by design, when it plainly isn't.

A deep Google search for well over 30 minutes threw up this thread in Google Groups. It has a number of solutions, that might fix the problem. It is in an SBS group, but SBS contains Exchange so it may well work.

http://groups.google.co.uk/group/microsoft.public.windows.server.sbs/browse_frm/thread/3527af6063650d7b/7c51b1792a606233

If that doesn't work, then delete the question, as it holds no use to the PAQ.

Simon.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
VenabiliCommented:
brian_appliedcpu,

Had this worked?
0
brian_appliedcpuAuthor Commented:
That was the answer, sorry it took me so long to get to it, the server is for a Nextel Race Team so getting a chance to reboot the server comes very infrequently.  This is the recap.
I checked the Metabase Explorer settings as listed below and they were fine.

1. Open Metabase Explorer and locate the following entry:
Lm\Pop3svc\<virtual server number>
NOTE: By default the virtual server number should be 1 if there is only one
POP3 virtual server configured on this Exchange 2003.

2. Locate the entry "ServerAutoStart" in the right pane and make sure the
value is 1. If not, please double-click this entry and set the vaule to 1.

3. Restart the server and test this issue again.

THEN ON TO DEPENDENCIES...

This issue can also be caused by a slow startup of the Exchange System
Attendant on reboot. To work around this issue you can add the System
Attended as depended service on startup of the Microsoft Exchange POP3
service. To System attended to startup dependency for the Microsoft
Exchange POP3 service follow the steps listed below.  


1.  Go to start and then run and type in regedit.  


2.  Navigate to the following registry key  
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\POP3Svc


3.  Right click on DependOnService entry and select modify


4.  In a new line below IISAdmin entry type in MSExchangeSA and click Okay.


5. Close registry editor.  


***Also a change to the Microsoft Exchange IMAP4 key may be required.

Thanks for all your help and patience.

Brian
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Storage Software

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.