We help IT Professionals succeed at work.

Forgotten Administrator Password on Novell Netware v4.11

fiji_islander
on
Medium Priority
1,518 Views
Last Modified: 2012-06-21
Hi,

We are running Novell Netware v4.11 on top of DOS v6.2 on a very old Digital Polaris server. The Novell Server is hosting a legacy app which is about to be retired soon. As such, it is not used often by users. It is mostly used to print reports once in a while. Now all the user login accounts for Novell Netware have expired and the expired password cannot be changed. When asking the Novell administrator to rest the pasword, the administrator forget her password since she does not use Novell that much.

I have access to the Novell Netware server console and tried to run the adminadd.nlm utility from a floppy to add a admin user but it just auto loaded a few modules like NCPNLM32.NLM, CLNNLM32.NLM, LOCNLM32.NLM and than failed with the following errors at the end:
Server -4.11-1586: Loader cannot find public symbol: NWDSCreateContextHandle
Server -4.11-1586: Loader cannot find public symbol: NWIsDSAuthenticated
Server -4.11-1586: Load file referenced undefined public variable
Module adminadd.nlm NOT loaded

How do I get to load adminadd on my Novell server? Or how do I reset the admin password from the server console.

This Novell Netware server was installed like many years ago before I joined the firm and I have no knowledge of Novell or its commands so I would at beginners level of Novell.  If giving instructions and command, please be detailed and step-by-step as I am only a beginner in Novell Netware platforms.

Thanks
Comment
Watch Question

CERTIFIED EXPERT

Commented:
Just an FYI:  NetWare does NOT load "on top of" DOS.  DOS is the boot loader for NetWare.

I'm not familiar with adminadd.  You might want to check into MakeSU from http://www.dreamlan.com/main.htm
dbruntonQuid, Me Anxius Sum?  Illegitimi non carborundum.
CERTIFIED EXPERT

Commented:

Author

Commented:
Hi,

Sorry for not replying earlier. My hotmail email account was deactivated and I lost all my emails in my inbox. My assistant at work had solved the problem for me by using the util called setpwd which downloaded from the net. Ran it off from the floppy on the server console and it resetted the admin account and problem was solved.

Sorry guys. Forgot to close this question. Cheers.
Commented:
PAQed with points refunded (500)

CetusMOD
Community Support Moderator

Not the solution you were looking for? Getting a personalized solution is easy.

Ask the Experts
Access more of Experts Exchange with a free account
Thanks for using Experts Exchange.

Create a free account to continue.

Limited access with a free account allows you to:

  • View three pieces of content (articles, solutions, posts, and videos)
  • Ask the experts questions (counted toward content limit)
  • Customize your dashboard and profile

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.