We help IT Professionals succeed at work.

We've partnered with Certified Experts, Carl Webster and Richard Faulkner, to bring you a podcast all about Citrix Workspace, moving to the cloud, and analytics & intelligence. Episode 2 coming soon!Listen Now

x

TS/Citrix not mapping local drives

wesleyservices
on
Medium Priority
549 Views
Last Modified: 2010-08-05
I have terminal services 2003 and citrix presentation server 4.0 setup.  If I logon as a user who is a admin on the server the local drives map through fine.  If I logon as a user who is not and Admin the local drives will not map through.  I have checked in both the ICA client settings and RDP settings and both are set to allow local drive mapping.  Is there any security setting I need to change  to allow all users to map their local drives.
Comment
Watch Question

Check the Group Policy setting for "Do not allow drive redirection" in Administrative Templates\Windows Components\Terminal Services\Client/Server data redirection

http://technet2.microsoft.com/WindowsServer/en/Library/17d44d9a-cf4b-4a6a-94ec-093cb5f8b2b71033.mspx

Author

Commented:
Checked group policy and it was set to not configured, set it to Disabled did gpupdate /force tried again and users are still not getting thier local drives.
Try using the RSOP (Resultant Set of Policy) plugin for the MMC, or the Group Policy Results Wizard in the GPMC (Group Policy Management Console) to see what Group Policy settings are being applied to the users, and how they differ from the Group Policy settings are being applied to the admin accounts.

http://redmondmag.com/features/article.asp?EditorialsID=460

Author

Commented:
Ok after appling the GPO when I logon as a normal user I get my local drives mapped through.  But if I wait about 10 min then logon to Citirix with the same user account the local drives are no longer mapping though.  The only way they come back is if I edit the GPO and reboot the server.  They come back for a while then dissapear again.

Author

Commented:
Also when I run the RSOP on the server no matter which user I run it for the computer configuration has a red X on it but if I look it shows the GPO for local drive mapping as disabled.

Author

Commented:
I figured out the issue was our logon script.  It is set to delete all map network drives when a user logs on.  In the new version of Presentation server 4.0 it mapps the local client drives as network drives.  Made a few changes to the script and now the local drives are mapping through fine.  Hope this helps if any one else was having the same issue.
Commented:
PAQed with points refunded (500)

GranMod
Community Support Moderator

Not the solution you were looking for? Getting a personalized solution is easy.

Ask the Experts
Access more of Experts Exchange with a free account
Thanks for using Experts Exchange.

Create a free account to continue.

Limited access with a free account allows you to:

  • View three pieces of content (articles, solutions, posts, and videos)
  • Ask the experts questions (counted toward content limit)
  • Customize your dashboard and profile

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.