Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
?
Solved

An error occurs while opening the specified store

Posted on 2006-04-04
12
Medium Priority
?
797 Views
Last Modified: 2008-01-09
Hi,
In our website we are using a certificate which was given to us by a bank to use when we do the online payment.
if we run a standalone page/test page which use this certificate, it works fine.  But when we run our website, then we get the error "An error occurs while opening the specified store".  Our website we run as user "selfcare".  Is this something to do with security or permission.

Please help us

Thanks
0
Comment
Question by:indikad
  • 6
  • 3
10 Comments
 
LVL 18

Expert Comment

by:Sam Panwar
ID: 16378467
Hi,

I think you are talking about SSl certificate for encryption data or ma be paypal.
1.Use the https:// instead of the http:// and try
2. May be SSL not install proper contact to your host company
3. Delete cookies and internet temporary file then try
0
 
LVL 18

Expert Comment

by:Sam Panwar
ID: 16378477
Suggestion 2
============
The error may occur because the language-setting in
Internet Explorer is missing.  To add a language, in
Internet Explorer, select Tools-->Internet Options, and
click the "Languages" button.  Add a language to the list
if empty.
-----------------------------------------------------------
---------------------
Suggestion 3
============
Check the system time.  SSL will not function if the
system time is more than 100 days off.
-----------------------------------------------------------
---------------------
Suggestion 4
============
Please uncheck "Check for server certificate revocation":

1.  Open Internet Explorer
2.  Click on Tools
3.  Click on Internet Option from the drop down menu
4.  Click on the Advanced tab
5.  Scroll down to the Security Section
6.  Unselect "Check for server certificate revocation"
7.  Reboot the machine
We may be able to resolve this issue by adding
  http://Windowsupdate.microsoft.com
  http://V4.Windowsupdate.microsoft.com
  https://v4.Windowsupdate.microsoft.com (Note: The https
is correct)
  http://Download.Windowsupdate.com
to the trusted sites list in the Internet Options.  
To access the Exceptions settings.  
1. Open Internet Explorer
2. Click Tools / Internet Options
3. Click the Security Tab
4. Click on the Trusted Sites Icon
5. Click on the Sites button
6. Unselect the check box "Require server verification
(https:)for all sites in this zone"
7. Add all 4 sites listed above
0
 
LVL 51

Expert Comment

by:ahoffmann
ID: 16378830
>  But when we run our website, ..
could you please post the command and the resulting error messages verbatime how you do that
0
Receive 1:1 tech help

Solve your biggest tech problems alongside global tech experts with 1:1 help.

 

Author Comment

by:indikad
ID: 16387811
in the web.config file we have this line :
<identity impersonate="true" userName="selfcare" password="c9112f31" />

if we set the impersonate="false" then this works.  Then this website runs as default ASP user.
So I thing this is something to do with the user "selfcare".  But I do not know what to do.

We have this user created on the web server and has the administrative wrights.
0
 
LVL 18

Expert Comment

by:Sam Panwar
ID: 16388709
Hi ,

Make the virtual directory the folder in which the webconfig.sys file existyour problem should be rresolved
0
 

Author Comment

by:indikad
ID: 16388757

If you are talking about the web.config file then that is already in the virtual directory.
0
 
LVL 18

Expert Comment

by:Sam Panwar
ID: 16388783
Recreate it and check and also check the you have select windows authentication user the directory security of your website.
0
 
LVL 18

Expert Comment

by:Sam Panwar
ID: 16388846
Check the directory security setting of the that folder and website if you use any other password check and tell me
0
 

Author Comment

by:indikad
ID: 16389187
it has the anon. access and the integrated windows authentication checked
in anon.access unchecked the "Allow IIS to control password" and the user is default ASP.NET user
0
 
LVL 18

Accepted Solution

by:
Sam Panwar earned 500 total points
ID: 16389949
1.Check with the administrator password ainstead of selfcare use then try.
 And also try with the anonomous user
Another method

1. assign ASPNET account used by asp.net with Administrator right
2. modify <winnt>\Microsoft.NET\Framework\<version>\CONFIG\machine.config
    change <processModel ... /> to: <processModel userName="machine"
password="AutoGenerate" />
Here is more infos:
In the RTM version of ASP.NET the ASP.NET worker process runs under a special ASPNET account that has limited priveleges. For impersonation to work the security context must have "Act as part of the operating system" priveleges.  There are a couple workarounds:
1.) Change the userName attribute of the <processModel> tag in your machine.config file to SYSTEM rather than its default which is MACHINE.
or
2.) Impersonate programatically which is demonstrated in this KB article:
http://support.microsoft.com/default.aspx?scid=kb;en-us;Q306158 
I'll bet that your developer machine is running pre-RTM .NET Framework bits or you have already reverted to the SYSTEM account on that machine.

Another
Please see the following information on Impersonation in ASP.NET.
When you want to Impersonate a thread with a user in ASP.NET, you can do that in any of the following ways based on your requirment.
 - Impersonate the IIS Authenticating user
 - Impersonate a Specific user for all the requests on all the pages of an
   ASP.NET application
 - Impersonate the Authenticating user whereever required within the code
 - Impersonate a Specific user whereever required within the code
Impersonate the IIS Authenticating User
---------------------------------------
To Impersonate the IIS Authenticating user on every request for every page
in an
ASP.NET application, you need to have an identity tag in the web.config file of this application and set its impersonate attribute to True.
   <identity impersonate="True" />
Impersonate a Specific user for all the requests on all the pages of an ASP.NET application
----------------------------------------------------------------------------
---------------
To impersonate a specific user for all the requests on all the pages of an ASP.NET application, you can specify that userName and password in the identity tag of the web.config file for that application as shown below.
   <identity impersonate="True" userName="accountname" password="password"
/>
Impersonate the Authenticating user whereever required within the code
----------------------------------------------------------------------
When you want to Impersonate the IIS authenticating user only during execution of a piece of code, you can use the following code to perform that. VB
   Dim impCtx as System.Security.Principal.WindowsImpersonationContext()
   impCtx =
System.Security.Principal.WindowsIdentity.GetCurrent.Impersonate()
   'Your code that runs under the security context of the IIS
authenticating user goes here.
   impCtx.Undo()
0

Featured Post

Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Most ColdFusion developers get confused between the CFSet, Duplicate, and Structcopy methods of copying a Structure, especially which one to use when. This Article will explain the differences in the approaches with examples; therefore, after readin…
What You Need to Know when Searching for a Webhost Provider
Loops Section Overview
The Relationships Diagram is a good way to get an overall view of what a database is keeping track of. It is also where relationships are defined. A relationship specifies how two tables connect to each other. As you build tables in Microsoft Ac…

564 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question