IDE boot drive won't power up with interface cable connected but will if interface cable is disconnected

Hello,

I have a Windows XP system that was working but I opened the box to replace a graphics card fan that had died.  When I put it back together, it wouldn't boot.  I took the hard drive out of the box and connected it to another system as a second drive and was able to read it fine.  I put another bootable drive in the original box and was able to boot it.

So, I put the original drive back in the original box and did some testing.  I found that if i remove the IDE interface cable from the hard drive, the drive will spin up.  I can feel it if I hold it in my hand.  As soon as I connect the interface cable and try to boot it, the hard drive refuses to spin up.  I put the other bootable drive back on the original box and now it won't spin up at power up time except for one time out of maybe 5-7 tries it booted OK.

I have replaced the interface cable but that doesn't seem to make any difference.  My guess is that something is wrong with the mother board that is intermittent.  The box was FULL of dust when I opened it so maybe in cleaning it out I have upset some delicate balance of fuzz on the circuitry.  :-)

Anybody have any ideas how to troubleshoot this box or what might be causing such odd behavior.

Thanks.

Mark
mgump9Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

PCBONEZCommented:
Start by replacing the cable.
PCBONEZCommented:
```` Yes,,, Again..

Look for bent pins in the IDE connector on the board.

Look for any dust bunnies jammed under the edges of chips or connectors.

Look for bad caps. http://www.badcaps.net/ident/

Remove and replace the memory as well as the other data cables (both ends).

PCBONEZCommented:
Unplug it FROM THE WALL while you are working inside... !!!!
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

PCBONEZCommented:
Are you getting any beep codes???
mgump9Author Commented:
PCBONEZ,

I just found that if I remove the power from both the CD and DVD drives that the hard drive spins up and it boots.  Aha!  Maybe there is a power supply that has gotten weak enough so that it is marginally able to drive all the hardware but when I remove some of the load (don't connect power to CD and DVD drives) it has enough oomph to spin the hard drive.  :-)

So, I just replaced the old 300 watt power supply with a new 350 watt power supply and connected all drives up and it I has booted several times with no problem.  But, I think it also did NOT boot a couple of times with the new power supply.  I can't remember at this point.  Too many variations and too late at night.  :-)

I don't suspect it is the IDE cable nor dust bunnies since I blasted it pretty well with a strong stream of compressed air and cleaned it out fairly well.  I have also removed and cleaned the RAM chip and slot so that doesn't seem suspect.  I am going to let it run all night and see if it wil re-boot OK in the morning.

No beep codes whatsoever.

BTW, it did boot OK from a Windows XP installation CD when I set the BIOS to boot from CD first.

I already had checked for bent pins on both the hard drive male connection and the motherboard male connection.  Good idea and may be useful for somebody else though.

The BadCaps web site is interesting.  I took a look at the capacitors on the motherboard and didn't find anything too suspect looking.  Still a good idea and interesting reading.  Thanks!

I'll post the results of my morning test.  Right now, I am suspecting a marginal power supply but I won't rule out an intermittent problem with the IDE controller on the motherboard.

Thanks for the suggestions.  Any other ideas at this point?

Mark
nobusCommented:
check what power you need here :

http://www.jscustompcs.com/power_supply/      

you can also test the ide channels, by connecting the disk drive to each one , and boot from it.
BTW, i suggest checking and reseating all cards and cables.
masnrockCommented:
Just from reading the start of the thing, I was thinking power supply. Check the differences in the amount of power each computer's supply can put out.

But I would also check the IDE channels.... if by wild chance you have one, you could try plugging in an IDE card and plugging your drive into that to see what hapens.
rindiCommented:
this usually happens when you connect the IDE cable with the color coded end aligned the wrong way, not to pin 1. Are you sure you hadn't mistakenly connected it the wrong way to the HD, after all you said it was late?...
masnrockCommented:
That is one possibility. However, there is another. How do you have the jumpers on your hard drive set? Do you have it set to cable select? If so, change the jumpers to another setting (master or slave). Sometimes there are problems with cable select for people without any real rhyme or reason.
maramomCommented:
>>Right now, I am suspecting a marginal power supply
That's what it sounds like to me. Many graphics cards need a 350w minimum to run. Since the problem arose after installing a new card, and (perhaps?) doesn't boot every time with a 350w supply, points to not enough power. If you want to test, before spending the money on a new PSU, try running minus an optical drive and some non-essential devices, and see if you get a reliable boot without the extra power needs of those devices. If it works this way without a problem, you can reliably deduce you need a heftier PSU.
mgump9Author Commented:
An update on the problem:

Well, I let the box run all night and it was fine in the morning.  I then shut it down several times and it re-booted without fail.  After probably about 10 re-boots both after complete power downs and non-power down reboots it kept working until one time it just didn't boot.  Tearing the box apart again and checking cables and trying combinations of disconnecting power supply connectors to the two CD/DVD drives, different graphics cards (another AGP and a PCI graphics card), another bootable hard drive, etc. nothing would make the hard drive spin up and boot other than removing the IDE interface cable from the hard drive.  (Of course with the interface cable removed, it would spin up but not be available for booting.)

I tried putting the hard drive in three other computers and wasn't able to get it to boot in any of them.  This may have been due to other factors unrelated to the original problem though as a couple of these other boxes were pretty old and there may have been some configuration problems with the hard drive and these boxes.  All in all, it seemed like they should have at least booted but all of them acted strange in different ways.

About to give up, I decided to pull all the cards and the motherboard on the original box and check for dust bunnies or loose connections on the bottom of the motherboard.  I didn't find anything suspect so I put everything back together again and tried to boot it at each step of the way.  The original box with the original hard drive and all of the other components booted up fine without any problems every time I added a new component and booted it.  It continued to boot up fine through several more test boots after everything was all back in it's original places.  I buttoned it up and returned it to it's original owner telling her to keep an eye on it and let me know if it acts up.

So...., who knows what the heck is/was wrong with it.  The only thing I found odd was when I added the modem PCI card back in the slot as I was adding components one by one when it was booting fine, just as I plugged the card in, the system powered up and booted without me pushing the power button.  I am fairly sure I had powered it down and not said to do a restart.  I thought maybe I had mistakenly said "Restart" when I shut it down before adding that card so I was very surprised when it just started up as I pushed that card in the slot.  I wonder if there was some sort of dust in the slot and pulling the card out and putting it back in did something odd.

As far as some of the other suggestions go, I tried setting the jumpers to Master and Cable with no success.  The drive was originally set to Cable so I don't think that probably had anything to do with it.  The IDE interface cable connectors were all keyed so I couldn't possibly connect them incorrectly.  There were no bent pins on anything.

"NOBUS" offered an interesting web site link about computing the size of power supply needed.  Thanks.  I did go to that site and it indicated a 250W would have been sufficient for the configuration.  I put a new 350W in so that shouldn't be the cause.  BTW, the graphics card was not new but rather I just replaced the chipset fan on the card because the original fan had frozen.  So unless I added a significant amount of power requirement by replacing that fan, which I seriously doubt, that couldn't have accounted for the problem.  Plus, I tried two other graphics cards without fans and that didn't help either.

Anyway, I'll have to wait and see if I get a call about it not booting again.

Thanks to everyone for the suggestions.

Mark
PCBONEZCommented:
Oops,, you're BUSTED!!!

"just as I plugged the card in, the system powered up and booted without me pushing the power button."

Do you remember "Unplug it FROM THE WALL while you are working inside... !!!!"

Never ever add or remove parts from an ATX system without killing power to the PSU *completely!!!

ATX power supplies power parts of the mainboard even when 'off'. The simple act of removing or adding a card can fry the chipset on the mainboard. What happens is the disconnect (or connect) causes a voltage spike large enough to fry the tiny connections INSIDE the micro-chip that connect the actual silicon wafer to the leads. Asus used to have a very detailed page on the subject complete with electron microscope photos of the damage inside chipsets. (Unfortunatly the page seems to be gone now.)

What you did when you popped that card in was you shorted something during the inscertion and caused the Wake on LAN or Wake on Ring function to kick in so the system started.

BAD BAD BAD!!!
.

rindiCommented:
Modems often have a setting which allows you to boot on ring. By inserting this card with the power connected to the PC could have triggered that. Check your BIOS, often you can turn that option off inside there.

There may also be a problem with the power connector to your HD. Did you hear it spinning up on all the PC's you tried it in?

Have you run the disk manufacturers testing utility on it?
mgump9Author Commented:
"RINDI":

Yes the hard drive DID spin up on all three of the other boxes.  It wouldn't complete booting though because of some other issues but it definately had the drive spinning because it always displayed on the monitor the "Windows was not properly shut down" message and the menu of startup options.

Thanks for the information about the modem possibly triggering the boot when it was inserted.  It sounds plausible.

"PCBONZ":

Yeah, you got me on that one.  I know better and still didn't disconnect the power cord.  I guess I didn't smoke any components though so I dodged that bullet.  It is a good reminder to me for the future and maybe you comments will save somebody else who reads this some grief in the future.

Mark
pcchecksCommented:
I have had a similar problem on two separate occasions.

1. culprit was a defective harddrive soln: change harddrive
2. the bios on the mainboard was corrupted somewhat and kept losing settings soln: flash bios and all was well after that.
mgump9Author Commented:
"PCCHECKS":

Thanks for your comment but I am unfamiliar with the term "soln".  Is that an abbreviation for solenoid?  If so, are you referring to the part of the hard drive that moves the arm?  If not, what does this term mean?  Or, could it be you have inserted an abbreviation that I am not familiar with such as "S... out of luck ...."  Please enlighten me.  :-)

You gave two causes.  Was each cause the reason for the hard drive not spinning up in two different situations?  Or did you have to replace the hard drive and flash the BIOS for both situations?

Thanks.

Mark
PCBONEZCommented:
"soln" is an abbreviation for "solution".
pcchecksCommented:
mqump9

I flashed the motherboard bios
mgump9Author Commented:
Well, the box came back to me after a day and it wouldn't boot again.  I tried resetting the BIOS and that got it to boot again but within a few hours it was back to not booting again.  

It won't boot with a different bootable hard drive so replacing the hard drive doesn't seem to worth the trouble.  I suspect the trouble is with the motherboard but don't know how to narrow it down any more or resolve it short of replacing the motherboard itself.

Any other thoughts anyone?

Mark
pcchecksCommented:
try flashing the bios as i did or if you can, remove the mainboard from the system and attach the main things for booting outside the case. This would let you know if the system is grounding off somewhere. if that does not work...then your mainboard may be at fault.
rindiCommented:
Have you tried replacing the small 3.3 V battery on the mainboard? Sometimes if these are bad you can get this type of erratic behaviour. Also, ifi this hasen't been mentioned yet and you haven't done it yet, check the motherboard for bad capacitors in the processor area. Look for cracks, leaking or bulging on them.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
PCBONEZCommented:
2 cents - rindi's ideas are both good ones.
http://www.badcaps.net/
gopherTeaboyCommented:
Do you have a IDE PCI card that you could use to bypass the controller on the motherboard?
That might be worth a try.
pcchecksCommented:
rindi

replacing the battery shouldn't have an effect because he said "I tried resetting the BIOS and that got it to boot again but within a few hours it was back to not booting again". If the battery was bad, then the bios would be on constant default(resetted values)
maramomCommented:
>>If the battery was bad, then the bios would be on constant default(resetted values)
Actually not, As rindi said, it can cause irratic behavior. There may be some charge, but not enough to hold the values, and also can contribute to corrupted values in CMOS.
mgump9Author Commented:
Hi All,

I tried a new 3.3v battery and it booted once then wouldn't boot again.  I took the motherboard out and it still wouldn't boot.  In taking a very close look at some of the capacitors I am going to have to vote for bad capacitors.  Several of them looked like the tops were slightly bulging and a couple had some crusty looking stuff around the tops.  I saw no evidence of leakage at the base but some of them seemed sort of loose to the touch.

I could try a new motherboard but given the age of the system and the owner's willingness (and desire) to get a new system I think this box is headed for the recycle bin.

Thanks to everyone for their suggestions.  I, and I hope others, learned some new things that may come in handy in the future even though I didn't actually fully solve the problem.  I am splitting the points but giving the majority to PCBONEZ because I suspect the bad capacitors are the most likely culprits.  I gave some points for the power supply calculator link and the 3.3v battery idea mainly because they were good ideas too.

Mark
rindiCommented:
thanks
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Desktops

From novice to tech pro — start learning today.