WINDOW2000 TERMINAL SERVER

Dear Sir,
I have set-up Terminal Server Service  on Window-2000 Server . When I try to telnet on this machine from some other Window machine , I am getting a message :

"NTLM Authentication failed due to insufficient credentials . Please login with clear username and password
 Server allows NTLM authentication only
 Server has closed connection"

Due to this problem I am not able to Telnet . Kindly guide me .

Rgds
B Mittal
bvmittalAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

NopiusCommented:
You are mixing terms: Terminal Server is not a Telnet server.

Terminal Server allows users to connect to _graphical_ console via RDP protocol (using rdesktop or like client)
Telnet service allows users to connect via telnet protocol, text based (using telnet command line)

While Telnet service is embedded to standard Windows, it should be started manually and it supports only NTLM authorization (that means that you can connect to in only from telnet client with NTLM support). You may either find telnet client with NTLM authorization or to disable NTLM in Microsoft Telnet service. Standart telnet.exe doesn't support NTLM.
For disabling NTLM in Win 2000 telnet server, look here: http://www.chicagotech.net/telnet.htm
--[snip]--
By default, the Win 2000 Telnet service requires NTLM authentication. However, if Win 2000 is configured to use Kerberos as its default authentication method, then Telnet users are not able to obtain access to domain/AD resources including network validation. To configure the Win 2000 Telnet Service to not require NTLM, run  Telnet Server Administration, select  option 3,  Display / change registry settings and then select option 7,  NTLM. Change the default setting from 2 to 0 to disable the NTLM requirement.
--[snip]--


0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
NopiusCommented:
P.S. Telnet Administrator is located in "Programs/Administrative Tools"
Also you should restart telnet service after changing option 7 (i.e. from command line):
net stop telnet
net start telnet

0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Server OS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.