Crystal Reports - Report Load Failed for Non Administrators

The very descriptive "Report Load Failed" Crystal error .... really narrows down the problem. :)

I have developed a Windows application in VB.NET 2003 that uses Crystal Reports (v. 9.1.5).  The database backend is MS Access, which is password protected.  I use DataSets with embedded Crystal Reports.  I install the application on users machines with no errors (the install includes all the necessary files for Crystal).  

The above application and install have these results with Crystal:

1. On a machine that DOES NOT have VS 7 installed: if the user who is logged into the machine is in the Administrators group, they have no problems viewing the reports.  However, if the user who is logged into the machine is not in the Administrators group, they get "Report Load Failed" error when attempting to view the report.

2. On a machine that DOES have VS 7 installed: users in the Administrators group or any other group can view the reports with no errors.

# 2 obviously is not an "issue", but confuses me seems how # 1 is.  What am I missing?  This seems like a rights issue, but where?

Please Help!

psisqlmgrAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Mikal613Commented:
a)Crystal 9 is the buggiest version yet. 10 should not give you the problems.
b)try installing the needed dlls in the app path and that should do it.
c)the dll can be in the system directory and only the admin has rights to that
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
psisqlmgrAuthor Commented:
Thank you for the quick response.  I will try your suggestions and let you know which one works.
0
Jojo1771Commented:
This is a pure guess, but I would say that VS7 is installing the merge modules correctly and your install is some how not. Pure guess thouugh as I use CR version XI (Business Objects) and have little to no experince with version 9.

I would recommend looking at this link.
http://support.businessobjects.com/fix/merge_modules.asp?ref=default.asp_wwwjump
0
Cloud Class® Course: C++ 11 Fundamentals

This course will introduce you to C++ 11 and teach you about syntax fundamentals.

psisqlmgrAuthor Commented:
Thanks Jojo1771.  I will make sure that the install is correct and take a look at the link as well.  I will report back when I find the correct solution.
0
psisqlmgrAuthor Commented:
Jojo1771, I checked the link and made sure that all the correct merge modules were in the install.  I even reread all the documents about Crystal and VS 2003 and included some new merge modules in the install, just in case.  I also upgraded Crystal 9.1.5 to 9.1.98 (Crystal 9 SP6).  Nothing has worked.

Mikal613, I dropped all the dll's in the app path.  That did not work.  I am currently upgrading my Crystal 9 to Crystal 11 to test that.  If the upgrade itself does not solve the problem I will upgrade the database from Access to SQL Server 2005 to see if that will help.

I was able to narrow down when the error occurs in code.  It happens when I set the ReportSource = TheCrystalReport.
0
Mikal613Commented:
can you run the report in crystal?
0
psisqlmgrAuthor Commented:
Mikal613, thank you for your continued help.  The .rpt file is embedded in the application and utilizes a dataset.  The report runs great for all users in the Administrators group.... so the report will pull up depending on what your rights are on the machine.
0
psisqlmgrAuthor Commented:
Mikal613, I upgraded from Crystal version 9.1.5 to 9.1.98 (service pack # ?) with no change for non administrators and their inability to view Crystal reports in my application.  However, when I upgraded to Crystal version 11.0.0.1994 and created a new install file using the 1 merge module that is needed (another merge module is optional, but not needed) all worked well.  I can't say with any certainity what was the problem, but I do know upgrading to Crystal 11 solved all my problems.  Thanks!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Visual Basic.NET

From novice to tech pro — start learning today.