RDP client imposing its keyboard layout onto the servers it is connecting to.

Hi there

I have customers in the States and whenever I log into their windows 2003 servers, the keyboard layout on the servers change to English UK which affects everybody. Is there a way to prevent my computer from "imposing" its keyboard layout onto the computer it's connecting to? or is this something that needs to be fixed on the server side?
eggster34Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

TheCleanerCommented:
This is the best I could find for you on this:

http://support.microsoft.com/?kbid=906693

0
TheCleanerCommented:
Note, it seems to be stating what you are experiencing, just replace "DVORAK" with your UK layout when reading the above KB article.
0
eggster34Author Commented:
I'm using windows server 2003. This fix would not apply to me.
0
Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

Netman66Commented:
Do not log into their servers with an account that has roaming profiles set.

Create an account to manage their servers on their AD make sure it has no profiles associated with it.

0
eggster34Author Commented:
I don't have a roaming profile..
in fact my profile has nothing to do with the remote servers' profiles since we are on completely different domains that are not related.
0
TheCleanerCommented:
I figured the fix might work regardless since the 2 underlying OS's (XP and 2003) are very similar.

Not that I would recommend you just apply it, regardless, but you may need to call MS (or post in the managed newsgroups or similar) and tell them the situation and cite the KB article that seems to apply to XP, and see if there is something similar for 2003.

Does the keyboard layout actually change for the local console or are you logging on as something like "admin" and they are using "admin" when RDP'ing in as well?  Basically is your user account different from theirs?
0
eggster34Author Commented:
the problem is that I have a different keyboard, and my accoutn is an admin accoutn because I'm the administrator of these servers.
whenever I log in, it changes the kb layout on the remote computer to that of mine.. so that the other users when they RDP into it have to use my keyboard layout.
 I don't want that. I want the keyboard layout on the remote computer to not change at all times.
0
TheCleanerCommented:
Is the account you use to RDP in the same as what they are using?
0
eggster34Author Commented:
yes it's the same account
0
TheCleanerCommented:
That's going to be why.  You need to create separate admin accounts, so that the profiles don't get updated with your keyboard settings.

You should be using separate accounts anyway for your own CYA, so that if something does go wrong, you can have proof it wasn't you that did it.
0
eggster34Author Commented:
good advice, but I cannot do it in this scenario :( can you think of any solutions to the problem?
0
TheCleanerCommented:
Sorry, no.  I don't have any real solution.  I understand the problem, but I'm not sure what's going to fix it other than using separate user accounts which would make for separate profiles.
0
TheCleanerCommented:
Just thought of this...what about using the MUI on the server:  http://www.microsoft.com/globaldev/DrIntl/faqs/MUIFaq.mspx

That may work...but I'm honestly not sure...
0
eggster34Author Commented:
that's exactly the opposite of what I2m tring to do..
I'm trying to disable this feature which adds every keyboard language that connects to the server via RDP.
0
TheCleanerCommented:
eh...I actually forgot that you were using the same user ID again...

Does this help at all:  http://blogs.msdn.com/michkap/archive/2006/01/05/509539.aspx

Again, the "solution" really is to use separate admin accounts.  Not the answer you want to hear due to your scenario, I know.
0
eggster34Author Commented:
Here's something weird.
I have another server (Windows 2003 Standard) in another company that I access usingt he same method. Oddly enough, that particular server does not behave like this. It always uses the default keyboard layout (U.S. English.)
Is there a language pack or something like that that may be causing this?
0
GranModCommented:
PAQed with points refunded (500)

GranMod
Community Support Moderator
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2003

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.