Sharing Permission

Hello :
I Have A Small Network (5 Computers) They Are Connected To Each Other By A Switch
They All Have Windows Xp Professional Edition
They All Are Members Of A Workgroup In A Peer-To-Peer Network
So Now I Want To Know How To Manage The Permissions Of The Sharing Between This Computers
Because I Want Some Computers To Be Able To Access Some Sharings And Prevent Others From Accessing

Note: In The Permission Of The Sharing I Can`t Reach Any Network Place (Only Local Users And Groups)

How Can I Do This
Thanks In Advance
waelolabiAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Craig_200XCommented:
1 - Turn off Simple File Sharing

---1. Double-click My Computer on the desktop.
---2. On the Tools menu, click Folder Options.
---3. Click the View tab, and then clear option to Use Simple File Sharing.
---4. Then share the folder or drive by right clicking it and selecting SHARING and SECURITY.
---5. Click Share this folder. Give it a name and set permissions for everyone or specific people. If it is a drive.. click new share and give it a name and the permissions. (You wont "SEE" a drive or folder ending in $ it will be hidden)

2 - Disable firewall. Click Start, click Run, type wscui.cpl and then click OK. Turn firewall off.

3 - Access the share by either going to Network Neighborhood and the workgroup. Or by entering FQDN name/IP in the browser window like this:

\"\COMPUTERNAME"

or

"\\192.168.1.xxx"  

the ip is the ip of the PC your accessing.
0
Jay_Jay70Commented:
Hi Craig_200X,

i would allow read access to shares and then drill down with NTFS permissions

Cheers!
0
bijal7612Commented:
Create Five Users in different Machine where u want to give access to the users.After that u need to right click on the folder or file which u want to share & remoeve Everyone from the list of sharing & ADD Particular User to that Folder or file ffor sharing.In this case only that user wud be able to access the file or folder which u have shared in the user name respectively.The Other User accesing to this folder or file want be allowed as access has been given to other 1.this is how u can prevent the  user being acces from other users.
0
Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

waelolabiAuthor Commented:
First I Want To Add That I Am Using FAT32 File System (No NTFS)

Second : To  bijal7612

I Did As You Say But When I Remove EVERYONE And Add A Specific User Instead, I Can`t Get Access From The Remote Computer
As I Think All The Computers Connect As "Guest" Because If I Give A Permission To A Guest Account The Remote Computer Can Access

So How Can I Make Remote Computers Connect As Thier Real Identity
Thanks
0
Jay_Jay70Commented:
any reason you cant convert to NTFS much more security options
0
bijal7612Commented:
Create an administartor account with an password.& add only that account to the shared Permission.So that whenever u want u can get connect with the addmistartor account & obtain the data.Enbling Guest account is not recommanded.
0
Craig_200XCommented:
you have to add local acocunts for EACH user on the shared folder machine.. once that is done, make sure users are logging on with those accounts. then add the account names to the permissions. The extra work on account IDs, is NORMALLY being done by a domain controller, but in your case you have to manually add user accounts to the shared machine.
0
waelolabiAuthor Commented:
Mr Craig_200X  :

I Did This But As I Explain Above The Remote Computers Connect To The Shared Folder Machine As "Guest"

I Don`t Want That
So How Can I Make Them Connect As Their Real Users Not As "Guest"

Because
When I Give A Permission To Guest : Remote Computers Can Connect The Shared Folder
When I Give A Permission To A User That I Add I Can`t Access The Shared Folder
(I Make Users Log On With Same Accounts On Remote Computers)

Thanks

0
Craig_200XCommented:
First please make sure Simple File Sharing is turned OFF. if it isnt - goto first msg at top

Do the remote computers logon to the computers with no password? if so change this so they have passwords, if they are not logging on with anything. create accounts for them to logon with. remove guest account.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Networking

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.