• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 227
  • Last Modified:

Cisco PIX to Cisco Client VPN restricting traffic to only 3389 traffic through tunnel.

I have a Cisco PIX with a working Cisco VPN Client and only want to allow 3389 traffic instead of all IP traffic  below is my config with a few numbers "*****'ed" out for security reasons.


PIX Version 6.3(5)
interface ethernet0 10baset
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password 0 ******** encrypted
passwd tMX2EO6BCnj6TMcE encrypted
hostname  ********
domain-name cardinalconst.com
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol ils 389
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
no fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names

access-list inbound permit tcp any host 2 ******** eq 3389
access-list inbound permit icmp any any echo-reply
access-list inbound permit icmp any any time-exceeded
access-list inbound permit icmp any any unreachable
access-list inbound permit icmp any any
access-list inbound permit tcp any host 21 ******** eq pop3
access-list 101 permit ip 192.168.1.0 255.255.255.0 192.168.222.0 255.255.255.0
access-list 101 permit ip 192.168.1.0 255.255.255.0 192.168.55.0 255.255.255.0
access-list 101 permit ip 192.168.1.0 255.255.255.0 192.168.69.0 255.255.255.0
access-list 101 permit tcp 192.168.1.0 255.255.255.0 172.16.0.0 255.255.0.0 eq 3389
access-list 110 permit ip 192.168.1.0 255.255.255.0 192.168.222.0 255.255.255.0
access-list outbound permit ip any any
access-list 155 permit ip 192.168.1.0 255.255.255.0 192.168.55.0 255.255.255.0
access-list 169 permit ip 192.168.1.0 255.255.255.0 192.168.69.0 255.255.255.0
access-list 156 permit tcp 192.168.1.0 255.255.255.0 172.16.0.0 255.255.255.0 eq 3389
pager lines 20
logging on
logging timestamp
logging monitor debugging
logging buffered debugging
logging trap debugging
logging history debugging
logging facility 23
mtu outside 1500
mtu inside 1500
ip address outside 2 ******** 255.255.255.248
ip address inside 192.168.1.254 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool clientpool 172.16.0.1-172.16.0.8
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list 101
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) tcp  ********2 smtp 192.168.1.252 smtp netmask 255.255.255.255 0 0
static (inside,outside) tcp 2 ********22 3389 192.168.1.245 3389 netmask 255.255.255.255 0 0
static (inside,outside) tcp 21 ********22 pop3 192.168.1.252 pop3 netmask 255.255.255.255 0 0
access-group inbound in interface outside
access-group outbound in interface inside
route outside 0.0.0.0 0.0.0.0 216.203.101.17 1
timeout conn 10:00:00 half-closed 5:00:00 udp 0:02:00 rpc 10:00:00 h225 1:00:00
timeout h323 0:10:00 mgcp 0:05:00 sip 0:10:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:02:00 absolute
timeout xlate 0:02:00
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set myset esp-3des esp-md5-hmac
crypto dynamic-map cisco 1 set transform-set myset
crypto map newmap 10 ipsec-isakmp
crypto map newmap 10 match address 110
crypto map newmap 10 set peer 21 ******* ********.190
crypto map newmap 10 set transform-set myset
crypto map newmap 20 ipsec-isakmp dynamic cisco
crypto map newmap 55 ipsec-isakmp
crypto map newmap 55 match address 155
crypto map newmap 55 set peer 21 ********80
crypto map newmap 55 set transform-set myset
crypto map newmap 69 ipsec-isakmp
crypto map newmap 69 match address 169
crypto map newmap 69 set peer 20 ********2
crypto map newmap 69 set transform-set myset
crypto map newmap client authentication LOCAL
crypto map newmap interface outside
isakmp enable outside
isakmp key ******** address 2 ********0 netmask 255.255.255.255 no-xauth no-config-mode
isakmp key ******** address 21 ********.2 netmask 255.255.255.255 no-xauth no-config-mode
isakmp key ******** address 20 ********62 netmask 255.255.255.255 no-xauth no-config-mode
isakmp key ******** address 21 ********2.180 netmask 255.255.255.255 no-xauth no-config-mode
isakmp identity address
isakmp nat-traversal 20
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption 3des
isakmp policy 10 hash md5
isakmp policy 10 group 2
isakmp policy 10 lifetime 86400
vpngroup ******** address-pool clientpool
vpngroup ******** dns-server 192.168.1.252
vpngroup ******** wins-server 192.168.1.252
vpngroup ******** default-domain ********.local
vpngroup ********split-tunnel 156
vpngroup ******** idle-time 1800
vpngroup ******** password ********
telnet 0.0.0.0 0.0.0.0 inside
telnet timeout 59
ssh ******** outside
ssh timeout 59
console timeout 0
username ******** password ******** encrypted privilege 2
username ******** password ******** encrypted privilege 2
username ******** password ******** encrypted privilege 2
username ******** password ******** encrypted privilege 2
terminal width 80
0
richeckstein
Asked:
richeckstein
1 Solution
 
prashsaxCommented:
hi,

you need to create an acl from outside to inside.

right now, you have specified the acl for port 3389, from inside to outside.

But, as i understand the RDP connection is initiated by VPN client, who have IP address 172.16.0.x.

so you need to create an acl allowing source IP 172.16.0.x, destination IP 192.x.x.x(your Terminal Servers IP). and service as TCP Port 3389.

0
 
richecksteinAuthor Commented:
I figured it out myself.  You were close on the ACL, but I had to remove the "sysopt connection permit-ipsec
" statement for it to work.
0

Featured Post

What Security Threats Are We Predicting for 2018?

Cryptocurrency, IoT botnets, MFA, and more! Hackers are already planning their next big attacks for 2018. Learn what you might face, and how to defend against it with our 2018 security predictions.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now