At a loss with Samba, FC4 and Win2k3 domain

Posted on 2006-04-05
Last Modified: 2010-03-18
I have tried everything I can think of and I still cannot get even a basic samba config to allow me to write to the share.  I get read access, but now write access.  

Have tried it under a simple "security=share" with a read only = no parameter in the share section.  I also have tried using valid users and guest ok.  Still just read only.  I have tried the spnego = yes for win 2k3, but nothing seems to work.  I know I am probably forgetting a step somewhere but it has escaped me.  What I want to do is create a linux file server for my Windows 2003 domain with it using domain credentials, but I cannot even get it to allow for it based on a simple samba config.  Anyone got any bright ideas that may cause me to bang my head on the table when I realize how stupid and blind I was.

By the way, SELinux and iptables have been disabled on this machine.  I have created both linux and samba users.  Still nothing but read only.
Question by:sr75
    LVL 17

    Expert Comment

    LVL 6

    Expert Comment

    Can you post you smb.conf file?
    LVL 3

    Accepted Solution

    Did you forget to set the filesystem permission on folder?

    # chmod 770  /home/sambashare

    In FC4, Samba works mostly out of the box.
    Minimum settings:-

    # vi /etc/samba/smb.conf

    path = /home/sambashare
    writable = yes
    browsable = yes
    comment = bla bla black ship

    # service  smb  restart
    # chkconfig smb on
    # smbpasswd -a  smbuser1

    Make sure you have the correct permission for the folders.

    LVL 15

    Author Comment

    Not sure what it was, because I had already done what you (kiitii) suggested.  But I tried it again and it worked.  Now I just need to get it to work the way I need it to do.

    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    How your wiki can always stay up-to-date

    Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
    - Increase transparency
    - Onboard new hires faster
    - Access from mobile/offline

    I have seen several blogs and forum entries elsewhere state that because NTFS volumes do not support linux ownership or permissions, they cannot be used for anonymous ftp upload through the vsftpd program.   IT can be done and here's how to get i…
    Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
    Sending a Secure fax is easy with eFax Corporate ( First, Just open a new email message.  In the To field, type your recipient's fax number You can even send a secure international fax — just include t…
    Access reports are powerful and flexible. Learn how to create a query and then a grouped report using the wizard. Modify the report design after the wizard is done to make it look better. There will be another video to explain how to put the final p…

    737 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    22 Experts available now in Live!

    Get 1:1 Help Now