We help IT Professionals succeed at work.

All mail stuck in 1 queue

robpendley
robpendley asked
on
Medium Priority
260 Views
Last Modified: 2006-11-18
Hi, thanks for any help in advance.

My setup:
we have 1 exchange server, that uses 2 smtp virtual servers.  One of them (SMTP1) routes all internal mail to the outside and recieves all mail.  The other one (SMTP2) recieves mail from our pop users on a different port (ie not 25) and sends mail out.  The default smtp connector shows SMTP1 as a local bridgehead.  This has worked fine for months.

Recently we had to switch external domain names for the exchange server.  I made all the changes I could think of, but not everything is working correctly.

Now, all mail received by SMTP2 gets stuck in its queue, but all in the same line item.  It says 'Default SMTP connector - _3oiasfpo8ajw4p984fa9ij(SMTP Connector - Remote delivery)' and then xx messages, where xx is the amount stuck in queue.  It doesn't have each email listed out separately, by domain, the way I've seen it before.  I can manually cut and paste the emails out of the SMTP2\Queue folder and into the SMTP1\Pickup folder, and it sends them right out.  SMTP1 works just fine.

I have not yet had the ptr record updated with the new domain name, so anything doing a reverse lookup might be having problems, but that would be across both SMTP servers, and I went ahead and changed the external name for SMTP2 to read 'mail.olddomain.com' to match the ptr record w/ the ISP, and that didn't change anything.

When I move the mails out of the SMTP2\Queue folder, the queue item  'Default SMTP connector - _3oiasfpo8ajw...'  still shows that it has the same amount of mails waiting to be delivered, but if I enumerate them, it shows them all to be blank (although they still have the original file sizes).  When I then select 'Delete All Messages (No NDR), it removes them, but stays in the queue showing 0 messages and 'retry'.  If I force connection, it switches to active for a minute, then back to 'retry'.

I have not yet tried to create an SMTP3 w/ the same config as SMTP2, and then disable SMTP2, but I will do so if necessary.  EDIT:  I created an SMTP3, deleted SMTP2, gave SMTP3 all of the settings from SMTP2, and it's doing the same thing.

Please help me figure out why my mails are getting stuck in SMTP2's queue.

Thanks.
Comment
Watch Question

Author

Commented:
Adding SMTP2 (now SMTP3) as a local bridgehead to the SMTP Connector fixed it.  It was not set this way before, though, so I still don't understand what happened.
Commented:
now smtp3 is configured as a local bidge head server so it is using smtp connector to send mails out for external users.

Not the solution you were looking for? Getting a personalized solution is easy.

Ask the Experts

Author

Commented:
Thanks,
I understand that, but I don't know how SMTP2 used to work without being a local bridgehead, yet now it won't work without being a local bridgehead.

Commented:
what are u usning to send emails dns or smart host?

Author

Commented:
DNS

Commented:
internal DNS with forwarders or External DNS?

please take a look on the following for Understanding SMTP and Exchange Server 2003
http://www.microsoft.com/technet/prodtechnol/exchange/guides/E2k3TransnRouting/0fe7e642-daec-4b1e-b9a9-836e38f2a776.mspx?mfr=true

Author

Commented:
Internal DNS with forwarders.  It's Exchange 2000, not 2003.
Access more of Experts Exchange with a free account
Thanks for using Experts Exchange.

Create a free account to continue.

Limited access with a free account allows you to:

  • View three pieces of content (articles, solutions, posts, and videos)
  • Ask the experts questions (counted toward content limit)
  • Customize your dashboard and profile

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.