font/printer problem with CR/Businessvision

Posted on 2006-04-05
Last Modified: 2013-12-03
On our old NT 4.0 Server system running Businessvision 32 v5.91 (which uses CR v8.0 for reports I believe) with an HP Laserjet 1200 printer, I always had trouble with a slightly modified "Invoice - Preprinted Forms - Laser.rpt" (which came with BV) and the standard HP 1200 PCL printer driver.  This report was changed (by someone I knew at the time with CR as it doesn't come with BV) so that the fields would fit properly on our preprinted invoices.  The area on the invoice where it itemizes the part number, description, and cost of what is being sold would come out (on screen in the CR and on the printer) with the bottom 1/8th or so of the text cut off .  I ended up installing an HP Laserjet III print driver and this problem no longer occured.  

We just added a new system  running XP Professional, which I am now using as the main BV workstation and server, networked to the old NT 4 box also running BV.  Everything else works fine, however when I go to print this same report (with the hp 1200 now connected to the XP box-automatically detected as a 1200 PCL by XP) this same old problem happens.  I tried my old solution with HP LJ III driver but no dice-same cut off text. If I go to the old machine and print the same report through the network to the same 1200 printer, it still works fine.  I noticed however, that on the new machine if I revert to the original "Invoice - Preprinted Forms - Laser.rpt" this problem does not occur, but of course the fields don't fit properly on our pages.  I have access to CR 10, and when I tried to open the report to change the font or something (it appears to be Ariel 8pt btw) I found that I could not resave the report because BV's CR won't open it.  I have been trying to track down a version of 8 (or someone who has it-im not very good at CR anyway) ,  but in the meantime I was wondering if anyone has any other ideas seeing as this form does seem to work with the HP III driver on NT 4.  Should I try installing an NT HP LJIII driver in XP?   Are there perhaps 1200 PCL driver settings I should change?  I'm pretty sure the problem is something to do with the CR Ariel font not calling the printer's Ariel font properly but I cannot really explain it or figure this out...
Sorry for the long post, hope this is in the right room.  Any help would be appreciated.  
I don't know how difficult this prob is but I'm setting it at 500 since you read and understood all that:)
Question by:ktronic
    LVL 100

    Accepted Solution

    I suspect the problem is the XP laser drivers are different.  I don't know if it will work or not but perhaps install the driver from the NT disks.

    LVL 26

    Assisted Solution

    by:Kurt Reinhardt
    1)  This is almost certainly printer driver related.  Additionally, as indicated by mlmcc, you're trying to use this old printer with a newer OS.  Is it possible to test this against a newer laser printer, preferably postscript?

    2)  You an still purchase CR8 by calling BusinessObjects directly, but it's expensive (I regularly purchase 8.5 for clients).  Here's a number to get started:  United States +1 866 681 3435.


    Featured Post

    Find Ransomware Secrets With All-Source Analysis

    Ransomware has become a major concern for organizations; its prevalence has grown due to past successes achieved by threat actors. While each ransomware variant is different, we’ve seen some common tactics and trends used among the authors of the malware.

    Join & Write a Comment

    Crystal Reports: 5 Tests for Top Performance It is complete, your masterpiece report.  Not only does it meet your customer’s expectations, it blows them out the water, all they want is beautifully summarised and displayed in a myriad of ways. …
    I hate sub reports and always consider them the last resort in any reporting solution.  The negative effect on performance and maintainability is just not worth the easy ride they give the report writer.  Nine times out of ten reporting requirements…
    Excel styles will make formatting consistent and let you apply and change formatting faster. In this tutorial, you'll learn how to use Excel's built-in styles, how to modify styles, and how to create your own. You'll also learn how to use your custo…
    Polish reports in Access so they look terrific. Take yourself to another level. Equations, Back Color, Alternate Back Color. Write easy VBA Code. Tighten space to use less pages. Launch report from a menu, considering criteria only when it is filled…

    745 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    16 Experts available now in Live!

    Get 1:1 Help Now