Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1477
  • Last Modified:

CAN SOMEBODY HELP ME INTERPRET AND SOLVE STOP ERROR 0XA

Whenever I plug in my HP photosmart 7550 printer I get a BSOD STOP Error:

IRQL_NOT_LESS-OR-EQUAL STOP: 0X0000000A (0X00000016, 0X00000002, 0X00000000, 0X804E469A)... The 4th parameter is sometimes 0x804DD69A. Without the printer installed everything works well, but I NEED TO PRINT!! I am running XP Pro SP2 with every latest driver and patch installed.

Can somebody please help me troubleshoot the faulty driver and solve this problem? Many thanks.
0
flittda
Asked:
flittda
1 Solution
 
Jay_Jay70Commented:
Hi flittda,

try rolling back to an older driver

Cheers!
0
 
simpswrCommented:
Or installing the driver from the cd prior to connecting the printer to the pc
0
 
flittdaAuthor Commented:
I'm using HP's original drivers... Moreover, I don't know how to roll back as the Device Manager only shows the printer drivers when the printer is plugged in.. which it doesn't allow without going to the STOP message.
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
flittdaAuthor Commented:
I installed the driver from the CD prior to connecting printer... This printer and this driver has worked in the past... recent work on my O/S including reinstallation has caused this incompatibility which I am now trying to troubleshoot.
0
 
AntunbCommented:
http://www.updatexp.com/stop-messages.html



remove the printer
click start >> Printers and faxes
right click the printer and delete


also unplug the printer, is it USB?

does this issue happen with other usb devices? have you tried different usb ports?


then reboot plug it back in and see what happens
0
 
scrathcyboyCommented:
Set a restore point (help and support, create restore point).  Remove the photosmart printer and all drivers. Remove service pack 2.  Install service pack 1 or 1a.  Reinstall the drivers for the Photosmart.  Does it work now?  If so, wait for an update compatible with service pack 2, from HP or elsewhere.

If this doesnt help, recover back to the original restore point you set in step 1 above.
0
 
flittdaAuthor Commented:
Antunb, I did as you said... good, simple suggestions, but I still get the same STOP error as soon as I plug the printer in. Yes, the printer is USB. This is the only USB device that gives me this error.

scrathcyboy...I will follow your tip later to seeif that works... Thanks
0
 
phototropicCommented:
Are you using front USB or rear? I've known pcs to bluescreen when the front USB is connected.

Try opening the case and disconnecting the front usb from the motherboard. Plug in the printer via rear usb and see how you go.
0
 
flittdaAuthor Commented:
Phototropic, what an unusual suggestion. My Toshiba Satellite has 3 USB ports...2 on the left and one on the right. I've tried all of them and they all bluescreen immediately when the printer is plugged in. However, every other USB device works perfectly on all three.
0
 
phototropicCommented:
I didn't realise you were plugging your printer into a laptop. I have repaired several desktop towers which bluescreened from the front USB, but would run from the rear once the front was disconnected from the m/board.
The problem definitely sounds like a driver issue. Could you try a system restore to a point before the most recent printer drivers were installed?
0
 
flittdaAuthor Commented:
Well, the 0xA error has now been replaced by another one: 0x0000007E (0XC0000005, 0XF7939C26, 0XF7B0288C, 0XF7B0258C) PartMgr.sys - Adress F7939c26. Again this error ONLY and ALWAYS occurs when I plug in the HP Photosmart printer. I then proceeded to uninstall HP PRINTER DRIVERS, uninstall SP2, INSTALL SP1, reinstall HP drivers and plug in printer as suggested by scrathcyboy... a lengthy, exercise. Would you believe I AM STILL GETTING THE SAME 0X07E STOPP ERROR whne I plug in the printer? By the way the Hard Drive is new and I did a comprehensive HD test with the Fujitsu disk checker which checked out OK. What else can I do?
0
 
flittdaAuthor Commented:
I think I found the culprit. It was: IEEE-1284.4 Compatible WDM Mass Storage Device (HPH11). When I reinstalled the HP Drivers, I accepted only those drivers that had to do with the HP 7550 print funtion. When it asked me to accept the installation of the WDM Mass Storage, I pressed "Cancel" and the rest of the installation worked! I can now use the printer again normally...though not the card reader function (which I never use anyway). I guess HP have not upgraded the WDM Mass Storage Device Driver to function properly in all cases with XP.

Thanks to all of you for suggestions, though in the end none of them worked... I am now trying to restore back to my original full SP2 configuration, but the Recovery Function doesn't want to (even though the restore point is on the calendar)... I guess I'll just have to reinstall SP2 and all the Security Patches.

If any of you or the Moderator feel that I should award the points, please let me know, as this is my first thread on this site, otherwise I consider this question closed.
0
 
flittdaAuthor Commented:
P.S. The solution above only worked for the remainder of the Windows Session. Upon rebooting, Windows XP redetected the conflicting Driver and gave the BSOD error again. To prevent this, uninstall and reinstall the HP Drivers. When you get to the question about accepting the installation of the WDM Mass Storage device, BEFORE PRESSING "CANCEL", go to Device Manager and DISABLE the photosmart printer card reader ((HPH11) which should have a yellow question mark before it. Then proceed to cancel or continue with installation. The Device will remain disabled and no more errors.

For the benefit of future readers who also get STOP PartMgr.sys errors when they plug in an HP Photosmart printer, I HAVE ISOLATED THE CONFLICTING DRIVER!!: It is SDDisk2k.sys, part of the SecureDoc encryption system. If you uninstall the SecureDoc software and then reinstall the HP drivers, they install with no problem (including the WDM Mass Storage device)... Hope my experience helps somebody.
0
 
GranModCommented:
PAQed with points refunded (500)

GranMod
Community Support Moderator
0

Featured Post

New feature and membership benefit!

New feature! Upgrade and increase expert visibility of your issues with Priority Questions.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now