setting up https server with existing vpn setup on pix 510

I am trying to set up a SSl web server on a Cisco Pix 510 that was already set up with a VPN.  When I make the changes the web server works great, but the VPN does not function.

I am new ( as in 2nd day looking at web info) at programming the PIX.
Any help would be appreciated

Here is the Original config

PIX Version 6.1(4)
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password tEzg4/5hClQ1Yb5O encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
hostname pixfirewall
domain-name ciscopix.com
fixup protocol ftp 21
fixup protocol http 80
fixup protocol h323 1720
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol sip 5060
fixup protocol skinny 2000
fixup protocol ftp 41
names
name 67.115.223.0 pixfirewall
access-list acl_out permit icmp any any
access-list 101 permit ip 192.168.1.0 255.255.255.0 192.168.2.0 255.255.255.0
pager lines 24
mtu inside 1500
ip address outside 12.44.216.246 255.255.255.248
ip address inside 192.168.1.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool bigpool 192.168.2.1-192.168.2.254
pdm location pixfirewall 255.255.255.128 outside
pdm location pixfirewall 255.255.255.0 outside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list 101
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
access-group acl_out in interface outside
route outside 0.0.0.0 0.0.0.0 12.44.216.241 1
timeout xlate 1:00:00
timeout conn 0:45:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h323 0:05:00 si
p 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
sysopt connection permit-pptp
no sysopt route dnat
crypto ipsec transform-set myset esp-des esp-md5-hmac
crypto dynamic-map dynmap 10 set transform-set myset
crypto map mymap 10 ipsec-isakmp dynamic dynmap
crypto map mymap client configuration address initiate
crypto map mymap client configuration address respond
crypto map mymap interface outside
isakmp enable outside
isakmp key ******** address 0.0.0.0 netmask 0.0.0.0
isakmp identity address
isakmp client configuration address-pool local bigpool outside
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption des
isakmp policy 10 hash sha
isakmp policy 10 group 1
isakmp policy 20 encryption des
isakmp policy 20 hash md5
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
vpngroup vpn-rx address-pool bigpool
vpngroup vpn-rx split-tunnel 101
vpngroup vpn-rx idle-time 1800
vpngroup vpn-rx password ********
vpngroup vpn-temp address-pool bigpool
vpngroup vpn-temp split-tunnel 101
vpngroup vpn-temp idle-time 1800
vpngroup vpn-temp password ********
telnet 12.44.216.0 255.255.255.0 outside
telnet 192.168.1.0 255.255.255.0 inside
telnet timeout 5
ssh timeout 5
vpdn group 1 accept dialin pptp
vpdn group 1 ppp authentication pap
vpdn group 1 ppp authentication chap
vpdn group 1 ppp authentication mschap
vpdn group 1 ppp encryption mppe auto
vpdn group 1 client configuration address local bigpool
vpdn group 1 ppp authentication mschap
vpdn group 1 ppp encryption mppe auto
vpdn group 1 client configuration address local bigpool
vpdn group 1 pptp echo 60
vpdn group 1 client authentication local
vpdn group 2 accept dialin pptp
vpdn group 2 ppp authentication pap
vpdn group 2 ppp authentication chap
vpdn group 2 ppp authentication mschap
vpdn group 2 ppp encryption mppe auto
vpdn group 2 client configuration address local bigpool
vpdn group 2 pptp echo 60
vpdn group 2 client authentication local
vpdn username ###### password ######## (omitted for question)
vpdn username ######## password ####### (omitted for question)
vpdn enable outside
dhcpd dns 203.241.132.34
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd auto_config outside
terminal width 80
Cryptochecksum:b0ae5ac1017f3fd5133c5c1382b7a63b

I added these lines:

pixfirewall(config)# access-list 101 permit tcp any host 12.44.216.246 eq 443
pixfirewall(config)# access-list 101 permit tcp any host 12.44.216.246 eq 21
pixfirewall(config)# access-list 101 permit tcp any host 12.44.216.246 eq 41
pixfirewall(config)# access-group 101 in interface outside
pixfirewall(config)# static (inside,outside) 12.44.216.246 192.168.1.10
aharsh75Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

calvinetterCommented:
Please post your most current config.  Sounds like ACL 101 (which in your case was used only for VPN traffic) got deleted & re-created.
0
calvinetterCommented:
 Actually, just try the following;  run these commands in this order:
no access-list 101
access-list 101 permit ip 192.168.1.0 255.255.255.0 192.168.2.0 255.255.255.0
nat (inside) 0 access-list 101

access-list acl_out permit icmp any any
access-list acl_out permit tcp any host 12.44.216.246 eq 443
access-list acl_out permit tcp any host 12.44.216.246 eq 21
access-list acl_out permit tcp any host 12.44.216.246 eq 41
access-group acl_out in interface outside
clear xlate

If still having problems, then post your most current config.

cheers
0
aharsh75Author Commented:
I didn't write the change to memory yet and when I show config it is the same.  
Do I need to write it to memory and the do a show config?
0
Introducing the "443 Security Simplified" Podcast

This new podcast puts you inside the minds of leading white-hat hackers and security researchers. Hosts Marc Laliberte and Corey Nachreiner turn complex security concepts into easily understood and actionable insights on the latest cyber security headlines and trends.

calvinetterCommented:
No, don't do 'write mem' yet.  Run the commands from my previous post, in the order they appear, then test.  
  Just be aware, in order to properly test outside access to the web server, you'll need to test from a PC *outside* your PIX, ie at another location.  The PIX won't let you access this web server by the public IP from internally.

cheers
0
lrmooreCommented:
Since you're new at PIX, I'll be gentle...

>PIX Version 6.1(4)
HIGHLY suggest you update this *old* version to the latest 6.3(5)
6.1 is very buggy...

given:
>ip address outside 12.44.216.246 255.255.255.248

The following line is going to screw you up royally....
>pixfirewall(config)# static (inside,outside) 12.44.216.246 192.168.1.10

Suggest instead:
 static (inside,outside) 12.44.216.246 192.168.1.10
 clear xlate
 static (inside,outside) tcp 12.44.216.246 443 192.168.1.10 443 netmask 255.255.255.255

IF you update to 6.3(x) you can use the keyword "interface" in the static:
  static (inside,outside) tcp interface 443 192.168.1.10 443 netmask 255.255.255.255

calvin - how'd you miss that?
Else Calvin has the access-list entries correct

0
calvinetterCommented:
doh!! you're right lrmoore.  static nat entry is incorrect.  Not a good excuse for that one!  Yep, agree that this version of PIX is pretty ancient.

cheers
0
lrmooreCommented:
Double  DOH!
I just noticed a typo in my post:

Suggest instead:
==> no static (inside,outside) 12.44.216.246 192.168.1.10
 clear xlate
 static (inside,outside) tcp 12.44.216.246 443 192.168.1.10 443 netmask 255.255.255.255
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
calvinetterCommented:
Whew, I don't feel *quite* so bad now.  ;)

cheers
0
aharsh75Author Commented:
Couldn't do the upgrade because we don't have a sales contract.

Here is the settings that worked:


pixfirewall(config)# access-list 101 permit tcp any host 12.44.216.246 eq 443
pixfirewall(config)# access-list 101 permit tcp any host 12.44.216.246 eq 41
pixfirewall(config)# access-list 101 permit tcp any host 12.44.216.246 eq 21
pixfirewall(config)# access-group 101 in interface outside
pixfirewall(config)# static (inside,outside) tcp 12.44.216.246 443 192.168.1.10 443 netmask 255.255.255.255
pixfirewall(config)# static (inside,outside) tcp 12.44.216.246 41 192.168.1.10 41 netmask 255.255.255.255
pixfirewall(config)# static (inside,outside) tcp 12.44.216.246 21 192.168.1.10 21 netmask 255.255.255.255


Thanks guys for the help - it was well worth the $90 yearly fee.

I will have to award the points to lrmoore since it was the static entry that was causing the problem.  Thanks for you help too calvinetter.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Software Firewalls

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.