?
Solved

sqlplus works as root or oracle but not as other users

Posted on 2006-04-05
9
Medium Priority
?
4,440 Views
Last Modified: 2013-12-11
Similar scenario to previous post: Oracle client on Citrix terminal server, but did not see information there to resolve the issue.

Sunblade platform, solaris 8, oracle 10g r 2

I am seeing the same issue with sqlplus running fine when logged in as root or as user oracle but failing for other users.

The error I get when logged in to my personal account and type sqlplus is:

SP2-1503: Unable to initialize Oracle call interface
SP2-0152: ORACLE may not be functioning properly

I did not find any information in the Oracle 10g docs that was useful to resolve this; is this a security measure in 10g to restrict sqlplus access?

Any advice to resolve or pointers to additional info appreciated.
0
Comment
Question by:alyssahacker
  • 4
  • 3
8 Comments
 
LVL 4

Expert Comment

by:meluhk
ID: 16400609
Try unsetting ORACLE_HOME.  You are using instant client it seems and this has been reported as a solution.  
0
 

Author Comment

by:alyssahacker
ID: 16401585
If you unset ORACLE_HOME, it then complains about :

Error 6 initializing SQL*Plus
Message file sp1<lang>.msb not found
SP2-0750: You may need to set ORACLE_HOME to your Oracle software directory

The suggested fix to this issue is to set ORACLE_HOME.....
0
 
LVL 4

Expert Comment

by:meluhk
ID: 16403257
I would normally agree with you alyssahacker... but this seems to be about instant client --- based on the errors reported.  The point of instant client is to not have to set the environment variables.  Unsetting ORACLE_HOME has been reported to be a solution.   I am not using instant client so cannot test this.  

I went to Oracle and found the following about instant client if this is what you are using:
1. Download the appropriate Instant Client packages for your platform. All installations REQUIRE the Basic or Basic Lite package.

2. Unzip the packages into a single directory such as "instantclient".

3. Set the library loading path in your environment to the directory in Step 2 ("instantclient"). On many UNIX platforms, LD_LIBRARY_PATH is the appropriate environment variable. On Windows, PATH should be used.

4. Start your application and enjoy.

So I would remove oracle products from the PATH environment variable, unset ORACLE_HOME and ORACLE_SID, and add the instant client directory to the LD_LIBRARY_PATH.

If you are not using instant client, then this is a wrong direction.
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Author Comment

by:alyssahacker
ID: 16403340
The installation is (10.2.0.1.0) for Solaris OS (SPARC); the Oracle DB is local to the machine, I'm not using instant client.
0
 
LVL 4

Accepted Solution

by:
meluhk earned 1000 total points
ID: 16403573
Ok, sorry for the sidetrack.

There is a note (Note:4516865.8) on Metalink about a Bug on wrong permissions set on some files following installation of 10.2.0.1.    It states to set the peremissions manually, giving world read and execute.  I would open a SR with Oracle and make sure to get the correct permissions to set instead of wide open world read/execute as a blanket statement though.
0
 
LVL 4

Assisted Solution

by:meluhk
meluhk earned 1000 total points
ID: 16403585
This is related to bug #4516865.
0
 

Author Comment

by:alyssahacker
ID: 16404997
I googled and found the following commentary related to this bug report number in metalink:
All credit for the following words goes to
http://laurentschneider.blogspot.com/2005/10/metalink.html
If he exists as an expert in this forum, hope he gets some points too. Thanks for the pointer to the bug report, meluhk.

Since a few days, I have been wondering why a non-dba user was not able to do sqlplus in 10gR2. Well, I saw the bug 4516865 on metalink for 9.2.0.7 and 10.2.0.1, but did not agree that it is a "desirable improvement", imho it is a major lost of service.

Just a few minutes (seconds?) after I finished writing my iTar, severity 2, I received a call from Oracle Support.

Apparently a group of customers asked to prevent any non-dba user from using sqlplus on a database server (just on the client). This kind of answer I do not like. But we had a long talk, he finally showed me a workaround for 10.2.0.1 : doing

chmod -R 755 $ORACLE_HOME

before root.sh.
0
 
LVL 2

Expert Comment

by:shahidns
ID: 16411383
Sorry, saw the post too late, else would have told you the same thing as Oracle support did to change the permissions for the Oracle_home directory.

Had exactly the same problem some time back and solved it by changing the permissions. But I changed the permissions after the entire and installation and after root.sh.

Regards.
Shahid.
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Why doesn't the Oracle optimizer use my index? Querying too much data Most Oracle developers know that an index is useful when you can use it to restrict your result set to a small number of the total rows in a table. So, the obvious side…
How to Unravel a Tricky Query Introduction If you browse through the Oracle zones or any of the other database-related zones you'll come across some complicated solutions and sometimes you'll just have to wonder how anyone came up with them.  …
This video shows setup options and the basic steps and syntax for duplicating (cloning) a database from one instance to another. Examples are given for duplicating to the same machine and to different machines
Via a live example, show how to take different types of Oracle backups using RMAN.
Suggested Courses

809 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question