?
Solved

PREVENT USER FROM MOVING FOLDERS

Posted on 2006-04-05
12
Medium Priority
?
654 Views
Last Modified: 2012-06-22
I have a Netware 5.1 server and a combination of windows-xp & windows-98 users.
Is there a way to prevent a user / users from moving folders.
Every time they move a folder I have to redo all the access right for all users when the folder is put back where it belongs. Thank you for any help that you can provide.
0
Comment
Question by:ramramcat
  • 5
  • 3
9 Comments
 
LVL 35

Accepted Solution

by:
ShineOn earned 2000 total points
ID: 16392616
To prevent moving of folders, you'd have to disable the "modify" right.  That might make it hard for the users to do anything, because the contents of a folder inherit the rights of the folder.

Another way would be to set the "rename inhibit" and "delete inhibit" extended attribute on all the folders.  You should be able to do that using a FLAG command, from the root directory of your user volume(s), selecting only directories and doing it recursively.  Note that you need to do it with the mapped drive as your current drive, from a CMD prompt/DOS window.  

FLAG *.* +RI +DI /DO /S

should do it.

You can do FLAG /? to see helps, and FLAG /? ALL will give you all the helps.  Do it from a NetWare mapped drive, or you'll only see the limited subset of functions that apply to a local drive.

Note that I have the plus sign before the attribute, which will add the attribute to existing attributes.  If you omit the plus it wil change the attributes to just what you specify, IIRC.
0
 
LVL 35

Expert Comment

by:ShineOn
ID: 16392644
Or, you can break their fingers when they drag&drop a network folder with Windoze Explorer.  Eventually, they'll learn ;)

Note that in any case, you'd have to keep up on it - newly created folders won't have those attributes...
0
 

Author Comment

by:ramramcat
ID: 16398129
Hi ShineOn - Thanks for the fast response - really appreciated.

I typed the following at a command prompt:
FLAG *.* +RI +DI /DO /S

The following message was displayed:
905: This utility was unable to initialize the country information.

Is there a setting in Windoze for this?
Thanks
Richie
0
Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
LVL 35

Expert Comment

by:ShineOn
ID: 16402603
Are you using the appropriate Novell client for your workstation OS, or are you using the crapware(tm) client that comes with Windoze?

If it's the crapware(tm) client you get with Windoze, you're going to have this kind of error.  It's deliberately crippled and has minimal connectivity functionality.  For any management-type functions you must use a Novell-provided client.
0
 

Author Comment

by:ramramcat
ID: 16406015
Hi ShineOn -

I am using the Novell Client 4.91 - Windoze-XP-PRO SP2

Thanks,
Richie
0
 
LVL 35

Expert Comment

by:ShineOn
ID: 16407684
Hmmm. Do you have sys:\public search mapped?  Are you using a localized version of NetWare?  Is the client the full, multilingual version or english-only?  (I don't know if they have english-only of 4.91 but they did for 4.90...)
0
 
LVL 1

Expert Comment

by:bconrey
ID: 16509402
If you're using a current Novell client and the user is moving folders on the server (not moving from server to workstation to server again), the extended Netware attributes like rights, etc should be moved with the files and folders.
0
 
LVL 35

Expert Comment

by:ShineOn
ID: 16511447
bconrey, The goal is to prevent users from moving folders around, not to maintain extended attributes during a move.  

ramramcat - try moving down a folder level - I've had problems running flag from the root of a volume.  Say, for example, your user folders are on VOL1: in a folder called DATA, and you have G: mapped to VOL1:\

In your CMD window, change to G:, so your'e at G:\> prompt, and then CD to DATA, so you're at G:\DATA> before issuing your FLAG *.* +RI +DI /S /DO command, rather than doing it at G:\>.
0
 

Author Comment

by:ramramcat
ID: 16795667
SORRY FOR NOT RESPONDING - WAS ON VACATION - BUT I HAVE NOT BEEN ABLE TO RESOLVE THE PROBLEM
0

Featured Post

Important Lessons on Recovering from Petya

In their most recent webinar, Skyport Systems explores ways to isolate and protect critical databases to keep the core of your company safe from harm.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

LinkedIn blogging is great for networking, building up an audience, and expanding your influence as well. However, if you want to achieve these results, you need to work really hard to make your post worth liking and sharing. Here are 4 tips that ca…
Exchange administrators are always vigilant about Exchange crashes and disasters that are possible any time. It is quite essential to identify the symptoms of a possible Exchange issue and be prepared with a proper recovery plan. There are multiple…
Exchange organizations may use the Journaling Agent of the Transport Service to archive messages going through Exchange. However, if the Transport Service is integrated with some email content management application (such as an anti-spam), the admin…
This lesson discusses how to use a Mainform + Subforms in Microsoft Access to find and enter data for payments on orders. The sample data comes from a custom shop that builds and sells movable storage structures that are delivered to your property. …
Suggested Courses

840 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question