WinXP can't read content from old harddisk

Originally I was using 2 IDE HDs:
Segate 80GB: primary, partitioned as c: & d:
Maxtor 160GB: secondary, partitioned as h: & i:

Recently I bought new motherboard, CPU, and HD. The new HD is a SATA-II Maxtor 250GB.

I replaced the hardwares, partitioned the new HD as c: & d:, and reinstalled WinXP Pro SP2. It worked fine.

Then I wanted to retrieve the files from my old HDs. First I plugged back the Segate80GB. Once I entered Windows, it's automatically mapped as g: and h:. No problem here.

Problem came on the Maxtor160GB. I unplugged Segate80GB, and plugged back Maxtor160GB. I changed the jumper to set it as primary. It was successfully recognized by BIOS. I could also see it in WinXP device manager.

However, it was not shown in Windows Explorer, not mapped as any drive. So I went to My Computer --> Manage --> Disk Management. I found that it was categorized as "Dynamic Disk", while the SATA-II HD was categorized as "Basic Disk".

Without knowing what's the difference, I tried to change the Maxtor160GB from "Dynamic" to "Basic". But windows said this would delete all contents from the HD. So I just cancelled it.

Then I googled about what this "Dynamic Disk" is. It seemed that, for a "Dynamic Disk", the partition info is not stored on the disk itself. Does that mean the history that I partitioned it into h: and i: was already lost? Does that mean its contents is unreadable now?
wcleung9Asked:
Who is Participating?
 
AlexGGGGCommented:
1. You need to check if your 160GB drive is recognized in full capacity.
See this reference for details: http://support.microsoft.com/default.aspx?scid=kb;en-us;303013

2. Once confirmed that the drive is recognized as 160 GB (NOT 128GB, NOT 137GB), open disk management. Right click the disk in question, select "Import Foregin Disks". Cannot recall exactly what you should right click at, either the "Disk 1" (left side of the view) or on the partition itself, but it is there somewhere.

3. Once the import is done, you may need to assign drive letters manually, that is -- right click the partition, click "Change Drive Letter and Path", add drive letter, OK.

This should do the trick.
0
 
arkoakCommented:
contents are fully readable as long as you do not ovewrite them
All you need is a data recovery software.
R-studio www.r-tt.com/ is a nice application, you can first try it if it works, you may need to buy it to recover all data

some free applications of data recovery are also availaible around there
one such is listed at http://www.freewarepro.com/showFile.php?FileID=233
i have not used it but it maybe useful in case you dont want to spend money on recovering the not so important but useable data.

0
 
Dushan De SilvaTechnology ArchitectCommented:
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
wcleung9Author Commented:
Thx AlexGGGG, it's done!!

I did notice that option "import foreign disk", but I dared not to try it as I didn't know what it does.

Also thx others for providing me tools to use.


One strange thing is that the 2 partitions were imported as NTFS, while I remember they should be FAT32.
0
 
AlexGGGGCommented:
But the data is there, readable and valid, correct?
0
 
wcleung9Author Commented:
yes, I can read the data now~~
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.