CISCO PIX 501 DHCP

Hello,

I am currently configuring a Cisco PIX 501 firewall. However, whenever I try to configure IP address on it, I get an error message saying 'Interface address is not on same subnet as DHCP poolroute'. So I figured out that PIX is acting as a DHCP server. What I really want to do is disable this function. I've ran through several commands to no avail.

Somebody please help!

Cytrax
LVL 3
cytraxAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Cyclops3590Commented:
first do
show run | grep dhcpd
look for the line with
dhcpd address <start IP>-<end IP> inside

copy that line down and put a no before it
example, by default it should like like this
dhcpd address 192.168.1.2-192.168.1.254 inside
although the range may be different depending upon the license you have on your 501, I have an unlimited license so it spans the entire class C
so if that's what is says then you type
no dhcpd address 192.168.1.2-192.168.1.254 inside

this will get rid of the range and automatically turn off the dhcp server on the firewall
now you should be able to change the IP of the 501
0
mh144831Commented:
To disable DHCP through the GUI you need to do the following in V.7

Click on the Configuration tab across the top

Click on Properties down the left hand side

Click the + next to DHCP services in the middle list.

Click on DHCP Server.

This is where you are able to Enable and Disable DHCP
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
cytraxAuthor Commented:
Thank you for reply.

@ Cyclops3590: I have tried what you suggested. However I get this error message: 'Type help or '?' for a list of available commands'. This is because I think the version of IOS on PIX 501 is only a fraction of the real deal, which is why I'm having this problem.

@ mh144831: I will try you suggestion. I guess stupid enough to think command line would save. Back to good old GUI then.

I'll keep you posted.

Cytrax
0
Cyclops3590Commented:
are you in global mode when you try this command your command line needs to look like this
pix(config)#
0
cytraxAuthor Commented:
Hello guys,

Yes, I was running all the commands in config mode. I think the IOS on the firewall is limited. However, I was able to use GUI like mh144831 suggested. It was pretty straight forward from there. It's a shame I can't do it all from command mode. Thanks for the all your contributions.

Cytrax
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Software Firewalls

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.