VPN/Firewall router and WINS on a Windows 2003 Server

Hi All,

I have a single NIC Windows 2003 Server and a Netgear FVS318v3 with the latest firmware.

Every 40 mins the server sends a multicast message (IGMP) out to find WINS partners to 224.0.0.22 then follows it up on UDP 42 to address 224.0.1.24

The router promtly replys to this message with a ICMP "Destination Unreachable" message which the server then promtly reports as an error:

Event Type:      Error
Event Source:      Wins
Event Category:      None
Event ID:      4204
Date:            06/04/2006
Time:            13:56:13
User:            N/A
Computer:      OURSERVER
Description:
WINS could not read from the User Datagram Protocol (UDP) socket.

I know this is programmed behaviour as the server is looking for WINS partners but is there anything I can do to prevent this. I have found a few guides on how t do this for Windows 2000 server but the registry keys are different for 2003.

Any help would be much appreciated.

Regards

Guy_Adams
LVL 2
Guy_AdamsAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

f_umarCommented:
This message means that WINS was unable to receive a name packet. Stop the WINS service. Then double-click Network in the Control Panel. Under the Protocols tab, verify that the TCP/IP driver is installed and running. Restart WINS if necessary to correct the problem." We have seen reports on this problem even when the TCP/IP seems to be running fine.

also give the Local System account read rights to the following registry key:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurePipeServers\winreg
Guy_AdamsAuthor Commented:
Thank you for the response but I have already tried that.

Also %Systemroot%\System32\Wins has the correct permissions.

Any other ideas?

Regards

Guy_Adams
Guy_AdamsAuthor Commented:
I've managed to trace the packets which cause the error, i just need to disable the behaviour either on the server or on the router.

Regards

Guy_Adams
f_umarCommented:
I have found that it is best not to set up WINS. it does not actually needs in Windows2003 this error causing because of router response, u either unintall the wins service if u dont really need it, or stop the router reply if u can or u can edit the registry and extend the time to attempt for discovery and safely ignore this error, because it does not effect on any thing in your network. more you can statically define a replication partner.

for registry settings check this
http://support.microsoft.com/?id=151761

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Guy_AdamsAuthor Commented:
Thanks again f_umar,

I think to be honest I will end up leaving it as in less than 14 days we have a new remote DC being put in place at another office conncted via a WAN link.

I wonder if a static route for the multicast address sent over the VPN to the new DC would resolve the issue?

I have rewarded the points to you for a swift response.

Thank you

Regards

Guy_Adams
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2003

From novice to tech pro — start learning today.