We help IT Professionals succeed at work.

We've partnered with Certified Experts, Carl Webster and Richard Faulkner, to bring you a podcast all about Citrix Workspace, moving to the cloud, and analytics & intelligence. Episode 2 coming soon!Listen Now

x

Backup of MS Exchange 2000 takes a long time with Veritas Backup Exec.

Penford-DCO
Penford-DCO asked
on
Medium Priority
593 Views
Last Modified: 2013-12-01
The backup of my MS Exchange server has been taking between 4 and 12 hours.  

The total store is 50 GB and I am using Windows 2000 SP4+ with Exchange SP3+.   The server is connected via 1 GB Ethernet Swtiched to the Backup server and then things are sent to tape (LTO2 tape).  The backup agent I am running is Veritas Backup Exec for Windows Server 9.1 with the Exchange Agent.

I run the backup as a combination of Full /Copy backup (flush committed logs) for Exchange and incremental backups on the file servers.  On the weekend a full backup is run on both the Exchange box and the file servers.

In the process of debugging the issue (because it seems random), I check the MS logs for application errors and warnings. Nothing appears and the system is running at a whopping 1% CPU utilization.   The VM for the mail store is not low and it is generally a week to two weeks before I see the Fragmentation issue (Event ID 9582) in the Applicaiton logs.  Per the MS KB, the solution is to restart Exchange and whallah - all is happy.  As an experiment, I have restarted the Exchange services before backup to see if that has an effect.  Nada.

Any ideas as to what may be happening?
Comment
Watch Question

CERTIFIED EXPERT
Most Valuable Expert 2015
Commented:
The 1% CPU use, is that the exchange, backup or both boxes? Have you tried disabling AV online scans while the backup runs?

Not the solution you were looking for? Getting a personalized solution is easy.

Ask the Experts

Author

Commented:
The CPU utilization is on the exchange server.

I think you may be on to something because the server AV scans are scheduled to run between 1 and 4 AM.  The job starts at 6:00 PM with the Exchange server.   Something about the brick level backup might be running into the AV scans.  

Alternatively, are you recommending disabling the AV for Exchange during this time?

Commented:
how much ram. also page file size. the backup agent doesent use alot of processor because compretion is done on the backup server or tape drive. ram is the most important thing for an exchange backup. I had a server with 1gb ram and a 2gb page file and backup was about 19mb per minute I uped it to 3GB and added the /3GB switch to the boot.ini and my backup rate went to 700MB per minute. dont expect speeds like this as this has 2 dualcore 3.4 xeons and a agregate quad gigabit connection to the network.

never expect exchange to perform as fast as your other servers in a backup becuase this is done without unmounting the database. if you unmount the database and do a direct file backup it will speed up considerably but this is not recomended and very rearly done.

upgrade the backup agent, do a defrage of the exchange database(find instructions it is not done normaly) and give that sucker some extra ram, also if you have 3GB or more or ram you must add the /3GB switch to the Boot.ini or will not take advantage of it.

Author

Commented:
I'll give it a whirl.   The memory on the box is 1.5GB with a 1.5 GB page file.   I also recompiled the Backup job given that I had recently disabled some accounts.    Also, I restarted the box (though I question the benefit, but it makes me feel better.)

For the defragging, etc; I am going to hold off until the weekendl backup is completed.

I'll let you know.  Thanks.

Commented:
set your page file to 3GB(2 x phisical memory) the defrage will help alot if you have never done it and the box has been running for aver a couple of months. I wish I could help you on the process but I havent done it for a while I just remember that it is not just a simpe defrag. I belive there is a MS KB artical on it. if not I know there is a Veritas KB artical.
CERTIFIED EXPERT
Most Valuable Expert 2015

Commented:
Yes, disable AV during backup, and if AV also runs on the backing up server, disable it there too. After the job you can enable it again. This shouldn't be a problem, as the users should also have AV setup on their boxes, and the scheduled AV scan should also catch virii.

Commented:
it doesent sound like an AV problem as it is only effecting the Exchange server. it may just be that this is as fast as the exchange server can go with a running database. test it out by unmounting the databases and doing the offline backup, I bet the speed is equivlent to your other servers.
Commented:
Hi,

I would expect it to be a AV problem also.  What make of AV are you using?

It's usualy to do with the email AV being set to scan message on open.  If it's Symantec it will have a time out of 5000ms or something stupid like that.  

You could look for an option that says "scan on open" and disable it.  it's unlikely that an email from 2 years ago is going to be suddenly infected with a virus.

Also look for any updates to your AV.  (service pack wise or new version).

Steve

Author

Commented:
I looked at the above comments and looked at the AV issue.   I'll verify that Exchange is degragging.  

The current engine is Symantec Mail Security for MS Exchange Version 4.6.108.

I think all were on to something with the AV.  One of the things I do is check the VM bytes for Exchange.  Once they fall to around 20%, I restart the IIS services which inturn restarts all of the Exchange services.   However, when this was done, the AV software had an option to re-scan the entire store when restarted.  Also, the store was rescanned when definitions were updated.  So, even though the CPUs were not showing much more than 25% utilization, there appears to have been contention on the store between Veritas and Symantec (how ironic).

I have deselected the option and am running a test.  For two nights, the backups are finishing in a relatively normal 4 hours.

Author

Commented:
Sounds fine.  I resolved the issue via alternative sources.
Access more of Experts Exchange with a free account
Thanks for using Experts Exchange.

Create a free account to continue.

Limited access with a free account allows you to:

  • View three pieces of content (articles, solutions, posts, and videos)
  • Ask the experts questions (counted toward content limit)
  • Customize your dashboard and profile

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.