?
Solved

Cisco Config Single ATM to Dual ATM Config

Posted on 2006-04-06
7
Medium Priority
?
747 Views
Last Modified: 2013-12-03
I'm looking to change from a single ATM to a dual ATM backbone.  What will change in my (Cisco 2620) config?  I'll be installing the second ATM circuit to ATM 1/1.  See below for present config...

!
version 12.2
service timestamps debug datetime msec localtime
service timestamps log datetime msec localtime
no service password-encryption
!
hostname NOC
!
logging buffered 8000 debugging
enable username password
!
ip subnet-zero
!
!
no ip domain-lookup
ip dhcp excluded-address 192.168.21.1 192.168.21.160
ip dhcp excluded-address 192.168.21.180 192.168.21.255
ip dhcp excluded-address 192.168.2.1 192.168.2.169
ip dhcp excluded-address 192.168.2.180 192.168.2.255
ip dhcp excluded-address 192.168.3.1 192.168.3.169
ip dhcp excluded-address 192.168.3.180 192.168.3.255
ip dhcp excluded-address 192.168.6.1 192.168.6.169
ip dhcp excluded-address 192.168.6.180 192.168.6.255
ip dhcp excluded-address 192.168.8.1 192.168.8.169
ip dhcp excluded-address 192.168.8.180 192.168.8.255
ip dhcp excluded-address 192.168.12.1 192.168.12.169
ip dhcp excluded-address 192.168.12.180 192.168.12.255
ip dhcp excluded-address 192.168.13.1 192.168.13.169
ip dhcp excluded-address 192.168.13.180 192.168.13.255
!
ip dhcp pool NOC
   network 192.168.21.0 255.255.255.0
   domain-name domainname
   dns-server 192.168.21.35 192.168.21.45
   netbios-name-server 192.168.21.35 192.168.21.45
   netbios-node-type h-node
   default-router 192.168.xxx.xxx
!
ip dhcp pool NE
   import all
   network 192.168.3.0 255.255.255.0
   default-router 192.168.3.1
   lease 5
!
ip dhcp pool SL
   import all
   network 192.168.8.0 255.255.255.0
   default-router 192.168.8.1
   lease 5
!
ip dhcp pool CC
   import all
   network 192.168.2.0 255.255.255.0
   default-router 192.168.2.1
   lease 5
!
ip dhcp pool SW
   import all
   network 192.168.6.0 255.255.255.0
   default-router 192.168.6.1
   lease 5
!
ip dhcp pool AR
   import all
   network 192.168.7.0 255.255.255.0
   default-router 192.168.7.1
   lease 5
!
ip dhcp pool WH
   import all
   network 192.168.12.0 255.255.255.0
   default-router 192.168.12.1
   lease 5
!
ip dhcp pool NW
   import all
   network 192.168.13.0 255.255.255.0
   default-router 192.168.13.1
   lease 5
!
ip audit notify log
ip audit po max-events 100
!
isdn switch-type basic-ni
call rsvp-sync
!
!
!
!
!
!
bridge irb
!
!
interface FastEthernet0/0
 ip address 192.168.xxx.xxx 255.255.255.0
 speed 100
 full-duplex
 no cdp enable
!
interface BRI0/0
 no ip address
 shutdown
 isdn switch-type basic-ni
 no cdp enable
!
interface ATM1/0
 description connected to SBC FRATM  45.HCGJ.xxxxxx
 no ip address
 no atm ilmi-keepalive
 no scrambling-payload
!
interface ATM1/0.2 point-to-point
 description connected to City Center via ADSL RLAN  @ 1.5/1.5Mbps
 pvc 2/102
  encapsulation aal5snap
 !
 bridge-group 2
 bridge-group 2 spanning-disabled
!
interface ATM1/0.3 point-to-point
 description connected to Northeast via ADSL RLAN  @ 256/768Kbps
 pvc 6/100
  encapsulation aal5snap
 !
 bridge-group 3
 bridge-group 3 spanning-disabled
!
interface ATM1/0.4 point-to-point
 description connected to Arlington Abrams via ADSL RLAN  @ 256/768K
bps
 pvc 2/104
  encapsulation aal5snap
 !
 bridge-group 4
 bridge-group 4 spanning-disabled
!
interface ATM1/0.5 point-to-point
 description connected to Melinda via FRS 45.HXGM.xxxxxx @ 128Kbps
 ip address 192.168.205.2 255.255.255.252
 pvc 3/105
  encapsulation aal5snap
 !
!
interface ATM1/0.6 point-to-point
 description connected to Southwest via FRS 45.HXGS.xxxxxx @ 512Kbps
 ip address 192.168.206.2 255.255.255.252
 pvc 3/106
  encapsulation aal5snap
 !
!
interface ATM1/0.7 point-to-point
 description connected to Arlington via ADSL RLAN @ 256/384Kbps
 pvc 2/107
  encapsulation aal5snap
 !
 bridge-group 7
 bridge-group 7 spanning-disabled
!
interface ATM1/0.8 point-to-point
 description connected to Southlake via FRS 45.HXFM.xxxxxx @ 768Kbps
 ip address 192.168.208.2 255.255.255.252
 pvc 3/108
  ubr 1000
  encapsulation aal5snap
 !
!
interface ATM1/0.9 point-to-point
 description connected to Westside via ADSL RLAN @ 128/384Kbps
 pvc 2/109
  encapsulation aal5snap
 !
 bridge-group 9
 bridge-group 9 spanning-disabled
!
interface ATM1/0.10 point-to-point
 description FRATM to Grapevine via FRS 45.HXGS.xxxxxx @ 128Kbps
 ip address 192.168.210.2 255.255.255.252
 pvc 3/110
  encapsulation aal5snap
 !
!
interface ATM1/0.11 point-to-point
 description connected to ACS/Title Records via ADSL RLAN @ 384/384
Kbps
 pvc 2/114
 !
 bridge-group 11
 bridge-group 11 spanning-disabled
!
interface ATM1/0.12 point-to-point
 description connected to Warehouse via ADSL RLAN 817 @ 128/384Kbps
 pvc 2/112
 !
 bridge-group 12
 bridge-group 12 spanning-disabled
!
interface ATM1/0.13 point-to-point
 description FRATM to Northwest via FRS 45.HXGS.xxxxxx
 ip address 192.168.213.2 255.255.255.252
 pvc 3/113
  encapsulation aal5snap
 !
!
interface ATM1/0.14 point-to-point
 description connected to Title Records via FRS 45.HXGS.xxxxxx
 ip address 192.168.214.2 255.255.255.252
 pvc 3/114
  encapsulation aal5snap
 !
!
interface ATM1/1
 no ip address
 shutdown
 no atm ilmi-keepalive
 no scrambling-payload
!
interface ATM1/2
 no ip address
 shutdown
 no atm ilmi-keepalive
 no scrambling-payload
!
interface ATM1/3
 no ip address
 shutdown
 no atm ilmi-keepalive
 no scrambling-payload
!
interface BVI2
 description connected to City Center via ADSL RLAN @ 1.5/1.5Mbps
 ip address 192.168.202.2 255.255.255.252
 clns mtu 1514
!
interface BVI3
 description connected to Northeast via ADSL RLAN @ 256/768Kbps
 ip address 192.168.203.2 255.255.255.252
 clns mtu 1514
!
interface BVI4
 description connected to Arlington Abrams via ADSL RLAN @ 256/768K
bps
 ip address 192.168.204.2 255.255.255.252
 clns mtu 1514
!
interface BVI7
 description connected to Arlington via ADSL RLAN @ 256/384Kbps
 ip address 192.168.207.2 255.255.255.252
 clns mtu 1514
!
interface BVI9
 description connected to Westside via ADSL RLAN @ 128/384Kbps
 ip address 192.168.209.2 255.255.255.252
 clns mtu 1514
!
interface BVI11
 description connected to ACS / Title Records via ADSL RLAN @ 384/3
84Kbps
 ip address 192.168.211.2 255.255.255.252
 clns mtu 1514
!
interface BVI12
 description connected to Warehouse via ADSL RLAN @ 128/384Kbps
 ip address 192.168.212.2 255.255.255.252
 clns mtu 1514
!
router eigrp 1
 network 10.0.0.0
 network 192.168.21.0
 network 192.168.202.0
 network 192.168.203.0
 network 192.168.204.0
 network 192.168.205.0
 network 192.168.206.0
 network 192.168.207.0
 network 192.168.208.0
 network 192.168.209.0
 network 192.168.210.0
 network 192.168.211.0
 network 192.168.212.0
 network 192.168.213.0
 network 192.168.214.0
 no auto-summary
 no eigrp log-neighbor-changes
!
ip classless
no ip http server
ip pim bidir-enable
!
logging source-interface FastEthernet0/0
logging 192.168.21.45
no cdp run
!
bridge 2 protocol ieee
bridge 2 route ip
bridge 3 protocol ieee
bridge 3 route ip
bridge 4 protocol ieee
bridge 4 route ip
bridge 7 protocol ieee
bridge 7 route ip
bridge 9 protocol ieee
bridge 9 route ip
bridge 11 protocol ieee
bridge 11 route ip
bridge 12 protocol ieee
bridge 12 route ip
!
dial-peer cor custom
!
!
!
!
!
line con 0
line aux 0
 transport input all
 stopbits 1
 flowcontrol hardware
line vty 0 4
 password smokey!!!
 login
!
end

NOC#enable

Thanks guys,
Keith
0
Comment
Question by:kbratton1
  • 4
  • 3
7 Comments
 
LVL 12

Expert Comment

by:pjtemplin
ID: 16405010
Are you increasing the available bandwidth overall, or moving some PVCs to the second port?

If #1, you'll probably need to coordinate a migration window to move each PVC over to an IMA (Inverse Multiplexing over ATM) group.  The interfaces are something like:

interface ATM1/0
 no ip address
 atm ilmi-keepalive
 ima-group 0
 no scrambling-payload
!
interface ATM1/IMA0.1 point-to-point
 description test interface
 ip address 192.168.200.1 255.255.255.0
 pvc name 2/35
  oam-pvc manage 60
  encapsulation aal5snap
 !

SBC/ASI had a "magic" tool to convert their side in rapid fashion; you may want to pull your configs off, munge them in a text editor, and then TFTP them back onto the router.

Otherwise, if I've misunderstood, please let us know what you're after.
0
 
LVL 8

Author Comment

by:kbratton1
ID: 16405432
I think we're on the right track.  I have a spare router that is identical to the online box, and I am getting two new ATM T1's installed to swing to.  I plan on copying the existing config to the spare and changing it to reflect the new config.  The two new ATM T1's will be bound together to make me a 3.0mb backbone, the existing backbone is a 1.5mb ATM.  I have a 4 port IMA card in each box to handle the interface.  How do the two circuits get set up to act as one in the router is what confuses me.  Never done that before and I can't find the info on Cosco web site.  I can get a Cisco guru in for $200 an hour, but that is the last choice since I have a spare router and time to get it right befor ecutting over, plus I can always go back to original circuit and router if all else fails, so I willing to try this myself with help from my friends.

Keith
0
 
LVL 12

Expert Comment

by:pjtemplin
ID: 16408827
Yep.  Assign the new T1 ports to ima-group X, then build your subinterfaces against ATMx/IMAX, and you should be good.
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 8

Author Comment

by:kbratton1
ID: 16439284
I'm not getting it.  Can I get a specific example of what to change/add in my config file posted above to try in my test router before I cut.  I understand what you are saying, but I don't know the syntax of the command to add to the config.
0
 
LVL 12

Accepted Solution

by:
pjtemplin earned 2000 total points
ID: 16439932
Reference snippet:

interface ATM1/0
 description connected to SBC FRATM  45.HCGJ.xxxxxx
 no ip address
 no atm ilmi-keepalive
 no scrambling-payload
!
interface ATM1/0.2 point-to-point
 description connected to City Center via ADSL RLAN  @ 1.5/1.5Mbps
 pvc 2/102
  encapsulation aal5snap
 !
 bridge-group 2
 bridge-group 2 spanning-disabled
!

Tasks:
Plug new T1 into atm1/1.  If you have two new ones, plug the second into atm1/2.

conf t
int atm1/1
 ima-group 1
!
int atm1/2
 ima-group 1
!

When the carrier says they're ready to move pvc 2/102 over:
no int atm1/0.2
!
int atm1/ima1.2 p
 description connected to City Center via ADSL RLAN  @ 1.5/1.5Mbps
 pvc 2/102
  encapsulation aal5snap
 !
 bridge-group 2
 bridge-group 2 spanning-disabled
!
0
 
LVL 8

Author Comment

by:kbratton1
ID: 16440356
Now I'm starting to see it!  I'll work on this later this week and early next week and post the new config from the spare router for you to look at.

Thanks!
0
 
LVL 8

Author Comment

by:kbratton1
ID: 16481108
I ended up with this config.  It makes telco happy, my router is happy, it actually worked earlier while testing with two small offices out on the WAN.  I'm now confident enough to cut the service without hiring the Cisco guru ($200/hr).  Thanks for the help!

config snippet --

interface ATM1/0
 description connected to ATT FRATM 45.YHGJ.xxxxxx.001.SUV
 ima-group 0
 no ip address
 no atm ilmi-keepalive
 no scrambling-payload
!
interface ATM1/1
description connected to ATT FRATM 45.YHGJ.xxxxxx.002.SUV
 ima-group 0
 no ip address
 no atm ilmi-keepalive
 no scrambling-payload
!
interface ATM1/IMA0
description connected to ATT FRATM IMA Group 0
 no ip address
 no atm ilmi-keepalive
!
interface ATM1/ima0.2 point-to-point
 description connected to City Center via ADSL RLAN @ 1.5/1.5Mbps
 pvc 2/102
  encapsulation aal5snap
 !
 bridge-group 2
 bridge-group 2 spanning-disabled
!
interface ATM1/ima0.3 point-to-point
 description connected to Northeast via ADSL RLAN @ 256/768Kbps
 pvc 6/100
  encapsulation aal5snap
 !
 bridge-group 3
 bridge-group 3 spanning-disabled
!
interface ATM1/ima0.4 point-to-point
 description connected to Arlington via ADSL RLAN @ 256/768K
bps
 pvc 2/104
  encapsulation aal5snap
 !
 bridge-group 4
 bridge-group 4 spanning-disabled
!
interface ATM1/ima0.5 point-to-point
 description connected to ML via FRS 45.HXGM.xxxxxx @ 128Kbps
 ip address 192.168.xxx.xxx 255.255.xxx.xxx
 pvc 3/105
  encapsulation aal5snap

...and so on through all the sub-if's.
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

There are two basic ways to configure a static route for Cisco IOS devices. I've written this article to highlight a case study comparing the configuration of a static route using the next-hop IP and the configuration of a static route using an outg…
Tired of waiting for your show or movie to load?  Are buffering issues a constant problem with your internet connection?  Check this article out to see if these simple adjustments are the solution for you.
Excel styles will make formatting consistent and let you apply and change formatting faster. In this tutorial, you'll learn how to use Excel's built-in styles, how to modify styles, and how to create your own. You'll also learn how to use your custo…
If you’ve ever visited a web page and noticed a cool font that you really liked the look of, but couldn’t figure out which font it was so that you could use it for your own work, then this video is for you! In this Micro Tutorial, you'll learn yo…

862 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question