[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 30788
  • Last Modified:

CISCO 871 - Problem to configure VLAN

I have a router CISCO 871 (4 fe ports and 1 wan port) and I want to configure new VLANs. I have this configuration in my router:
...
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface FastEthernet4
 description $FW_OUTSIDE$$ES_WAN$$ETH-WAN$
 no ip address
 no ip redirects
 no ip proxy-arp
 ip route-cache flow
 duplex auto
 speed auto
 pppoe enable
 pppoe-client dial-pool-number 1
!
interface Vlan1
 description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$$ES_LAN$$FW_INSIDE$
 ip address 192.168.0.1 255.255.255.0
 ip access-group 100 in
 no ip redirects
 no ip proxy-arp
 ip nat inside
 ip virtual-reassembly
 ip route-cache flow
 ip tcp adjust-mss 1452
!
interface Vlan2
 ip address 192.168.100.1 255.255.255.0
 no ip redirects
 no ip proxy-arp
 ip nat inside
 ip virtual-reassembly
 ip route-cache flow
 ip tcp adjust-mss 1452
!

...

When I try to configure VLAN2 to fe2 I receive the following error:

router(config)#interface fastEthernet 2
router(config-if)#switchport access vlan 2
%Access VLAN 2 does not exist. Please add it to vlan database


When I try to add the vlan to database I receive the following error:

router#vlan database
router(vlan)#vlan 2 state active
Vlan can not be added. Maximum number of 1 vlan(s) in the database.

or

router(vlan)#vlan 2 media ethernet name VLAN02
Vlan can not be added. Maximum number of 1 vlan(s) in the database.

The router CISCO 871 supports 4 VLANs and I don't know where I'm making the mistake!

This is another configuration I have in my router in vlan:


router(vlan)#sh
  VLAN ISL Id: 1
    Name: default
    Media Type: Ethernet
    VLAN 802.10 Id: 100001
    State: Operational
    MTU: 1500
    Translational Bridged VLAN: 1002
    Translational Bridged VLAN: 1003

  VLAN ISL Id: 1002
    Name: fddi-default
    Media Type: FDDI
    VLAN 802.10 Id: 101002
    State: Operational
    MTU: 1500
    Bridge Type: SRB
    Translational Bridged VLAN: 1
    Translational Bridged VLAN: 1003

  VLAN ISL Id: 1003
    Name: token-ring-default
    Media Type: Token Ring
    VLAN 802.10 Id: 101003
    State: Operational
    MTU: 1500
    Bridge Type: SRB
    Ring Number: 0
    Bridge Number: 1
    Parent VLAN: 1005
    Maximum ARE Hop Count: 7
    Maximum STE Hop Count: 7
    Backup CRF Mode: Disabled
    Translational Bridged VLAN: 1
    Translational Bridged VLAN: 1002

  VLAN ISL Id: 1004
    Name: fddinet-default
    Media Type: FDDI Net
    VLAN 802.10 Id: 101004
    State: Operational
    MTU: 1500
    Bridge Type: SRB
    Bridge Number: 1
    STP Type: IBM

  VLAN ISL Id: 1005
    Name: trnet-default
    Media Type: Token Ring Net
    VLAN 802.10 Id: 101005
    State: Operational
    MTU: 1500
    Bridge Type: SRB
    Bridge Number: 1
    STP Type: IBM

I need some help, please!
0
rafaeldemartin
Asked:
rafaeldemartin
  • 5
  • 4
  • 2
  • +5
1 Solution
 
mikebernhardtCommented:
Just for fun, try it this way
config t
vlan 2
end
0
 
rafaeldemartinAuthor Commented:
No, it doesn't work.

router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
router(config)#vlan 2
                            ^
% Invalid input detected at '^' marker.

router(config)#

or

router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
router(config)#vlan2
                           ^
% Invalid input detected at '^' marker.

router(config)#
0
 
mikebernhardtCommented:
Did you enter the command "switchport" before you tried to add the vlan? Just a thought, I'm grabbing at straws here...

config t
int fa2
 switchport
 switchport access vlan 2
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
mikebernhardtCommented:
Ohh... did you create a vtp domain? You need to do that before you can create multiple vlans.
0
 
rafaeldemartinAuthor Commented:
I've tried

config t
int fa2
 switchport
 switchport access vlan 2

 but it did'n work. And I didn't create a vtp domain... How do I do that? Why do I need to create a vtp domain before I can create multiple vlans?
0
 
mikebernhardtCommented:
You definitely do on most switches, so that may be the problem for you:
vlan database
 vtp domain [name]
 vtp transparent [so it doesn't listen to other vtp packets]

Then try creating the vlan while you're in there.
0
 
FrabbleCommented:
From what I understand, you can't add VLANs, they're pre-defined and their assignment to the switch ports is automatic if the VLAN interface has an IP address and is up.

For instance, all switch ports fa0 - 3 will be VLAN 1 if interface Vlan1 is active.
If Vlan2 is active, one of the switch ports will be VLAN 2. If it's similar to what I've come across before then it's probably the last port fa3. This is their "DMZ" feature.

While 4 VLANs are supported, you'll only get them with the Advanced IP Services firmware and not the default Advanced Security.
I guess their assignment will be similar to the above and to each switch port.
0
 
rafaeldemartinAuthor Commented:
It doesn't work, not even configuring vtp. It's always the same problem:

"Vlan can not be added. Maximum number of 1 vlan(s) in the database."


So, if I want to create another vlans I must change the default firmware Advanced Security with Advanced IP Services ? Do I have to buy it from CISCO? Or can I download it for free?
0
 
mikebernhardtCommented:
Well, Frabble could be correct, I'm very familiar with IOS and Vlan cnfiguration, but not with that particular piece of hardware. If he's correct then you'll have to buy the new software- it definitely won't be free.
0
 
rafaeldemartinAuthor Commented:
Thanks very much for your help!
0
 
FrabbleCommented:
No problem, unfortunate that you'll have to upgrade get more VLANs. To see what you get look at Table 5 at:
http://www.cisco.com/en/US/products/hw/routers/ps380/products_data_sheet0900aecd8028a976.html

It won't be free and you'll also have to get an extra 4 MB of flash for the larger IOS image.
0
 
wgoodfellowCommented:
Just for clarification (came across this thread by accident).  
The problem is not having the advanced ip services ios.  The 871 can only use the native vlan (vlan1), and you cannot create more without the advanced ip services IOS.
0
 
marksarriaCommented:
try
switchport mode access
switchport access vlan 2
0
 
usere3Commented:
faced the same problem... unless You have the advanced IP services ( advanced security will not work) you will be stuck with vlan1
0
 
pcrequestCommented:
Assign IP address on the VLAN instead of the layer 2 switch ports.

http://www.cisco-tips.com/cisco-router-851-871-interfaces-and-basic-configuration/
0
 
Encrypted1024Commented:
I actually found the answer to this today if any one cares. Assuming you have AdvIPServices you can not ping a VLAN interface unless it is assigned to a switchport and the switchport is UP. Meaning you have a cable plugged into it.
0

Featured Post

New feature and membership benefit!

New feature! Upgrade and increase expert visibility of your issues with Priority Questions.

  • 5
  • 4
  • 2
  • +5
Tackle projects and never again get stuck behind a technical roadblock.
Join Now