disconnected drive mapping - using net config server /autodisconnect:-1 to resolve

I am trying to resolve an issue where my XP clients show a mapped drive as disconnected, but it actually connected.  I did some reading and found a post that directed me to the autodisconnect setting on my Windows Server 2003

I set the disconnect to -1 as above and want to know how I can be sure it is set?  If I look in the registry I see a value of 0xffffffff

Is that right?
victoriatechAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Jay_Jay70Commented:
Hi victoriatech,

what is the key that you changed?

i have seen exact same problem in 2003 server

Cheers!
0
victoriatechAuthor Commented:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\lanmanserver\parameters

0
Jay_Jay70Commented:
victoriatech,

i cannot set a -1 parameter on my machine, where did you read this? mine is set to 0x0000000F and has a decimal value of 15
0
Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

victoriatechAuthor Commented:
use the command (from a command prompt
net config server /autodisconnect:-1
which disables autodisconnect and that stopped the remote users from loosing their Mapped Drive.

http://support.microsoft.com/default.aspx?scid=kb;en-us;Q297684

0
Craig_200XCommented:
This is a feature of Win2000/03, XP where you can set the timeout period or disable it completely. You can use regedit or the command line. Command line is better when using the -1 to disable auto disconnect.

Use Registry Editor to increase the default time-out period. To do this, follow these steps, and then quit Registry Editor: 1. Click Start, click Run, type regedit (Windows 2000 or Windows Server 2003) or type regedt32 (Windows NT 4.0), and then click OK.  
2. Locate and then click the following key in the registry:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\lanmanserver\parameters
3. In the right pane, click the autodisconnect value, and then on the Edit menu, click Modify. If the autodisconnect value does not exist, follow these steps: a.  On the Edit menu, point to New, and then click REG_DWORD.
b.  Type autodisconnect, and then press ENTER.  
 
4. Click Hexadecimal.
5. In the Value data box, type ffffffff, and then click OK.  

Command Line
NOTE: If you use this method, you may turn off the autotuning feature for the Server service.

To change the default time-out period for the autodisconnect feature of the Server service, open a command prompt, type the following line, and then press ENTER
net config server /autodisconnect:number
where number is the number of minutes that you want the server to wait before it disconnects a mapped network drive. The maximum value for this command is 65,535.

NOTE: If you set the autodisconnect value to 0 (zero), the autodisconnect feature is not turned off, and the Server service disconnects mapped network drives after only a few seconds of idle time.

To turn off the autodisconnect feature, open a command prompt, type the following line, and then press ENTER:
net config server /autodisconnect:-1
0
Jay_Jay70Commented:
just check your decimal value on that key    it should be some ridiculously large figure and if so then yes its working   i would set to 0 though and just turn it off
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
victoriatechAuthor Commented:
I do have the ridiculously large number.

0 does not turn it off though, 1 does.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Networking

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.