Where can I find libata-core.c?

Hello,
I recently purchased an I-Ram, and want to get it working with linux. In order to do this I have read that I have to make a change to the libata-core.c source file for the kernel and rebuild it. I am a fairly experienced programmer, but have never toyed with the linux kernel and am pretty new to linux itself. My current issue is I cannot find the libata-core.c file at all. I have looked in /usr/src/kernels/scsi/ where according to what I read is where it should be, but it isnt... all I find are a few folders with nothing but makefiles and some other basic config files. What am I missing here? Yum reports that I already have the smp-devel kit installed.

Correct Answer worth 500 points.

Thanks,
Rick
richardsimnettAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

richardsimnettAuthor Commented:
PS - I have also done a drive wide search and yielded nothing.

Thanks,
Rick
0
sheetbirdCommented:
It kind of sounds like your kernel-source package isn't installed. Although it would seem it would need to be there as a prereq for smp-devel.

What does "yum search kernel" come back with?  

So if kernel-source isn't in there than obviously run "yum install kernel-source"

0
kiffneyCommented:
the kernel sources will usually be (on redhat, which is what I guess you're running) /usr/src/redhat

Go to that directory and try

find . | grep -i libata

and see if you can locate it.

If the kernel sources aren't really installed, you can do

# up2date --get-source kernel

or install them from the cds if you have them.
0
Cloud Class® Course: C++ 11 Fundamentals

This course will introduce you to C++ 11 and teach you about syntax fundamentals.

richardsimnettAuthor Commented:
sheetbird,
yum search kernel results in a ton of hearders being thrown at me installed, however, none of them are the kernel source.

When I run yum install kernel-source I get:  no match for argument kernel-source

Thanks,
Rick
0
richardsimnettAuthor Commented:
kittney,
I tried to isntall the kernel via up2date like you specified and this is what I got:

kernel-2.6.9-34.EL.src.rpm...
An error has occurred:

An HTTP error occurred:
URL: http://mirror.centos.org/centos/4/os/i386//SRPMS/kernel-2.6.9-34.EL.src.rpmStatus Code: 404
Error Message: Not Found

0
kiffneyCommented:
looks like the mirror is down or something wrong with your repository files (I think it's /etc/repos?)

try going to

http://mirrors.kernel.org/centos/4/os/SRPMS/kernel-2.6.9-34.EL.src.rpm

and get that file and install it with
rpm -i kernel-2.6.9-34.EL.src.rpm
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Duncan RoeSoftware DeveloperCommented:
The fiole certainly exists in recent kernels:

$ locate libata-core.c
/usr/src/linux-2.6.12.2/drivers/scsi/libata-core.c
/usr/src/linux-2.6.8.1/drivers/scsi/libata-core.c
/usr/src/linux-2.6.15/drivers/scsi/libata-core.c

I just ftp kernels from a local mirror of kernel.org. Latest is linux-2.6.16.2.tar.bz2
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux OS Dev

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.