• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1048
  • Last Modified:

Died on Signal 13

Hi,

I have a korn shell script on a HP UNIX box. This script tries to FTP (GET) files from various other boxes. So basically ...
a. It connects to a system
b. GETs the file
c. Closes the connection
d. does other stuff ... which I dont think is important here.

Steps a-d are repeated several times.

Everytime an FTP connection is established, " ident/tcp: Died on signal 13" error is recorded in the syslog.

When I do this manually though, from a command prompt it works fine. No error in the syslog.

I thought this could be a congestion problem and tried using "sleep 120" between calls. But that didnt work. Same error was recorded in the syslog.

Can anyone help me fix this problem. My SA gets paged everytime I run this from the CRON and he isn't exactly happy.:-(

Thanks
0
suhas_jain
Asked:
suhas_jain
  • 2
  • 2
  • 2
  • +2
1 Solution
 
gheistCommented:
#define SIGPIPE         13      /* write on a pipe with no one to read it */
0
 
ahoffmannCommented:
please post the script if gheist's hint isn't sufficient
0
 
suhas_jainAuthor Commented:

I was googling for a solution and found one in the HP Unix forum. The suggestion was to comment out IDENTD entry in the inetd.conf file. It seems to work perfectly fine. But my SA didn't  like this solution much.


Gheist - I've to confess, I'm not sure what you are hinting at. Please can you explain in detail.

Also NOW, I see this error even when I FTP from the command prompt. So it's not the script that's the problem. For some reason I didnt see the error from command prompt when I first posted my question. I apologize for that.


AHoffman - Here is the script.

function get_Files
{

print "\nIP ADDRESS=$IP_ADD\nSYSTEM=$SYS_ID\nREGION ID=$REG_ID\n"

ftp -nvi <<-EOFFTP
open $IP_ADD
quote user ${FTP_USER}
quote pass ${FTP_PASS}
cd ../reports
cd SQI
lcd $TMP_DIR
get indexes indexes.$SYS_ID.$REG_ID.$YEAR.$MONTH.$DAY
close
bye
EOFFTP

}

This function is called multiple times by the main script in a loop.
0
Cloud Class® Course: Certified Penetration Testing

This CPTE Certified Penetration Testing Engineer course covers everything you need to know about becoming a Certified Penetration Testing Engineer. Career Path: Professional roles include Ethical Hackers, Security Consultants, System Administrators, and Chief Security Officers.

 
ahoffmannCommented:
sounds like your ftp client uses ident to check the user name, this is probably caused by the -n option (if it is an ncftp)
Check your manuals how that works.
0
 
suhas_jainAuthor Commented:
Not sure if -n is the problem. Because when I ftp from the command prompt even with no options used just a simple "ftp ip_add" causes this error.

More I look into various forums, I'm convinced this is a know issue with the HP Unix 11.00 and 11.11 boxes. The only fix for now I guess is commenting out the IDENTD entry.

I'll see if I'm able to convince my SA to install a suggested patch for this problem (phne_24419). Hope that helps.

Thank you gheist and ahoffman for trying.
0
 
NopiusCommented:
ahoffnam, ftp server, not client asks for identd reply after each connection.
suhas_jain, yes, comment indent line, it's quiet obsolete and unreliable protocol.

As for me, it's still not clear why this works from manual run and doesn't work from script.
0
 
gheistCommented:
ident is useful on multiuser machines to punish guilty. nothing more.
0
 
GranModCommented:
PAQed with points refunded (200)

GranMod
Community Support Moderator
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Introducing Cloud Class® training courses

Tech changes fast. You can learn faster. That’s why we’re bringing professional training courses to Experts Exchange. With a subscription, you can access all the Cloud Class® courses to expand your education, prep for certifications, and get top-notch instructions.

  • 2
  • 2
  • 2
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now