IRQ Conflicts in a Toshiba Satellite L25-S1216

My hard drive died two weeks after I bought this laptop.  Best Buy replaced it with a new 60 GB Hitachi drive.  Since I had a new blank drive I thought this would be a good time to upgrade my laptop from XP Home to Pro.  Everything seemed to go well except my NICs (wired and wireless) weren't working.  The Realtek NIC gave a code 12 error: not enough resources.  Seems like an IRQ conflict.  Eight items are mapped as IRQ 11.  If I disable the PCMCIA controller and sound card both NICs start working again.  I've tried uninstalling and reinstalling sound/PCMCIA (and everything else but NICS) and adding them back but once all are added I lose network connections.  Toshiba helpdesk was not so helpful (I didn't tell them I was upgrading to XP Pro).  There suggestion was to disable ACPI and manually configure the two devices to another IRQ.  Anyone know another way around this?  Not sure I want to go that route.  Tech didn't seem to know too much about it and I've googled this problem up and down without too much enlightment.

Other items on IRQ 11:
Atheros AR5005G Wireless Network Adapter
AC97 Data Fax SoftModem with SmartCP
ATI RADEON XPRESS 200M series
Realtek RTL8139/810x Family Fast Ethernet NIC
Standard Enhanced PCI to USB Host Controller
Standard OpenHCD USB Host Controller
Standard OpenHCD USB Host Controller

All drivers are latest on Toshiba website.  Realtek NIC was also loaded with latest from Realtek site v6.39 but didn't help.
LVL 1
clbiiiAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

MarkCommented:
Disabling ACPI would be the worst thing to do as it is the heart of most laptops ability to manage power resources, especially when on battery. Is the ability to allocate resources manually in the device manager greyed out for the NICS? If they are available try and change the IRQ  settings from there.
clbiiiAuthor Commented:
They are greyed out.
nobusCommented:
did you install all the motherboard drivers?
Amazon Web Services

Are you thinking about creating an Amazon Web Services account for your business? Not sure where to start? In this course you’ll get an overview of the history of AWS and take a tour of their user interface.

MarkCommented:
Have you upgraded the XP pro to service pack 2. It seems that on the toshiba driver download page, they don't offer the realtek driver in the XP downloads but do in the XP SP2 downloads.
clbiiiAuthor Commented:
Completely up to date on XP patches and Hotfixes.  Installed all motherboard drivers from toshiba website, plus went to realtek's site and downloaded latest generic driver for NIC from there site after I had problems and the toshiba driver didn't seem to help.
clbiiiAuthor Commented:
After uninstalling all drivers and all hardware and then reinstalling everything but starting with the two NICs and followed by chipset and then all other items I don't get an "out of resources" error but NICs both don't work correctly.  Won't pick up DHCP or browse traffic if configured manually.  Seriously considering giving up and using their recovery disk and just uninstalling all the JUNK they load on the computer.  Would rather have PRO as I have a server in the house and would like to do a domain, plus logging on at work requires a domain.
clbiiiAuthor Commented:
I threw my old harddrive back in to see how everything was set up and it is majorly different.
IRQ settings for factory install
17 Radeon video
17 Audio
19 usb
19 usb
19 PCI to USB
20 PCMCIA
21 Realtek NIC
22 Wireless NIC

Anyone know how I can force these IRQ settings on my XP Pro setup?
nobusCommented:
For some devices you can change the IRQ setting in device manager, by right clcicking the devices, selecting properties, and sources, then select the IRQ and input a new one, or select a manual setting.
But not all devices allow it
MarkCommented:
When you installed the XP pro did you download and install the appropriate Toshiba Utilities programs. Without these you may not have total control over the way XP allocates resources on the laptop, or the laptops ability to identify and install hardware properly.
clbiiiAuthor Commented:
I've installed every Utility listed under this model at Toshiba's website.  No dice.  I'm considering just ghosting my old disk to the new and clean up default installs and sticking with XP Home.  
clbiiiAuthor Commented:
Ok, here's what fixed the problem:  I ran the XP setup and chose Repair (not the repair console) and this seemed to fix the problem.  I have to reload SP2 but so far everything is similar to what it was under Home.  Thanks for the suggestions.
GranModCommented:
Closed, 125 points refunded.
GranMod
The Experts Exchange
Community Support Moderator of all Ages

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Laptops Notebooks

From novice to tech pro — start learning today.