?
Solved

Exchange 2003 Log files Non Delivered Report NDR

Posted on 2006-04-07
8
Medium Priority
?
1,230 Views
Last Modified: 2012-05-05
Ok.  So I know where the Exchange log files reside.  And this question is most likely a multiple question.

The log file in the Exchsvr? folder w/the date formats....I open and can read them properly.

My NDR is set to not send out ->
I’ve been investigating into the NDR returns the users receive when they emails are rejected.  And the odd things is, although it’s an auto enabled feature it has been turned off. So, I don’t quite know how user's are receiving a bounce reply.  If users were to receive the rejected/bounced emails then the “Allow non-delivery reports” would be enabled.

I've now set myself up to be the one to receive the NDR reports and have set a role so it doesn't interfere w/anything, it'll just have to be monitored.

Also, want to add we are running GFI Essentials, and I've heard throughout this forum it's not the best, unfortunately we're stuck w/it.

When I set the NDR's to be sent to by inbox to a certain folder, it has the error code, the subject the receiver and some additional information, but it does not show me the sender.  It shows the sender as System Administrator.  Is there anyway, to add the sender of the message into the NDR file?

AnD also, even though the NDRs are turned off for the user's they still receive them.
0
Comment
Question by:mdmcq5
  • 5
  • 3
8 Comments
 
LVL 23

Expert Comment

by:TheCleaner
ID: 16407899
The NDR's sender will be the Postmaster/sys admin...that is by design...it's not joe@domain.com that generates the NDR, even if the email was destined for joe originally.

Where did you turn NDR's off?  In Exchange system admin or in GFI?  Can you tell me the exact thing you turned off?
0
 

Author Comment

by:mdmcq5
ID: 16407935
i went into system manager, highlighted Internet Message Formats, right clicked on Default, the Properties page came up and at the bottom the "Allow non-delivery reports" is not checked.

I've looked through GFI, and it appears the only options set are the white and black lists, everything else says "not enabled" so there must not be an NDR setting in there, if there is, I can't locate it.

And do you know if there's a way to determine who the original sender is of the NDR message?  Or is my only obtion to Message Track the 'Subject' in System Manager?

The IT dept wants to monitor these, we don't want the user's receiving them.  
0
 
LVL 23

Expert Comment

by:TheCleaner
ID: 16413553
The original sender of the NDR message will be either your mail system (Exchange) or an external mail system.  It won't be an individual.

Are you trying to prevent NDR's your Exchange system is sending out to external users or internal users?  You WON'T be able to prevent other mail systems from sending out NDRs.
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 

Author Comment

by:mdmcq5
ID: 16413995
The way it is currently setup by our Security Admin is for neither internal or external to receive the NDRs, espeically external if they're just spammers.

And since the NDR setting is turned of in System Manager, any clue why an internal user received an NDR?
0
 
LVL 23

Expert Comment

by:TheCleaner
ID: 16416922
Internal users will still receive an NDR from external postmasters.  Check the "from" address in the headers to see if that's the case.
0
 

Author Comment

by:mdmcq5
ID: 16423425
Well internal users receive the NDRs, even though the checkbox is empty? Does that mean 'External' senders will not recieve the response it is a wrong email address?
0
 
LVL 23

Accepted Solution

by:
TheCleaner earned 2000 total points
ID: 16427698
Correct.

You are basically controlling what your mail server is doing with it's own NDR's, whether it is sending an internal NDR because a user tried to send something over the size restrictions, or an external user is getting an NDR from you because they are trying to send something to you over the size restrictions (or whatever).

You aren't saying "nobody in my organization should receive an NDR, ever", because you cannot control what other mail systems send out.  Now you can "filter" who receives copies of those NDRs from the outside.  MS recommends you setup a postmaster address and then if needed have NDRs go to that address, as opposed to the user.

See this KB article.
http://support.microsoft.com/default.aspx?scid=kb;en-us;294757

0
 
LVL 23

Expert Comment

by:TheCleaner
ID: 16440773
Thanks for the points!
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I guess it is not common knowledge to most Wintel engineers/administrators: If you have an SNMP-based monitoring system in your environment (and it's common to have SNMP or Syslog) it's reasonably easy to enable monitoring of the Windows Event logs,…
Setting up a Microsoft WSUS update system is free relatively speaking if you have hard disk space and processor capacity.   However, WSUS can be a blessing and a curse. For example, there is nothing worse than approving updates and they just have…
Loops Section Overview
Screencast - Getting to Know the Pipeline

807 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question