Can not forward port 21 using Linksys WRT54G for Remote Administration

Hello all,

Thank you in advance for any help you all can provide.

My issue is that I have recently upgraded to a Linksys WRT54G router (having the latest firmware installed) from an old Linksys 802.11b wireless router. On the network I currently have two wireless devices (one PC, one iPaq) and a wired (Cat5) "server". I use a program entitled "Remote Administrator v2.1" to connect remotely from work to my home PC. This application uses port 4899 in order to communicate. As a forward, please do not suggest other applications as this does everything I need it to do and more.

The issue I have is that the proxy server at work only allows traffic on port 21 (or FTP) to establish a tunnel of any kind. So, previously I told my old router that any traffic coming in on port 21 simply forward to port 4899 using IP 192.168.1.100 (servers’ static address). This worked great with no issues.

Now with this new router, I am doing the exact same forwarding routine but I can not establish a connection to port 4899 on 192.168.1.100. I believe it is because the router believes this is an FTP connection and is treating it as such (not forwarding).

Can anyone lend any suggestions on how I can tell this new router to forget about FTP and to use port 21 as a gateway to port 4899?

Many thanks,
HuBBie

P.S. - Anyone using a Linksys 802.11b router should definitely pickup a WRT54G. Other than this little issue, it is a beautiful (and reliable) device.  

HuBBie36Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

masnrockCommented:
Did you turn on any of the virtual servers? Make sure they're all off, especially the FTP one.. might even need to delete them, but turning them off should be sufficient.
0
HuBBie36Author Commented:
Thanks for your comment masnrock.

I can not see any "Virtual Server" options within the router settings. The only mention of the FTP service is under a heading "Access Restrictions" which enables me to set Access Policies. Here I have the ability to Block FTP however this will ban any traffic on port 21 and will kill it at the router. Again, it will not be forwarded.

I can not see a "disable" option anywhere...

Regards,
HuBBie
0
HuBBie36Author Commented:
Hey all,

You won't believe it but after some research, I was able to set my "Remote Administrator v2.1"'s port to 21 and bang, it worked fine.

Regards,
HuBBie
0
HuBBie36Author Commented:
Thank you GranMod
0
GranModCommented:
Closed, 250 points refunded.
GranMod
The Experts Exchange
Community Support Moderator of all Ages
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Networking Protocols

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.