Can not forward port 21 using Linksys WRT54G for Remote Administration

Posted on 2006-04-08
Last Modified: 2013-11-29
Hello all,

Thank you in advance for any help you all can provide.

My issue is that I have recently upgraded to a Linksys WRT54G router (having the latest firmware installed) from an old Linksys 802.11b wireless router. On the network I currently have two wireless devices (one PC, one iPaq) and a wired (Cat5) "server". I use a program entitled "Remote Administrator v2.1" to connect remotely from work to my home PC. This application uses port 4899 in order to communicate. As a forward, please do not suggest other applications as this does everything I need it to do and more.

The issue I have is that the proxy server at work only allows traffic on port 21 (or FTP) to establish a tunnel of any kind. So, previously I told my old router that any traffic coming in on port 21 simply forward to port 4899 using IP (servers’ static address). This worked great with no issues.

Now with this new router, I am doing the exact same forwarding routine but I can not establish a connection to port 4899 on I believe it is because the router believes this is an FTP connection and is treating it as such (not forwarding).

Can anyone lend any suggestions on how I can tell this new router to forget about FTP and to use port 21 as a gateway to port 4899?

Many thanks,

P.S. - Anyone using a Linksys 802.11b router should definitely pickup a WRT54G. Other than this little issue, it is a beautiful (and reliable) device.  

Question by:HuBBie36
    LVL 17

    Expert Comment

    Did you turn on any of the virtual servers? Make sure they're all off, especially the FTP one.. might even need to delete them, but turning them off should be sufficient.

    Author Comment

    Thanks for your comment masnrock.

    I can not see any "Virtual Server" options within the router settings. The only mention of the FTP service is under a heading "Access Restrictions" which enables me to set Access Policies. Here I have the ability to Block FTP however this will ban any traffic on port 21 and will kill it at the router. Again, it will not be forwarded.

    I can not see a "disable" option anywhere...


    Author Comment

    Hey all,

    You won't believe it but after some research, I was able to set my "Remote Administrator v2.1"'s port to 21 and bang, it worked fine.


    Author Comment

    Thank you GranMod

    Accepted Solution

    Closed, 250 points refunded.
    The Experts Exchange
    Community Support Moderator of all Ages

    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    How to run any project with ease

    Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
    - Combine task lists, docs, spreadsheets, and chat in one
    - View and edit from mobile/offline
    - Cut down on emails

    The article explains the protocols and technology which is involved when two computers on different TCP/IP networks communicate with each other. In the diagram, a router is used to segregate two networks. The networks are and 192…
    Join Greg Farro and Ethan Banks from Packet Pushers ( and Greg Ross from Paessler ( for a discussion about smart network …
    After creating this article (, I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
    After creating this article (, I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

    760 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    7 Experts available now in Live!

    Get 1:1 Help Now